DW822A+ and external Oxf. 911 - any chances?

vbimport

#1

Hi everyone,

great forum - already learned a lot so far :slight_smile:

Anyway, here is my question:

After reading a lot about problems with BenQ drives in external enclosures I deceided to buy the LiteOn SOHW 832 instead - until I saw the DW822A+ retail for 85,- Euro at a local store - can’t go wrong with that offer!

The external encloser (USB2+Firewire) with Oxford911 chipset will arrive in a few days - if I can’t get it to work with the BenQ I’ll just send the enclosure back, although I would prefer using the BenQ externally. Any tips/solutions/warnings on what to do and what not to do to get it working?

TIA,
Dembo


#2

If You buy a 822+ these days it will have B3HC installed. So you would easily see wether it works with this firmware. also as much as i know its not possible to go back to b3bc.

Conclusion: make sure to handle the “The external encloser (USB2+Firewire) with Oxford911 chipset” with care, so that you can return it if it doesnt work fine.

I personally would put the 822 on ide for upgrading firmware. just to be on the safe side.


#3

okay… I’ll keep my fingers crossed then - still, it is hard to beleive that BenQ is stupid enough to skrew up their firmware…

BTW I noticed that it didn’t say Dual Layer Upgradable on the 822U (or whatever the name of the external BenQ drive is) - does it really contain a 822A?


#4

I’m the original poster of External PROBLEMS with the BenQ DW822A drive. I have got it to work in both USB & 1394 modes. The ChipSet is Prolific PL-3507(04133C) installed in a Plumax Case. On SALE at Dealtronics.com. You can go back to B3BC with a special Firmware install that doesn’t check installed versions.

BenQ USA can’t help with anything. BenQ Global states the drive is only sold as internal. When you ask they about their external units - they say not available in your country. Will all the BULL S#@T from BenQ, returned drive and got a LiteOn 832S. No problem with this unit with any ChipSet in USB mode. And I know that Oxford and Prolific work in 1394 mode.

I might go back to BenQ when their 1630 16X unit comes out, but only after knowing all the external issues have been corrected. Like I stated in the past, many long time BenQ/Philp users wrote me telling me this has been an issue with BenQ for a very very long time…


#5

Why not buying the EW822U?
http://www.benq.de/Products/DVDRewriter/index.cfm?product=422
It is already an external solution.


#6

I dont beleive there are any issues with the oxford chipset and the 822A i think it was a different chipset. i have mine external not having issues upgrading fw or burning i think i have a oxford.


#7

i have an ext. usb/firewire case with Prolific PL-3507 chipset and no problems here either, with none of the firmwares.
So Profilic chipset should be okay too.

cdpower


#8

My usb/firewire enclosure with Profilic PL-3507 chipset do NOT work! (it’s an E-Magic: http://www.emagictech.com.tw/fd6523-1.htm )

But my usb/firewire enclosure using an ALi chipset works fine with the BenQ DW822A.

Using firmware B3IC


#9

Hello,

To give some feedback so there will be more info on using the BenQ in external enclosures.

The enclosure I used was a Titan TT-335U2F with an Ali chipset for USB and an Oxford 911 chipset for firewire. Out of the box it worked fine (b3hc firmware) and with the b3ic firmware it also worked fine. Upgraded firmware through firewire.

One caveat though I didn’t fully test USB, since I have an old laptop that only has a USB 1.1 port, all I did was make sure the drive was visible and that I could read from it.


#10

@ageha: I thought about the EW822U but then again: I didn’t say anything about the Dual Layer upgrade on the EW822U and I didn’t find any reliable informations whether BenQ build a 822A in it or just relabled an 800A. In addition I am slightly leaning towards firewire instead of USB2 (the drive might connected to an old P3@1200 from time to time).

@Jamos/blacktea: That is the post I’ve been waiting for all the time :slight_smile: Thank you, there is light at the end of the tunnel… :wink:

@OC-Freak: That is the post I’ve not been waiting for - things working some time and not working another time aren’t what I am looking forward to…

Anyway, the case will arrive pretty soon. I keep my fingers crossed, blacktea and Jamos in mind and I will report on any success and/or failure.

Bye and thanks for the help so far!


#11

OK Guys & Girls,

:iagree: Profilic PL-3507(04133C) FirmWare LOAD :iagree:

Just received and installed last night. Corrected all my problems completely with Firewire on WinXP/Pro SP2 and a BenQ DW822A in a Plumax Case.

The original firmware load from Argosy (hde360c) is version 03.10.29.001 .

The firmware I received from the emagic manufacturer late last night is version 04.04.22.009 with a late April 2004 date. Like I said this one fixed ALL my Firewire problems. The hde360c is alot older and only corrected about half of my issues.

If anyone would like a copy please send me a EMail at beach-hobo@earthlink.net.

Regards,


#12

It’s too big to upload it here, right?!
Or do you think there are legal issues when uploading it here?
(Me, I don’t need it personally, I use it as internal.)


#13

Yes, on both Issues…


#14

ehm just another - preliminary - success story:

Bought a DW822A+ and put it into a Oxford911(1394) / Genesys(USB2) enclosure. Checked the USB2 connection yesterday by burning a CD-R @ 24x and a DVD+R at 4x (Verbatim, didn’t have any 8x lying around). DVD+R plays on BenQ, Pioneer, Toshiba and dirt cheap standalone from amazon.

The results: Success! Absolutely no problems - drive recognized by WinXP and by Nero, burned right away. Firmware is the ‘H’ flavour (at least I think so…).

Slight drawback: No PI/PO scan with Nero CD/DVD Speed :Z at least via USB2 - will try Firewire tonight.

And one question to the community: I did set the speed in Nero to 4x - does the 822A+ care at all or does it set the burn speed to whatever it likes?


#15

I bet the Verbatin discs are “MCC 002” media code. With this media the DW822A+ will burn at 8x wit no problems.

I could run Nero PO/PI test via a USB connection. The speed is very slow, somewhere around 1.5X and takes over an hour to run. The ball has been passed to BenQ because it’s a firmware limitation they have to fix.

Here’s another issue I discovered, USB can work with all the other programs on your system but fail in CDSpeed.


#16

hmmm, very slow… That might be a reason… I just stared at the screen, waited for 20 or so seconds (hey, it’s a brand new burner after all :bigsmile: ) and nothing happend. Maybe I just have to wait a little longer.

I am still not sure whether IEEE1394 is handled by an Oxford911 or by the GeneSys chip. Trying to find out whether they sent me the wrong enclosure (with the help of the seller, so no complains there…).


#17

Okay, here are the final results of my external enclosure odyssey:

Although I ordered an Oxford911 enclosure they first sent me one with a GeneSys711 combi chipset (the shop did swap it very fast and at no costs for me - two thumbs up!). Put the 822A+ with B3HC in it and it did work out of the box via USB2 and Firewire. :bigsmile:

Yesterday the Oxford911 arrived - USB2 still worked fine (GeneSys or Cypress, dunno) but Firewire didn’t (drive not recognized by WinXP) - arrrrgh :frowning:

So I thought, wtf and started flashing the Oxford firmware (I know it is dangerous) to version 3.8 - still no go and then played around with the Oxford settings (6s delay, recognize non-standard devices, etc.). Good news: Didn’t screw up the enclosure but still no drive recognized via Firewire (I did recognize an old HDD just fine btw).

Next thing on my list was the BenQ firmware. I flashed B3EC (I think) which I got from a webpage posted here somewhere. I did warn me about the downgrade but flashed just fine. I did flash via USB2 because I was somewhat pissed at BenQ anyway :wink:
After a reboot the drive was recognized via USB2 and Firewire. :bigsmile:

I was still in experiment mode so I flashed the original B3IC which I downloaded directly from BenQ and to make sure I end up with a ruined drive I flashed it via Firewire g. Well, to my big surprise after the reboot the drive was recognized via USB2 and Firewire. Amazing!

Summary: GeneSys711 worked out of the box for me, Oxford911 worked after some weired flashing and I am happy - excellent burner, excellent enclosure, long story though :wink:


#18

Hi,

I’m gonna buy a DW822A… But what is DW822A+? is it a better version or just a DW822A with newer firmware?

Thanks,


#19

DW822A = Firmware Version B3BC
DW822A+ = Firmware Version B3HC (8x DVD-R Support)

Otherwise same drive…


#20

ok thanks a lot beach-hobo.