DW1670 won't let me burn discs

I’ve tried burning disks using both Nero 6 and Alcohol 120, and both seem to hang during the burn process; my computer also shut off when I tried to burn with Alcohol, after a few minutes, and it’s never done that before.

I thought it might be something wrong in the firmware, so I tried to flash it to version 103, but both gave me the error, “The drive is not allowed to be updated.”
I also tried with the 102 firmware I found on this forum, with the same result.

I tried flashing with BQFlasher, but it wouldn’t load either the 102 or the 103 firmware .exe files.

I’ve replaced cables, and I can read from the drive okay… it’s identified as an ATAPI DVD DC 16X8X5 in the device manager. There is something weird about the device instance ID, though – it’s got tons of underscores in it, something like:
IDE\CDROMATAPI_DVD_DC_16X8X5_________________________100_______\5&15E97DEB&0.0.0

It might be worth noting that I had Starfire on my system (I’m not sure how it got there, but it was present), and I couldn’t use the drive AT ALL, before I removed it… now I can read from the drive, okay, but I can’t write with it at all – when I took the blank DVD+R out of the drive after my computer shut down, it had been written to a little bit, but it was only about 2/3 full (from looking at the discoloration where the burn had occurred).

Anyway, this is totally kicking my butt; anyone got some advice on how to fix it?

You need to use MCSE (Media Code Speed Edit) to modify the 1.03 firmware to be flashed to your ‘Atapi’ labeled drive - your drive is an OEM drive sold under another brand.

This may have no effect on your burning problems, but I’d still give it a try.

Two things:

First, now burning does “work”, but my computer abruptly powers off (not blue screen, not restart, but bam power off), about half way through a burn. This happened twice, and the second time, I couldn’t get my computer to come back on; the computer would not come on when I pushed the power button, and the LED on the front kept slowly blinking on and off, every 5 seconds or so. I managed to get it booting again, after I removed the drive, but now I’m scared to put the drive back in my machine. I am burning with my Lite-On drive, now, and it appears to be working okay… so far.

Second, the drive is labelled thus:
Mfr. by BenQ Corp for Phillips & BenQ Storage Corp.

Model: DW1670
No: 291

Until someone can help me figure out why burning with this drive shut down my computer, I’m not putting it back in… I was afraid I’d fried my motherboard, for a few minutes there.

I don’t know that I’d try using that drive in your system either with those sort of scares, although it may not be only the drive to blame. It could be a sketchy power supply, for example. You could try attaching the Benq to an external enclosure and see how it functions in that - it would even work with many (most?) 3.5" Hard Drive enclosures, though obviously it wouldn’t fit inside of the enclosure, but I’ve used several HD enclosures with my burners and just left the drive bare outside the enclosure.

Regarding what is labeled on the drive itself, again it is still an issue where you’ll need to modify the 1.03 FW with MCSE to be flashed to an ‘ATAPI’ recognized drive. I’ve had several Benq drives that were either OEM or sold under another brand, that’s where you’ll see the drive recognized as an ‘ATAPI’ drive instead of a ‘Benq’. Once you flash with the modified 1.03 FW, it will show it as a Benq 1670.

I have a second computer lying around, I guess I’ll use it as a guinea pig; if it fries anything, then, won’t be a huge loss.

Try it in your other computer yet?

Not yet, I’ve been sick.

Okay, installing Windows on the secondary machine now, to test out the modded firmware.

Also: I’ve got my Lite-On drive connected to the same IDE and molex connectors that the BenQ drive was hooked to, and it’s worked fine for about 12 burnt DVDs since the BenQ acted up, and innumerable burns before that.

I just upgraded the firmware, so I’m gonna try a burn on the other machine, now, and see if it screws up.

Okay, so on the old machine, I burnt a CD and a DVD with no problems.
On the machine I want to use it in, I tried:

  1. Burn a DVD at 16x from a file on a network share. Computer powered off.

  2. Burn the same file at 8x (different brand media). No problems.

I am now going to try burning at 16x locally, using the media that is capable of it, and see what happens.

Okay, I’m dragging this thread from the grave, because the same problem has come back to haunt me:

I have done a full memtest on my system (using memtest86+) and swapped power supplies, but the same DW1670 is making my system reboot randomly while burning CDs/DVDs; I also have changed operating systems from WinXP to Linux (for other reasons) and I experience the same problem under Linux, as well. I have no problems playing games, reading discs, etc., but burning CDs or DVDs occasionally makes me restart when using this burner.