DW1655 mechanically broken?

vbimport

#1

Hello,

My BenQ is in an external exclosure and attached through Firewire. I burned a DVD+RW with Nero 7. The burn process was reported to be successfully, but during verification Nero hang. After some time, I cancelled the verification, and Nero said there were read errors on some sectors. I tried to burn again, but Nero didn’t recognize the media. I inserted a new DVD+RW, but still Nero didn’t recognize the media. When I try to open the tray, the BenQ didn’t react: The green light flashed for some seconds, but the tray stayed closed. Also ImgBurn and DVDInfoPro didn’t recognize the DVD, and couldn’t eject, neither Windows Explorer could.

ImgBurn gave the follwing hint in the status line: Device Not Ready (Logical Unit is in process of becoming ready).

I rebooted, switched to USB connection, but without any success. The drive is correctly recognized, but the tray doesn’t react at all. Finally, I opened the tray mechanically, but the OPEN/CLOSE button still doesn’t function. Is there any way to reanimate the drive?

Many thanks in advance for any help.

Best regards

mumdigau


#2

Hi,

as there is no answer so far I think things look bad, i. e. the drive died.

Let me ask you another question: Do you believe It could help to reflash the firmware of the drive (BCGB) or of the controller (Prolific 3507C)?

Ciao

mumdigau


#3

I think your external enclosure has a bad/defective PSU. That’s the most probable explanation for your issue. Many external enclosures, mainly the cheap ones, have terrible PSUs. Optical drives, mainly the Benqs, are extremely sensitive to power supply stability.

Sorry about your drive. :frowning: - it’s probably dead.

Only thing you can try is take it out of the enclosure, hook it up in your PC or another PC and see if it still works. Who knows…