DW1655: BCGB or BCHB

vbimport

#1

I just received my second BenQ drive. A 1655. My 2 month old 1650 was amazing so I decided to add another :smiley:

Anyway. The DW1655 shipped with firmware version BCGB. Should I just upgrade to BCHB automatically? Or do I stick with BCGB for a while to test?

The thing is, it seems BenQ’s firmware page doesn’t have the BCGB available for download. So I am afraid that if I want to revert back I might be stuck!

Probably a silly question. Is the a way to back up the current firmware?

Thanx :flower:


#2

FINALLY!
I was making sure that the 1655 is operational, so I put a DVD burned with my 1650 to scan it. With 8X P-CAV I got the same speed dips (comb) at the same intervals as I used to get with the 1650. With 8X I just got one dip at the beginning, like most scans that I see here. I don’t care to know why it works, I am just glad it does :wink:

YAY I am so happy :smiley: :stuck_out_tongue:


#3

Congrats to your new drive. :clap:
I’ll just answer one question; There is no way to back-up current firmware. But then, there is no need, just flash back with whatever firmware you like.
You’ll find firmwares posted in stycky thread at top of this forums first page.

Hope other members with this drive will post their experiences soon regarding BCHB…


#4

well… i have used bchb, but the results wernt as good as the results from gbab. so, i have changed to gbdb as recomended by others on the site(which i did have for a while before “upgrading” to gbhb which obviously has some issues with single layer media)


#5

How about the following threads:

New Firmware BenQ DW1655 BCHB support and discussion thread

Problem burning Verbatim MCC 004 with BenQ DW1655 BCHB (Verbatim MMC 004 crap?)


#6

my bad, I found the link to the BCGB here: http://club.cdfreaks.com/showpost.php?p=1374564&postcount=33
I just didn’t find it on the main benq support site and thought it might not be available for download

I guess I’ll do some experimenting of my own now that I have both firmwares

thanx :smiley:


#7

DW1655 BCHB slow down all my 8x 16x medias to 4x , I flashed back to BCGB everything is back to normal where it should be.


#8

this has been a common problem with BCHB. everything is going fine and dandy then suddenly the burns slow down (mine were all 2.4x)

i went all the way back to BCDB and have had no problems.


#9

Did you go all the way back to BCDB because you also had problems with BCGB?


#10

no. i went all the way back because i didn’t have bcgb saved on my computer and didn’t feel like looking for it :stuck_out_tongue:

haha I’ll probably go back to G tonight


#11

The experience I have had with both BCHB and BCGB and CMC and Prodisc MCC004 at 12X as well as TY T02 at 8X have caused me to go back to BCDB. Scans were no where near as good and BCDB is as good as it gets for this media.


#12

Does anyone here use Sonic DLA with their DW1655 drive? I have two USB drives - a DW1655 (firmware: BCGB) and an HP300e. I have Sonic DLA 5.20 installed. While the DLA seems to work fine with the HP drive plugged in (using DVD+RW disks), when I unplug the HP drive and plug in the DW1655 usb drive in its place with the same DVD+RW disk it can read the contents of the disk with no problem. However, I cannot add to the disk at all (says 0 bytes free, the same as if it were put into a non-writeable / non-DLA DVD drive). The discs are 4x ITG Media Legacy DVD+RW (http://www.itgmedia.com/itg_product.php?pid=5). I also cannot format these disks with the DW1655. Again, no problem with the HP300e. I thought of upgrading to the BCHB firmware but from what I’ve read it most people seem to be going back to BCDB so I doubt that would help. Any thoughts or ideas?

Thanks.


#13

Well, I guess the problem is actually that Sonic DLA just sucks. I tried erasing the same DVD+RW discs and recording the files directly to them as a track-at-once open session using, believe it or not, Sonic RecordNow, and it worked perfectly the first try (with the same disc), while Sonic DLA failed EVERY TIME even on a simple Format (saying the disc was bad)! Still curious as to why, but I guess in the end, it’d be just wasting more time…