DW1640: read errors when in enclosure?!

vbimport

#1

I just got a new DW1640, heard it was a great drive and was pretty excited to replace my 4X burner. I put the burner into a usb 2.0 enclosure, did a burn in nero with 8x media and it seems to go well until it came to verify the files. Then it kept saying sectors didn’t match and the windows eventlog starts filling up with Warnings about an error detected on the device. I try a few more times and again, the burn didn’t have any incident but the verification fails.

The files I burned on the disks have .par files (parity/checksum) so I put the disk back into the DW1640 and do a .par check. Again, I get errors reading from the disk. Then I even put the oem nero disk in the drive and tried to copy a folder to my harddrive and it got errors as well! At this point, I’m starting to think I got a lemon since it can’t even read a pressed disk without errors.

Then for the heck of it, I took out an old computer, hooked the drive up directly to IDE, and I was able to burn and verify 8x disks with no problems. So the DW1640 doesn’t like to be use in enclosures?!

I took the original burned disks I thought were fubar, put them into a laptop, and the .par files confirmed that the originally burned files are fine. So the DW1640 has problems reading disks when in an enclosure?

I’ve tried the drive in a usb 2.0 enclosure using the In-System ISD300A1 chipset and it had read problems. Then I tried it in a usb 2.0/Firewire enclosure using ATMEL AT49BV512 for usb and TI TSB41AB2 for firewire and it had read problems for both interfaces. Argh.

The drive originally came with firmware BSHB. After the errors, I upgraded it to the latest BSRB but it didn’t help. I heard good things about BSLB but that didn’t help either.

The drive is made in May 2005 China. Is is a lemon and I should return it or is there something else I should change or test?

Thanks!


#2

your drive isn’t a lemon. you’ll need to use a enclosure with the prolific chipset which works well with Benq drives. there’s a huge thread about enclosures in this forum site. you’ll have to search for it in here or use google.


#3

This was also a know problem with Prolific chipsets but Prolific released a new firmware for the bridge chip to fix the problem.