DW1640 Incompatibility issue?

Hi to everyone, it’s my first post here.

The reason why I’m writing it’s that I have a BenQ DW1640 since last October and I cannot get to burn a DVD with data verification OK.

I’m posting this message after reading a lot of post here and making a lot of test, waisting almost 50 DVDs in test.

First of all I’ve got to mention that for the tests I used some of the MAME roms zips (enough of them to fill a DVD5), because using them I can have to method of testing the burnt DVD, one method is with Nero data verification and the other is checking the integrity of the zips burnt in the DVD.

I started installing the DW 1640 in my computer with the following configuration:

Hardware

  • Processor: AMD Athlon XP
  • Motherboard: Gibabyte GA-7NNXP
  • Chipset: NVidia NForce 2
  • Bios version: F20 (last one available)
  • Memory: 2 Elixir DIMMs 512 Mb. PC-3200/400 Mhz. each one in dual channel
  • Sound: On board provided by the NForce2
  • Video: XFX with chip NVidia GeForce FX5200 and 256 Mb. in AGP 8x
  • SATA controller: Silicon Image 3112 (on board)
  • PATA controller: On board provided by the NForce2
  • RAID PATA controller: IT GigaRAID IT821F (on board)
  • Hard disks: 1 Segate SATA ST312002 6AS 120 Gb.
    1 Segate PATA ST380021A 80 Gb. connected as Slave in 2nd channel of the PATA controller with 80 pin cable (DMA Mode: DMA Ultra mode 5)
  • Optical drives: 1 LiteOn LTR-48125W connected as Master in 2nd. channel of the PATA controller with 80 pin cable (DMA Mode: DMA Ultra mode 2) Firmware: VS0D
    1 BenQ DW1640 connected as Master in 1st. channel of the PATA controller with 80 pin cable (DMA Mode: DMA Ultra mode 2) Firmware: BSOB
  • LAN: On board provided by the NForce 2
  • Gigabit LAN: Intel 82540EM

Software

  • SO: Windows XP updated with SP2 and updated up to January 20th, 2006 (in Spanish)
  • Burning software: Nero 7.0.1.2
    InCD 5.0.0.4
    Alcohol 120% 1.9.5.2722 (now uninstalled explained below)
  • Drivers: Silicon Image 3112 controller v1.0.0.51
    ITE GigaRAID IT8212F controller v1.6.1.8
    Nvidia NForce2 v5.10 international
    Nvidia Audio driver v4.57
    Nvidia Forceware v71.84
    Intel Gigabit LAN 82540EM v10.0

Note: After each DVD burnt with data verification failed I checked the integrity of the zips because I’ve read some comments that the Nero data verfication is not 100% reliable.

IMPORTANT: Before reading some post here about the incompatibility issue between the DW1640 with the IDE/PATA NForce drivers, I sent the burner to the RMA, they change the laser and they calibrated the burner, as errors in the data verification and integrity verification persisted I came back to the RMA and they changed for a new one, with this new burner the result is the same so as it’s too difficult that two burners where in bad state I started to investigate reading the posts here discovering the incompatibility with NForce drivers.

The media I used to test was always media supported by the BenQ DW1640. I used Imation DVD-Rs (Manufacture ID: FUJIFILM - Media Type: LM03) and Verbatim DVD-Rs (Manufacture ID: MCC 02 - Media Type: RG20).

With the NForce drivers I made unsuccesful tests changing the burner from 1st. channel to 2nd., changing from Master, to Slave and to Cable Select in each controller, I test by each combination of the burner connection taking the zips from the SATA hard disk and from the PATA hard disk in case that maybe there was a transfer conflict. I’ve also tried to burn the DVDs at less speed. Nothing works.

After reading about the incompatibility issue with NForce drivers I roll back to Microsoft IDE/PATA drivers (5.1.2600.2180), and I uninstalled Alcohol 120% because I’ve discovered that I was locking atapi.sys file and perhaps this could cause some kind of trouble. Doing this the burner improved a little in a strange way, this means: with the Microsoft IDE/PATA drivers with the Imation DVD-Rs at 8x the data verification failed in two sectors (instead of almost 7 sectors and it used to fail with the NForce drivers) and only two zips failed the integrity test (instead of almost 10 zips that used to fail with NForce drivers), this situation was found taking the zips from the SATA and from the PATA hard disk. I’ve tried after that to burn the Imagion DVD-R at 4x and for my surprise almost 20 sectors failed the data verification and almost 15 zips failed the integrity test.

After all of this I take the burner and I put it in an old computer that I have, with

  • Processor: AMD Athlon 900 Mhz. FSB 200 Mhz.
  • Motherboard: Epox 8KTA3+ with VIA KT133A
  • Hardisk: Western Digital WDC WD200BB 20 Gb. PATA

In this computer no VIA Hyperion driver was installed, and the Windows XP installed was with SP2 integrated.

The difference that I noticed between the IDE/PATA Microsoft drivers from one computer and the other, it’s that in the old computer the driver for the controller is from VIA (it says something like Principal IDE controller bus VIA) and the other one seems to be a generic one (it says something like Standard PCI IDE dual channel controller - I’m translating from Spanish to English).

The Imagion DVD-Rs burnt with this old computer were all right at 8x and 4x!!!

So I’m stuck, I don’t know what else to do or where the problem can be.

If someone there knows something about this please help me!!

I’m run out of ideas.

Thanks a lot!!!

Sounds like you should try swapping IDE cables or at least to test… That is at least one cause of data corruption and simple to test. Running memtest86would also be an idea to rule out memory issues on the nVidia machine. Also see here on how to roll back nVidia IDE drivers.
BTW. Welcome to CDFreaks.:slight_smile:

I shouln’t trust Nero “data” verification…
Better to run ScanDisk funktion in Nero CD-DVD Speed.

Use md5summer to get your checksums and then again to verify. :slight_smile:

Hi pinto, I took the statement below as it worked with his old machine but not with his new one. Never had an issue with Nero Verification so far but that is not saying it won’t happen.:stuck_out_tongue:

The Imagion DVD-Rs burnt with this old computer were all right at 8x and 4x!!!

Crossg I forgot to mention that I tried with different IDE cables, I tried with a 40 pin cable, the one that I used in the old computer to connect the burner and where the burnt DVDs where perfectly burnt. I rolled back Nvidia drivers uninstalled them like that FAQ that you posted said and I tested without result.

I’ll do a memtest86, perhaps the memories are having some issue.

Pinto2, I checked the DVDs burnt with MD5Summer against the MD5 generated for the set of zips that I built to make the test and I found the MD5 differences in the same zips that the zip integrity check told me that was failing on the burnt DVDs.

Thanks anyway for the help. I’ll post later the result of the memtest86.

Not sure about the md5summer but pinto2 knows what he is talking about so I would trust his judgement. Did you also try swapping the Sata IDE cable? S ATA is great but the connectors/connections suck sometimes!

Sofar topic poster only used dash (DVD-R) media. Would be interesting to know if the same happens with +R’s.
(Although I can’t understand how one can waste “almost 50 disc” without a reaction…)

Output from Nero InfoTool would be of interest santiago78. :wink:

Hi again to everyone.

Well, I’ve got to thank you crossg because I’ve would ever imagine that the verification data was failing because of the memories.

The memtest86 failed, I took one DIMM out and burnt a DVD-R with great success, then I put the other DIMM but in a different slot to have dual channel enable again, I burnt an other DVD-R and I worked again!! Finally I re-install the IDE NVidia driver and this time tried with a DVD+RW that wasn’t supported by the DW 1640 and it worked fine!!!

So thanks a lot!!

Pinto2 the reason I waste all those DVD-R it’s because for various reasons:

  1. I want to backup all my XBOX games and my XBOX Philips DVD Drive doesn’t like DVD+R
  2. A personal reason: I don’t like to post asking for help before I make everything that’s in my hands to find a solution. Yep, perhaps I’m a little bit crazy hahaha, but sometimes I read some post here and in another site for people asking for help without even tried to find a solution by themself, because doing trail and error in computer things it’s when you leanr most.

Well, that’s all.

I hope this post could be usefull to someone having this same problem.

Regards from Argentina.

Thank for posting back. :slight_smile: Happy you got it sorted out.

And kudos to crossg for this great tip. :clap: