DW1620 dying?



Hi all; i’ve been a lurker here for quite a while and decided it was high time i joined, especially since i have a problem to post.

I’ve had a BenQ DW1620 (I/O Magic branded) for quite a while now, a little over two years, i think. It’s always worked very well for me, until somewhat recently.

For a few months i’ve been experiencing slow burns. Most of the time it’s bearable, and it often goes back to its old self after a while. Once it got very bad at both burning and reading, but that seemed to be fixed upon reinstalling Windows (which was needed for other reasons), so i don’t think that the problem is with the drive itself. Somewhere around December it started ripping audio CDs a bit slower than usual. Now, within the last two weeks or so, burning has become less than half as fast as usual. Today i tried burning some DVD-R discs (i normally stick to +R, but these are Verbatims, and they were on sale pretty cheap), and i noticed that most of the time they were burning at less than 1x (though the second disc did get up to 3.5x for a bit). +R discs have been the same way, though not quite that slow.

I spent a lot of time today reading some older posts (and the stickies) here about firmware and similar problems, but didn’t find anything exact. I checked on some of the issues described there anyway, since they seemed likely culprits. I did discover that the location my burner is on was set to PIO mode by Windows, but correcting that (reinstalled the IDE driver which reset it to UDMA Mode 2) didn’t solve the problem. All of my IDE cables are about 2 years old and are 80-pin, and the Master/Slave devices are in the proper physical position on the cables. The transfer rates of my hard drives seem to be perfectly normal as well (this was actually my first thought, since a lot of the files i was burning were coming from the oldest drive in my system).

relevant system specs:

BenQ DW1620 (B7W9)
Sempron 2500+
nVidia nForce2 chipset
WinXP Pro

Someone give me an idea, please! I’ll gladly run additional tests and/or provide more information to help narrow this thing down.

EDIT: Forgot to mention, CD-Rs seem to burn just fine. Ran one just now, just to be sure before i posted it; burned a 55 min .bin at 40x in 2:42.


Welcome to cdfreaks :slight_smile:
Use the orginal Microsoft IDE driver, do not use the NVidea driver. Keep source and target drives on different IDE busses.
Post the result of the Nero CD-DVD Speed burst transfer test, you need a disk with some data in the drive to run the test. It should display about 23 MB/sec.
Check the DMA settings of your source and target drive.


yeah, do not install forcewave drivers, you can, but uncheck the ide drivers, only use that driver for your USB, audio, and other drivers, uncheck the IDE


Thanks for the welcome, and for the suggestions.

Actually, i am not using any Forceware drivers at all. I don’t recall doing that intentionally, but all the bus and IDE drivers are from Microsoft.

As for keeping source/target on different buses; sometimes that’s possible, sometimes not. I have 3 hard drives and one burner on two buses. I get the same results regardless of which hard drive is my source.

Both channels of both buses are set to UDMA modes.

Results of Nero CD-DVD speed are…interesting. Starts out at 3.5x and ends up at 8x? CPU usage at 8x was 47%…that seems awfully high, but it would explain a few things (see next paragraph). Burst rate was indeed 23MB/sec.

Another quirk i forgot to mention is that when the painfully slow burn times started occurring, my system started to slow down while burning as well. I never usually had much of a problem reading an already loaded web page, or editing a text file, or other things i wasn’t worried would interfere with Nero (or DVDdecrypter, as i’ve been using lately). But as of the last few weeks, i can’t even move the mouse from one corner of the screen to the other. I didn’t even have this much trouble when i was still using a system half the speed of this one. Any ideas there?



I’ve burned 2 more discs today (both DVD-R) so far. Both of them suddenly decided to burn around 6-7x. The only thing i’ve done since my original post last night was that i defragmented my Windows drive (not the source drive for these particular disc images). The machine is also not slowing down while burning anymore; i suppose that could theoretically have something to do with the (de)fragmentation.

6x is a vast improvement, but they are supposed to be burning at 12x. So even if this state is maintained, i would still seem to have a problem.

I’ll try a +R disc later on and post my results if they are different.


check to make sure windows didn’t downgrade to PIO mode for your drives


Try to update your drive (burner) with latest firmware available and also use brand name media like Verbatim, Sony, and Fuji,


Whatever the issue, it doesn’t sound like the burner itself is the problem. Software/driver/Hard Drive/etc. yes, but I don’t think it’s the burner.


His first post mentions using the latest firmware and Verbatim already.


Yep, like i said in my first post, i did have to correct that originally. I’ve checked several times since, and it hasn’t been downgraded yet.

Thanks. :slight_smile: Yes, i upgraded to B7W9 long ago. Lately i’ve been using Sony-branded YUDEN000-T02-02 +R discs, and the Verbatim -Rs are MCC 03RG20. I also have a lot of Fuji +Rs that are PRODISC-R05-01; same results burning these, but i haven’t been using them for my PS2 backups (which is what i’ve been doing lately) as the system doesn’t read them very well. I’ve been sticking with “first-class” media for that. All three brands are rated 16x.

I’d like to point out that all of my burns are completing properly and are reading perfectly when finished. They’re simply not burning at full speed. I just finished burning one of the Sony +R discs with about 1.2 GB of data. By the time it got to the end, it had gone from 1.5x to 11x, and took just over 3 minutes overall. This is far more acceptable than before, but i did have the speed set to 12x. I’m going to run a few more tests (some full-size images and video discs) and see what happens. Perhaps i’ve fixed the problem somehow, but i’d like to figure out what the problem actually was. Changing to DMA mode didn’t seem to help immediately, and i refuse to believe that defragging my Windows drive had any effect on burning disc images from a different physical hard drive.


Post a cdspeed create disk scan.


If the program is using the OS HD to buffer the data, then defragging may have had an influence. And as ala42 mentions, posting a create data disc result would help. You can burn a data image with CD-DVD Speed. The other option would be to burn with ImgBurn and post the output screen capture from DVDInfoPro (this will also show burn speed, CPU and burner buffer, etc).


THAT had not occurred to me–very good point.

Although, i had very erratic speeds burning another -R a little while ago. I’m running some tests and logging my results, which i’ll post later. I’ll post “create disc” scan results in a short while as well.



I’m not really sure what to conclude from that. What does it mean that it repeatedly spiked so low?


WOPC kicking in.


OK, i wasn’t familiar with how WOPC worked, but i found a page on it; i get it now.

So, here are some more burning results. It seems to be mostly working better now, but there are still some quirks i can’t figure out.

Here’s my log:

<b>Burning a 4.3GB disc image to a DVD-R using DVDdecrypter:</b>
Attempted 12x.
Speed is very erratic, sometimes climbing to 4x or 5x, sometimes dropping below 1x, but generally hovering near 2x. This image is on the Windows drive, which is on the same bus as the burner (unfortunately, it has to be, as my Windows drive is the only one currently formatted as NTFS). Thusly, it will stay at 4-5x more if i refrain from using other programs while burning. Also experiencing system slowdown again. Perhaps it’s time i reformat one of the partitions on my other drives to NTFS for larger images like this one.
73% complete: speed has climbed to and is staying within the 9.5-10.6x range. Seems to work best if DVDdecrypter stays in focus.
Forgot to record overall burn time; somewhere around 20-25 minutes.

<b>Burning compressed DVD-Video to Fuji DVD+R using Nero:</b>
Emptying the partition these are on before formatting to NTFS to try large image files.

3.2 GB, attempted 12x. Time = 5:23

3.6 GB, attempted 16x. Time = 12:11
Took 7 minutes to get from 5% to 9%, then resumed proper speed.
(I’ve had this problem as well as a number of coasters when burning at 16x; that started happening long before my current problems.)

3 GB, attempted 12x. Time = 5:01

<b>Burning a 3.7GB disc image to a DVD-R using Nero:</b>
This one is on a drive on a different bus, and is quite fragmented.
Attempted 12x. Time = 5:58

<b>Burning a 4.2GB disc image to a DVD-R using DVDdecrypter:</b>
This time the image has been placed on the new NTFS partition, which is on a different bus from the burner.
Attempted 12x. Time = 6:29
Speed varies again, but this time in the 6-8x range. Average speed slowly climbs and reaches the 10-12x range at around 40% completion.

I am also noticing that my drive is occasionally refusing to recognize the -R discs. It seems i can usually get it to work by swapping it for a blank +R and allowing it to recognize the disc, then swapping back, but not always. I have no such trouble with +R discs.

(end of log)

It seems that my speeds are tolerable if the file is on a different bus from the burner, the file is preferably not fragmented, and the planets are correctly aligned.

I guess my problem is basically solved. I’m still not sure exactly what it was, but likely it was a combination of the transfer mode and fragmentation of the Windows drive and/or source files.

As a mentioned, a few things i still don’t quite understand…

  1. I know it isn’t recommended, but i never had problems burning from a hard drive on the same bus before. Why now?
  2. What could be causing the trouble burning at 16x? I normally burn at 12x, but it would be nice to know if this is something that can be fixed.
  3. What might be preventing the initialization of blank -R discs?

The third point is the biggest problem. I’ve got a whole bunch of brand new, quality DVD-R discs, and half of the time it takes an act of congress to get the drive to recognize them (and i think we all know how speedy the legislative system can be). Anyone else have experience with such a problem?

Thanks to all who’ve made suggestions thus far; this forum in general has been a really big help!