Dw-u18a wont work

hi, im not sure if this is a hardware or software problem but if anyone can help i would be grateful.
my problem started about a month ago, my burner made a clunking noise and then the tray would not close, so i sent it in for warrenty no probs, came back worked fine for a week and then it starts, first nero kept coming up with “power calibration” errors or burn failures when finalising any project (dvd or data burns).
then dvd dycrypter gets to 60-90 % before failing and saying check device and the same problem with dvd shrink.
Now the drive has the latest firmware and my machine has all its drivers up to date. Neros support line said it was my audio and video drivers needing up dating as their best guess, but they are and also the machine and drive burnt fine with the old and new drivers before all this
my machine is
amd athlon 3000xp+
512mb ddr400 ram
120gig HD (92%free)
XP home service pack 1(also have tried sp2)
via KM400-M2 mother board
geforce 128mb 5200
sony dw-u18a burner
nero 6 (with and without updates tried)

Power Calibration error is a sign of bad or unsupported media in the first place.
Also it could be a sign of insufficiant PSU power.

But it’s probably only bad/poor/unsupported media.