DW-U14A isn't working with 510A firmware - it seems stuck

Hello. My cousin flashed his Sony DW-U14A with the DRU-510A firmware, but now it doesn’t work. The flash was ok. Now he has errors and pauses on burning, dvdxcopy crashes when it was ok before. The only dvds he managed to burn don’t work.
He’s on XP.
He tried to install another h/d with Windows 2000, and had the same problem. He even cannot READ dvds, if he tries to see a movie everything is scrambled, there are large areas of blocks all around the screen. DMA is now turned on, he tried to flash every firmware version he could find. His u14a is apparently incompatible with the 510a fw.
Just for notice, yes, the drive is on secondary master, and YES, it was perfect before.
Now he just wants to go back to his previous fw, but obviously he cannot do so using the normal Sony fw.
I tried to look for some DOS utility a la mtkflash but sony-aware, but I could not find any, nor i found a .bin for the burner.
We need some advice, anything useful? In this state he cannot ask sony, cause the warranty is void.

try this file:
http://www.membres.lycos.fr/laurentlegenial/4244fb10d.zip
(this is firmware u14a 1.0d)