Dw-g120a

vbimport

#1

Hi, This is my first post and any body to help the problems.
I have Sony DVD Writer (DW-G120A) (OEM). When a DVD (movie) is being burned, the disc is not being perfectly played in stand alone DVD players, it is stucking / skipping. But when the media is Moserbaer (RW) it is running in stand alone DVD players without any problem.
To get rid of this problem I have downloaded the firmwere MYR3 from www.sonyisstorage.com. But the ‘UPDATE’ is not being opened (The OS of my machine: WIN XP SP2), ‘Windows Task Manager’ is showing that G120A-BR_MYR3.exe is running and during this time no other application is not being opened

kshk_31


#2

So the media must be not suitable for your burner or cheap or it were burned too fast.

What media have you used (not the RW) and what mediacode/MID does it have?
(You can find that out by using DVD.Identifier or DVDInfo.)


#3

Try re-downloading the firmware installer, it should pop-up a little window when you run it.

Also, Sony OEM-drives seem to come with different firmware series. If MYR3 says it doesn’t recognize your drive, you may have to get MYS3 (or another - depending on the actual version you have now).

And if you still have problems and you know what you’re doing, you can crossflash with Lite-On 165P6S firmware from Codeguys.


#4

I used Writex DVD-R media.

Nero CD-DVD Speed: Disc Info
Basic Information
Disc type: : DVD-R
Book Type : DVD-R
Manufacturer: : CMC
MID : CMC MAG. AE1
Write speeds: : 4 X - 6 X - 8 X
Blank Capacity : 4.38 GB
: 4489 MB
: 4707319808 bytes
Extended Information
Layers : 1
Usage : General
Copyright protection : n/a
Recorder information : recorded with SONY DW-G120AMYS2
Disc Status : Closed
Raw Data
Pre-recorded Information in Lead-in (0Eh)
0000 - 01 40 C1 FD 9E D8 52 00 02 55 0D 0E 88 9A 80 00 - .@…R…U…
0010 - 03 43 4D 43 20 4D 41 00 04 47 2E 20 41 45 31 00 - .CMC.MA…G…AE1.
0020 - 05 88 80 00 00 00 02 00 E0 D4 05 00 18 EE 90 7C - …|
0030 - 78 FB 90 7C FF FF FF FF 71 FB 90 7C 18 6A DD 77 - x…|…q…|.j.w
0040 - 51 6A DD 77 00 00 15 00 02 00 00 80 30 00 00 00 - Qj.w…0…
0050 - 18 00 00 00 30 00 00 00 18 D5 05 00 40 00 01 00 - …0…@…
0060 - 0B 00 00 00 20 D4 05 00 4E 00 4E 00 98 D5 05 00 - …N.N…


#5

Just try with better, recommended media.

www.videohelp.com/dvdmedia


#6

Thanx, I have changed the media and now it is working absolutely perfect.


#7

Hi,
I’ve got the same issue. Could you tell me which media you’re now using (particularly any DVD-R).
Thanks


#8

Hi,

Your firmware is MYS2, so MYSx (recent: MYS4) is the right version (scroll down on www.sonyisstorage.com). Sony is confusing me here, because any information they provide for my drive (DW-G120A-BR, “Sony”-logo on the frontplate) indicate that this should be a retail drive. But the firmware, the drive came with, was also MYS2, which is a version for OEM drives :confused:

If voiding warranty doesn’t matter, this drive can be crossflashed to Liteon SHM-165P6S, if I remember correctly. In that case, you should search the Liteon/Sony forum for further information.

Michael

(sorry for digging this old thread out ;))


#9

That’s just OEM-drives finding their way into “retail” shops, Michael. There’s two firmware series MYRx for the G120A-BR (Branded=w/Sony logo) and MYSx for the G120A (OEM). Looks like they’re confusing themselves with Branded and OEM if your -BR has MYSx firmware. The only real current Sony retail drives are 810A and 820A.


#10

I bought this from play the other day, but they helpfully didn’t send any software or drivers with it.

where can i find them?


#11
  • No drivers required
  • Firmware updates: www.sonyisstorage.com
  • Burning software: Nero etc. (or freeware Burn, Burn4Free, Deepburner…)
  • Video playback: PowerDVD etc. (or freeware VideoLAN Player, Media Player Classic…)

#12

this maybe so but how come my computer doesn’t reconise the drive?


#13

Check the Master/Slave jumper setting on the back of the drive (MA/SL positions are indicated on the back and on the top label.


#14

what setting does it need to be on?


#15

Sorry, I can’t tell without looking at your PC :slight_smile:

Suggest you put it as Master on the Secondary IDE-channel (i.e. not on the same ribbon-cable as your Windows hard disk). If you want to put a second hard disk or optical drive on the same cable, jumper it as Slave. Use 80-wire (Ultra ATA 60/100) ribbon cable and attach the blue connector to your mainboard and the black connector on the other end to the Sony.


#16

aha
got it working, hurray! thanks for your help


#17

:slight_smile:

Welcome to CDFreaks!


#18

Hi,

Seems, as if I am not the only one with that combination :wink: Just want to note, that installing MYR3 FW worked without problems here.

Michael


#19

Yes, I have one too :slight_smile: . Sold in brown box with DW-G120A-BR sticker and came with MYS2. Haven’t used it enough to give an opinion, it’s in an ICY BOX right now.