DW-D22A to SOHW-1673S and BLINK

vbimport

#1

hello,

for my first post on this forum, let me tell you what i’ve done and can’t undone now :sad:
i know that i’ve made some mistakes,
but i hope that i will find some help on this famous forum

-=-=-=-=-=-=-

i have a Sony DW-D22A who came with the BYS2 firmware

i successfully upgraded to a SOHW-1633S with the BS41 firmware found here : BS41 - patched - crossflashing

then i tried an upgrade to a SOHW-1653S with the CS09 firmware found at the same place : CS09 - patched - crossflashing, it was successfull too.

Using Flashfix 1.1.1.9, found here : FlashFix tool,
i flashed the DVD-Writer with the resulting fix firmware CS0C.EXE,
the original can be found here : DR16CS0C.zip

OmniPatcher could not patch this fix firmware, it could not patch the original as well
but i flashed anyway,
and as far as i remember, the result was good

then, and last,
i took the original SOHW-1673S DR16JS02.zip,
using FlashFix tool, i’ve been able to make a fix firmware
that OmniPatcher could not patch

i’ve forgotten to patch the JS02 - stock - unscrambled available at codeguys.rpc1.org
with Fix the “dead drive blink” / Enable cross-flashing
maybe if i had done this, i will not have had the problems i have now
but i flashed the DVD-Writer with a non patched JS02 firmware

and that is the last time i could have an access to the drive from MS-Windows

-=-=-=-=-

the DVD-Writer is seen at the machine post boot with its new “LITE-ON DVDRW SOHW-1673S JS02” name
but exists no more in windows
so all the usefull windows flashing tools are useless
even the MTK WinFlash with its IDE MODE doesn’t work
the light of the DVD-Writer is blinking all the time

-=-=-=-=-

before posting here,
i have used mtkflash to try to recover my DVD-Writer
i have tried on ide channel 0 slave and ide channel 1 slave

unfortunately, with all the versions of this program i tried (1.80, 1.80.1, 1.83c), i was in the impossiblity of flashing a new firmware.

i can obtain a response of the program when i make a :
MTKFLASH # SR

Flash Type : SST(SST25VF040)(Serial)
Reading … Finished!(0000)
>>> Please REBOOT your PC !

and then a :
MTKFLASH # W /B /M xxx.bin

Flash Type : SST(SST25VF040)(Serial)
Updating…00%

the program stops at 00%

with 1.83c version,
a MTKFLASH # DR and then a MTKFLASH # W /B /M xxx.bin
does not give better results

a MTKFLASH # UW gives

Port:1f0, Master/Slave: b0
process HOST to DRAM
process DRAM to FLASH
Bank 0 Check Bit
request sense:0000 0000 0000 0000 0000 0000 0000 0000
Check Bit
request sense:0000 0000 0000 0000 0000 0000 0000 0000

and so on

a MTKFLASH # UW xxx.bin gives

Port:1f0, Master/Slave: b0
process HOST to DRAM
Bank 0 Check Bit
request sense:0000 0000 0000 0000 0000 0000 0000 0000
Check Bit
request sense:0000 0000 0000 0000 0000 0000 0000 0000

and so on

with the others options,
there is no answer of the program

-=-=-=-=-

so, what can i do now ?

thank you in advance for your help

-=-=-=-=-=-

Edit:

sorry if this post should have been posted @ Club CD Freaks - Knowledge is Power > International Chat: Hardware related > Recording Hardware Forum > LiteOn Forum


#2

hello,

i answer to myself,
the solution was in the forum

i’ve found it in this thread

[quote=“C0deKing”]

Yes, it must be held during the power up reset. Note, this is only required for MTKFlash, not a normal Windows flash.
[/QUOTE]i have used mtkflash v1.83c

:bow: thank you C0deKing


#3

Good find, thanks for searching. I don’t think that the DW-D22A is upgradable to a SOHW-1673S though. Did it work for you?


#4

no dhc014, it didn’t work at all
i made a big mistake, and i began to read threads in this forum after.
my DW-D22A was not upgradable to a functionnal SOHW-1673S when using the way described above
but i could revert it to its previous state with mtkflash v1.83c and the “hold eject key at reset” trick

i did not try with a patched JS02 - stock - unscrambled with Fix the “dead drive blink” / Enable cross-flashing enabled
because i don’t know if it is the right way

maybe that
downloading the official flasher => FlashFix => Flash => Dump => OmniPatch => Reflash
does the same thing
but i don’t if it works without rebooting the pc

any ideas about this ?


#5

You Can !not! Flash 1213-1653s With 1673s Firmware!


#6

I have tried the patched one but it did not work at all it just blink fast then nothing happen anymore it did not spin at all and windows don’t detect it.


#7

As stated before, you cannot crossflash to the 1673s or the 1693s. Different puppys.