DW-D22A/NTI DVD-Maker Gold buffer problem

Hi,

I’ve been doing a lot of research to find a solution to my problem, to no avail, so I’m asking to see if anyone could help.

I have a Sony DW-D22A drive, which came with BYS2 firmware, and which worked perfectly until recently.

It doesn’t burn and I get a data buffer underrun error message.

Now, I tried a few things that didn’t work for me:

-Upgraded to BYS3 (with LtnFW, which went smoothly even though my specs still indicate that my firmware is BYS2);

-Defragmented my HD;

-Tried different writing speeds.

Whenever I try to burn files (I’m mostly doing data DVDs), the cache bar never fills up and the burning aborts. At least I’m not turning DVD-Rs into coasters, but I can’t burn anything.

I never had that problem before, but aside from the obvious, I also noticed I cannot use the test & write feature anymore.

The only thing I could point out to, is that so far I have used Imation 4x blank DVD-Rs, and my problems started when I tried to use the Memorex from the pack I just bought. I got both 8x and 16x, neither of them work, but they do have different writing speed options, none of which will do, even the lowest, which is 1x (on the 16x DVD-R, the minimum for the 8x is 2x, IIRC).

Could it be that my drive doesn’t like the Memorex flavor? If so, that’s a shame, because I just bought 50 of them and there’s nothing anywhere that says I can’t use them, right?

At the same time, I hope it’s the cause of the problem, because it’s still better than a dying drive (it’s not even 6 months old).

I still can’t figure why the cache bar doesn’t fill up. It’s like a data buffer error that happens before the burning process starts.

I enabled for all files to be copied to a temp folder before writing, regardless of size, and when I retried to burn, NTI tells me it’s processing the file, then nothing happens, then the DVD-R ejects and a message tell me the burning was succesfully completed even though nothing has been actually burned. Kinda like a ghost writing.

Anyway, I’m not so knowledgeable about burning and I’m all out of ideas, can anyone recognize my symptoms?

Any help will be welcome.

Thanks

Anyone?

Thanks.

What’s the mediacode of the Memorex disc your trying to burn.

Use DVDIdentifier and post result.

Alright,

here’s the result for the 8x Memorex

Unique Disc Identifier : [DVD-R:RITEKG05]

Disc & Book Type : [DVD-R] - [DVD-R]
Manufacturer Name : [Ritek Corp.]
Manufacturer ID : [RITEKG05]
Blank Disc Capacity : [2,298,496 Sectors = 4.71 GB (4.38 GiB)]

[ DVD Identifier V4.2.0 - http://DVD.Identifier.CDfreaks.com ]

And this is for the 16x


Unique Disc Identifier : [DVD-R:CMC MAG. AM3]

Disc & Book Type : [DVD-R] - [DVD-R]
Manufacturer Name : [CMC Magnetics Corp.]
Manufacturer ID : [CMC MAG. AM3]
Blank Disc Capacity : [2,298,496 Sectors = 4.71 GB (4.38 GiB)]

[ DVD Identifier V4.2.0 - http://DVD.Identifier.CDfreaks.com ]

here’s some extra info from the same software about my drive regarding the 16x DVD-R:

** INFO : Drive = SONY DVD RW DW-D22A [FW BYS2]
** INFO : Write Capabilities = DVD+R DVD+R-DL DVD+RW
** INFO : Write Capabilities = DVD-R DVD-RW
** INFO : Disc = [DVD-R:CMC MAG. AM3]
** INFO : Reference Speed : 1x DVD = 1385 kBps
** INFO : An Writeable Disc Is Recommended For Accurate Results
** INFO : Write Speeds (Supported By This Drive On This Disc) Listed Below

** INFO : GET PERFORMANCE Write Speed Descriptor(s)
Descriptor #1 = 5540 kBps ( 4.00x) - [CLV/Non-Pure CAV]
Descriptor #2 = 2770 kBps ( 2.00x) - [CLV/Non-Pure CAV]
Descriptor #3 = 1385 kBps ( 1.00x) - [CLV/Non-Pure CAV]

** INFO : MODE SENSE Write Speed Descriptor(s) [Legacy Command]
** WARNING : MODE SENSE Is Obsolete And Not Always Properly Supported
Descriptor #1 = 5540 kBps ( 4.00x) - [CLV/Non-Pure CAV]
Descriptor #2 = 2770 kBps ( 2.00x) - [CLV/Non-Pure CAV]
Descriptor #3 = 1385 kBps ( 1.00x) - [CLV/Non-Pure CAV]

Thanks for your help.

The 16x Memorex is not supported by drive’s firmware.

The 8x Memorex ritekg05 are known to be off inferior quality. http://club.cdfreaks.com/showthread.php?t=158296

Try better media. I use Verbatim.

The Sony DW-22A is bulk of Sony 710A. http://club.cdfreaks.com/showthread.php?t=156564

You loose warranty when you crossflash drive. http://codeguys.rpc1.org/firmwares.html

Ok, so should I crossflash it? Would it allow me to use the 16x DVD-R?

When I load the 710 crossflash firmware in Omnipatcher, it lists both my DVD-Rs as supported, so I figure I’d give it a try.

In case of problem, can I flash back to BYS2 or 3 after a crossflash? I know about the void warranty issue, but it’s not like it cost me a grand to begin with, I’m willing to take the chance, it doesn’t seem too risky.

Okay, little update:

I crossflashed my drive with the BYX5 firmware. The update went smoothly, my drive is now a DR710/1633S.

I tried burning on an 8x Memorex at 4x speed and something weird happened.

NTI DVD-maker processed the files, wrote the TOC and then said the writing was successfully completed.

In the process, the cache bar filled a little, about a fifth of the way, then emptied out.

The resulting DVD-R is now 4.14 Gb in size, but I can’t open it. When I try to, the drive does not respond (according to MS task manager) and when I eject the DVD, the window finally pops open for a second and all my files seem to be on it. I will try to read it on another computer later.

Also, during the burning, the little light on the drive turned red, something I had never observed before (it is usually green), it is green when I read DVDs or CDs.

Could it be that the 4.14 Gb are just the TOC? I can’t verify that the files are actually on it, all I can see are the folders they were divided in, in the brief moment before ejecting that they actually show up.

I’m still under the impression the problem is with the cache, not the DVD-R or the drive itself. It just doesn’t fill up to provide a buffer. My computer is quite good, I defragmented yesterday, I have about 15% of my HD free and other than that, I have no slowdowns or other. Why isn’t the data cached? Is there a cache file that could be clogged and that I could clean? I also shut down all the non-essential programs during the burn to keep a maximum of the system resources available.

Any guess as to what might have happened here?

Try Nero CD/DVD Speed and do a ‘Create Data Disc’, save as png and post result.

The red burn led comes from the new firmware that are ‘Patched and Multicolored led’.

Nero CD Speed Test results

General Information

Operating System Windows XP
Drive SONY DVD RW DRU-710A
Firmware Version BYX5
Serial Number
Disc DVD-R
MID RITEKG05
Capacity 4.38 GB

Write Transfer Rate

Write Mode DAO
Start 5.40x
End 8.03x
Average 7.71x
Type P-CAV

Thanks for your help jbv!

Must be NTI software problem.

Try Nero 6.6.0.18. Nero 7.0.1.2 still reported buggy. Maybe 7.0.1.4 are better.

Have you installed any Nvidia or Via ide contoller drivers.

Okay, I took your advice, I switched to Nero 6.6.0.18 and it works fine with all my different brands of DVD-R/+R. Seems that NTI was the problem, regardless of what caused it to go bad after working fine for 6 months.

Thanks a lot for your help jbv, I really appreciated it.

Cheers