DVRTool - Pioneer DVR/BDR firmware flashing utility (v1.02)

BD-ROM Pioneer BDC-207 BK or DBK

Thanks, Finally, where can I find, get or buy the BDR-PR1EPDV firmware and kernel.?

Rather, you can not buy. Only Epson can help here, but he doubts he wants to help. They sell these models

I’d like to flash a previous firmware on the pioneer bdr 209m drive with the dvrtool -ff command. Can someone give me the password for this drive?

grtz

And what’s the story between the pioneer bdr 209m different versions of firmware? Like general firmwares and 209ebk specialized firmwares which are according to dvrtool incompatible with each other.

I could flash my 209M ID60 without a password, be sure you have the correct firmware files though.
Any particular reason for you to try a previous firmware? From my personal experience with CMCMAGBA5 media, the later firmwares have better write quality than the earlier versions.

Hello Oinker,

well all of a sudden my pioneer bluray burner won’t read any bluray discs. So, i thought maybe it is some firmware upgrade i did in the past. My burner, a pioneer bdr 209M ebk burner bought in 2016, but on it’s label it said 2014 build date. So, i just want it to read bluray discs again.

I guess i also have an id60 burner. id60 stands for the kernel used right? Even put in a new laser unit for blue laser and red laser. But somehow the blue laser is a bit blue/purple coloured.

I was trying to adjust the height of the sled and at some point i had a little blue dot on the upside of the disc. That must be something, but that was it. Then i should just keep on adjusting the height of the lasersled.

Yes, as you can see in the screenshot you’ve posted where it says Kernel Type: ID60. The firmware you want to flash must be the same, otherwise it won’t work. The screenshot says you’re on firmware 1.30, that’s rather old, did you try any newer version, the latest is 1.52?
Now I doubt the problem is a firmware update, so downgrading probably won’t solve the issue of being unable to read BluRay discs. And it would be really weird if the laser optic would be completely out of focus even with a replaced laser unit.
So considering the drive is out of warranty I’d suggest to just buy a new drive.

ok, i understand, but what’s the difference between the ‘general’ firmware files and the ID60 firmware files?

Btw it isn’t just the two leds replaced, but it’s a sled with the leds, so i replaced the complete sled. But strange thing is, that before i replaced the sled, it also didn’t read bluray anymore. But although i did clean, i cleaned the red laser lense. Cause that looks blue. So i cleaned the wrong lense. I always use the blue spiritus alcohol to clean the lenses. Has always worked out fine. Looks like the blue ray just can’t focus on the disc right. There should be a point that’s blue visible on top of the disc ( i opened the unit then connect it to be able to see how it works). Maybe i should try cleaning again, using ordinary alcohol.

About the firmware versions i installed, tried a very old firmware indeed, to no avail. Yes, now i have the newest version fresh from the pioneer site installed. Still isn’t working. It just won’t start using the blue laser.

Hello guys,
I have met a problem.
When I upgrade my pioneer s09jbk to firmware 1.52.
Its blackout. The last message is now internal reflashing... It havent reach 100%.
Can you help me downgrade to lower frimware version?
I want to crossflash it back to firmware 1.52 again. Thanks a lot.

Crossflash? As mentioned in the first post, the newer drives (207 series and above) have some kind of crossflash protection. Thus it won’t work. I’ve no idea if that’s recoverable. Hope you’ll get some help regarding that.





I tried. Fortunately,it works.
Thanks to all guys.
DVRtool is such a great tool.
If you are not lucky like me, you can take a chance.

Yes, a real old Thread, maybe i could get some information.

Drive Information:

Model Name : PIONEER BD-RW BDR-S09
Firmware Rev : 1.52
Extra Info : 19/01/11 PIONEER
Serial Number : OEDL015979WL
Buffer Size : 4000 kiB

Additional Drive Information:

Label Code : BDR-S09XLT
Hardware Rev : SAT 8600
Kernel Type : ID43
Firmware Type : ID43
Kernel Version : 0000

Drive is in normal mode.

Firmware flashing support : YES
Firmware dumping support : NO

“Just” flashing with DVRT isn’t possible: Drive not ready.
Used .120 and up, no luck. Can’t get away from the 1.52 Version, but since this is installed device don’t read anything.

Password, i don’t know how to get, searching since days.

Any way to get the firmware down to other version?

@czary2mary still here and could pls help?

Firmware to be installed version 1.20 for Pioneer BDR-S09XLT


or
S8600431.zip (1,8 MB)

command
DVRTool -f X: S8600431.120

where “X” is the letter of the Pioneer BDR-S09XLT drive in your system.

Password:149C15DC

1 Like

Wow, thank you so much. Super.
Downgraded to 1.20 with success.

This drive is sh, ehm, low quality.
Used to burn 5 CD in 2 years. Nothing else. Don’t recognize anything.

Would’ve surprised me if a firmware downgrade would’ve worked. But are you sure the drive doesn’t recognize any disc or the OS? Did you try it in another PC yet?
Then again it is technical equipment and as such can fail anytime, but to claim Pioneer drives would be low quality is simply not true, I think many users here agree that they are pretty good actually.
I hope though you didn’t get a fake one of ebay, there were fake 208/S08 though, I’m not sure there were fake 209/S09 drives too.

Hi, yes, the drive takes / recognize not one type of Disc. DVD, CD, blank to burn, Movies, Music, Original MS OS CD and DVD.
The drive don’t spin up, it does nothing.
Changed cable, SATA Controller, RAID Controller.
Nothing.
3 Weeks ago i used to burn one CD. No Problems. Did not use the drive since this.
3 days ago liked to burn a CD. Nothing…
Don’t have further PC to try but clean installed Win10 Pro stable.

I said: this drive is less quality. Not all Pioneer Drives. Don’t understand how a drive could fail by Standby. Will have to buy a new one, warranty is gone.

Drive has been ordered and shipped by Amazon

Well, there are a lot of parts in a drive that age over time, e.g. capacitors. The laser unit itself shouldn’t age that much if not in use, although it contains parts that can, too. There’re other factors that could 'cause problems, PSU related, power related, and dirt (dust, from smoking, etc.). If the drive doesn’t spin up there could be a failure of the disc motor or missing 12V from the power supply, if the problem would be the laser unit it should at least start the motor. I’d still suggest you check the drive in another system.

Today had time, opened the drive.
The cable between PCB and motor is just plugged. Or, in my case, unplugged. With only a few millimeter it’s been in the connector. Plug and Play in real words.
It works again.

Interesting, thanks for the info, and good it was so simple to fix and that it’s working again.

Btw I’d suggest to flash firmware 1.52 again, because from my personal experience the write quality on e.g. CMCMAGBA5 media is better with the newer firmware.

Hi, I’m looking for flash dump to my BDC-TD03RS