DVR-212D Firmware

vbimport

#1

I just got this drive, and I know it’s new, but is there modified rpc1 firmware?. Also, is there 212 firmware that supports DVD-RAM writing?


#2

Supply a firmware and it can be patched…


#3

It was released, 2 weeks ago http://club.cdfreaks.com/showthread.php?t=210917 but still no patch :frowning:


#4

I got one today. we are looking for tdb. :slight_smile:


#5

do u think this firmware will work on 212d?

http://tdb.rpc1.org/

Crossflash DVR-212D to DVR-212

PIONEER DVR-212 (SATA)
Currently RPC1 firmware based on 1.08 *.

  • TDB Flasher w/Kernel

thanks


#6

There is rpc-1 firmware for both the 212 and 212D from above TDB’s page

PIONEER DVR-212 (SATA)

Currently RPC1 firmware based on 1.15.

PIONEER DVR-212D (SATA)

Currently RPC1 firmware based on 1.15.


#7

The crossflash does not work. :frowning:



#8

Supply more info or no one will be able to help you with…


#9

I’m also having trouble with the new rpc-1 212 firmware, it simply cant see my 212 :frowning: Its see’s my NEC and old DVD-ROM but not he Pio 212. The unit burns and reads perfectly, I’ve changed SATA ports, still cant be found.

Has anyone else had this problem or has anyone successfully installed it to there 212 ?


#10

I can’t seem to flash mine I just get “Available Target Not found” error and have no idea why, the reason I’m trying to flash it is due to the fact it won’t seem to burn DVD’s or CD’s althogh it has no problem burning DL DVD’s, weird???


#11

RMA it… I sent mine back because it would not burn CD-R’s… The new one came today and it is working fine, though I have not tried to crossflash it for DVD-RAM support, though it would be nice. The new firmware does not say anything about crossflashing at TDB’s site.


#12

But it burns DL disks and shows up under device manager?


#13

BTW, if I’m not mistaken, to crossflash a Pioneer drive you need to have the Kernel part of the firmware too, not only the Normal. The 1.15 release, as you can see, says “Normal only”. Eh, am I right? :bigsmile:


#14

Crossflashing [B]requires[/B] a suitable kernel.


#15

Mine burned everything but CD-R’s… I tried everything and coastered a bunch of Maxell CD-R Pro’s (Taiyo Yudens)… I RMA’d it and when I got the new one it worked like a champ. A user at CDRLabs had a similar issue. A few lemons are out there. I suggest you RMA it assuming you have tried to burn quality SL and CD-R media (Verbatim/Taiyo Yuden) without success.


#16

TDB must have pulled the 1.08 crossflash version for a reason… it was a beta, perhaps it is not as ready as they would have liked.


#17

I tried 1.08, and it caused an immediate system reboot when 212_108.exe was executed.


#18

That would be a damn good reason to pull it! :iagree:

I’d guess you tried to flash in safe mode and from WinXP; not Vista, right? Probably not worth the effort though if you had not… No need to render the drive useless.


#19

I was not in safe mode and I am running WinXP. I am surprised there have been no other reports, good or bad, from individuals that have tried this update.


#20

I already have a 212, not the 212D model, so no need to cross-flash. However, I just wanted to use the rpc-1 firmware and it only saw the 212 when in Safe-mode. Flashed successfully and working well :slight_smile: