DVR-110D slow in linux :-(

Hi!

Just bought a DVR-110D, but am really unlucky with it in linux (no I don’t use win and don’t plan trying)

The specs:

AMD AthlonXP 2500+
512DDR RAM
SEAGATE BARRACUDA winchester on the same ide a the DVR-110D (HDA and HDB)
Linux: SLACKWARE 10.2

I bought a 50pack ARITA 8x DVD-R, but can burn them only at speeds of 0,2-0,6x
Burning takes almost 3 hours :frowning:

I tried other burning programs beside k3b, even run growisofs as root, but still no luck. I even upgraded the firmware to 1.22…

The burnt dvd’s are okay and can read back them too…

No, I don’t have other media to experiment with :frowning:

Please help

Using harddisk and burner on the same ide port is a very bad idea. Also check the DMA modes of your source and target drive with hdparm.

It was on seperate cables, but as a last resort I put them on the same to se what’s gonna happen. Reading speed was terrible this way (2MB/sec), but writing speed didn’t change…

So I bought a new fancy cable (tubed - or what it’s called) and put the winchester and the dvd burner on seperate cables.

Writing speed is still terrible (0.3x-0.6x)m and I don’t think that it is beacuse of noname media (ARITA DVD). Why? Beacuse it could writ Fuji CDRs at the speed of 3x!!!

HELP!!!

My previous mail consists of two sentences :). What about hdparm ?

Ok, sorry…

The burner:

hdparm -I /dev/hdc

/dev/hdc:

ATAPI CD-ROM, with removable media
Model Number: PIONEER DVD-RW DVR-110D
Serial Number: EGDL091643WL
Firmware Revision: 1.22
Standards:
Likely used CD-ROM ATAPI-1
Configuration:
DRQ response: 50us.
Packet size: 12 bytes
Capabilities:
LBA, IORDY(can be disabled)
Buffer size: 64.0kB
DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 *udma4
Cycle time: min=120ns recommended=120ns
PIO: pio0 pio1 pio2 pio3 pio4
Cycle time: no flow control=240ns IORDY flow control=120ns
Commands/features:
Enabled Supported:
* DEVICE RESET cmd
* PACKET command feature set
* Power Management feature set
HW reset results:
CBLID- above Vih
Device num = 0 determined by CSEL

=================
The hdd:

hdparm -I /dev/hda

/dev/hda:

ATA device, with non-removable media
Model Number: ST3120022A
Serial Number: 3JT1QNP1
Firmware Revision: 3.06
Standards:
Used: ATA/ATAPI-6 T13 1410D revision 2
Supported: 6 5 4 3
Configuration:
Logical max current
cylinders 16383 64761
heads 16 1
sectors/track 63 255

CHS current addressable sectors: 16514055
LBA user addressable sectors: 234441648
LBA48 user addressable sectors: 234441648
device size with M = 10241024: 114473 MBytes
device size with M = 1000
1000: 120034 MBytes (120 GB)
Capabilities:
LBA, IORDY(can be disabled)
bytes avail on r/w long: 4 Queue depth: 1
Standby timer values: spec’d by Standard
R/W multiple sector transfer: Max = 16 Current = 16
Recommended acoustic management value: 128, current value: 0
DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 *udma5
Cycle time: min=120ns recommended=120ns
PIO: pio0 pio1 pio2 pio3 pio4
Cycle time: no flow control=240ns IORDY flow control=120ns
Commands/features:
Enabled Supported:
* READ BUFFER cmd
* WRITE BUFFER cmd
* Host Protected Area feature set
* Look-ahead
* Write cache
* Power Management feature set
Security Mode feature set
SMART feature set
* FLUSH CACHE EXT command
* Mandatory FLUSH CACHE command
* Device Configuration Overlay feature set
* 48-bit Address feature set
SET MAX security extension
* DOWNLOAD MICROCODE cmd
* SMART self-test
* SMART error logging
Security:
supported
not enabled
not locked
not frozen
not expired: security count
not supported: enhanced erase
HW reset results:
CBLID- above Vih
Device num = 0 determined by CSEL
Checksum: correct

I had the same problem. I solved it this way (i’m not a linux guru, i hope this helps):
first, check modprobe for ide-scsi, if it’s not there, modprobe ide-scsi
if you don’t have that module, compile your kernel
then, in lilo.conf append this line
append = " hdc = ide-scsi"
(replace hdc with where your dvd burner is)

this helped me…full speed instead of 0.2x-0.6x which I had

cheers

Hi everyone,
tenchi, can You say how you installed firmware and from where You have obtained it?

stalker, I have done as You described, but, I still can’t burn on higher speed than 4X.
I doubt You mean 4X when You say “full speed”.

TIA

4x with what specific media?

a classic Verbatim cd-r 52X 700mb. Same thing goes for Verbatim dvd+r 8X 4.7GB.
Sometimes it records on 1.8X. I have noticed no specific cause for this…

I am using cdrecord to record on cd-rw, and growisofs for dvd’s.
With both programs “speed” option is obsolete.

I have a friend who installed new firmware and now burns in full speeds with this same model. But in win :frowning:

Hell yeah, this is sad. :frowning: