DVR-109 not detected in BIOS

vbimport

#1

My DVR-109 seems to burn DVDs fine (and very quickly). My only problem with it is that it only gets detected in the BIOS some of the time.

It usually gets detected correctly when I first turn the machine on, and then disappears after a restart, but sometimes does not appear in the BIOS when the machine is first turned on.

I have updated to the latest firmware (1.17). The drive is on the secondary IDE channel and is master, there is a hard disk on the channel as well, which is set to slave. I have tried having the DVD drive as slave and the hard drive as master, but the problem occurred more frequently in that configuration. If the drive is not detected in the BIOS, it is still detected by windows, and reads discs correctly (I have not tried writing yet).

my motherboard has an nForce 250GB chipset.

Has anyone else had this problem? And does anyone know of a solution?

thanks for your time. :slight_smile:


#2

Sound like a communication problem, Try changing your IDE cable or re-routing them…


#3

Update

Ive now tried burning a DVD at 8x when the drive isn’t detected in the BIOS, but detected in windows. The burn took over 30 mins! The 109’s buffer was jumping between full and empty every second or so, so I assume it defaulting to PIO and the data isn’t getting to the drive fast enough.

The DVD I burned seams to read correctly.

has anyone else has slow writing problems with the 109?


#4

There is a thread about N force chipsets and PIO mode somewhere in this forum.
Do a search and see if you can find it, Nvidea has updated chipset driver that may fix the problem. Hope this helps


#5

I have the same problem with my DVR-A09XL. I don’t think I have the BIOS problem, though I haven’t really chekced for it. I have an Intel chipset, 1.17 firmware and all the current Nero updates.

Nero says it burns at 8x yet it takes about 25min and the buffer drops from around 80% to 40% the whole time. I have the secondary IDE channel set to DMA if available, yet the drive still gets set to PIO mode. I have an older Plextor (slave) that’s running in “multi-word DMA mode 2.”

The DVR-A09XL burned at 8x fine right after I installed it a couple days ago. I burned a couple discs and the only took about 10min at 8x. Then burning programs started locking up before starting to burn. I had other problems, and it had been about a year since my last fresh install, so I did a clean install of XP.


#6

Replace the IDE cable with a 80 wire one > they are recommended & necessary.


#7

I had just started to wonder about that. Couldn’t remember what kind of cable was in there. I had previously been using a Lite-On LDW-811S at 8x with no problems, so I figured I would be fine until it came time to burn at faster speeds.


#8

I put in an 80-wire cable. The drive is still in PIO mode. I tried uninstalling the drive in device manager and rebooting. It doesn’t change anything except now the drive is installed as DVR-109. Originaly it was detected as “DVR-A09XL” by Windows and, I think, in the BIOS as well.


#9

Nobody has any other ideas? Crispy123, let me know if you figure something out!


#10

Now I have any even bigger problem, but it should lead to the solution. I googled and found an article that suggested to uninstall the secondary IDE channel. After a reboot WinXP installed the DVR-A09XL as DVR-109 and installed my Plextor. It had a problem installing the secondary IDE, though.

There was a problem installing this hardware:

IDE channel

An error occured during the installation of the device
Driver is not intended for this platform.

How do I fix this? I have an ASUS P4C800 Deluxe and there doesn’t appear to be any special drivers for it.


#11

I’ve solved my problem. I just had to get the install the drivers using the Intel INF Install utility. The drive is now running in Ultra DMA Mode 4. I’m still curious why it is detected as DVR-109.


#12

All the xx9 drives should always be recognized as “DVR-109”.


#13

Update

Following some suggestions in this thread, I tried a different IDE cable and it now detects the drive every time. The old cable was a 80 conductor, so it should have worked fine… The only difference is that the old cable was rounded but the new one is not. Perhaps there was some cross-talk/interference in the cable and the DVR-109 is less tolerent to it than other drives. Does this sound likely?

It’s still not working perfectly, every 10-15 seconds or so the buffer drops to zero and the refills. Burning at 8x now takes 8 minutes rather than 30 tho, which is a big improvement. It looks like the cables are definitely the problem. Strange they work fine for all my other drives and not the DVR-109 tho…

Is this drop in the buffer level likely to cause problems? The burns complete successfully and the DVDs seem to read fine. Does the drive have buffer underrun protection etc?


#14

A few things: The OPC of the drive kicks in less or more often mostly depending on the used media.
The drive has a UDMA4 Host Interface - most other optical drives only have a UDMA2 Host Interface.
And of course does the burner have Buffer Underrun Protection.

Check eg. in Nero > Recorder settings > options.


#15

What does OPC stand for?


#16

Orthodox Presbyterian Church. :bigsmile:


#17

Well, in that case, I’ll make sure no questionable material is ever put in the drive. :a


#18

LOL

What is OPC?


#19

Thanks. I kinda understand it now. So the OPC will change the laser strength in the middle of the burn? What did you mean by “less or more often”?


#20

It’s written in the firmware how and when the OPC will act.