DVR-109 firmware update problem

Hello there. I am new here, so be kind - :stuck_out_tongue:

I have Sony VAIO VGC-RB44G PC with Pioneer DVR-109 installed. There is version 1.58 firmware from Pioneer website. So I downloaded and try to update it.

But It failed to update. Then I tried DVRFlash ver 2.2 to update.
I got following messages;

Commandline:
dvrflash -vf D: R9100009.158 R9100109.158

Reading firmware ‘R9100009.158’…
firmware is of Kernel type (PIONEER DVD-RW DVR-109 1.58 )
Reading firmware ‘R9100109.158’…
firmware is of Normal type (PIONEER DVD-RW DVR-109 1.58 )

Drive Information:
Description : PIONEER DVD-RW DVR-109
Firmware Rev : 1.00
Firmware Date : 05/05/20
Manufacturer : PIONEER
Drive is in normal mode.

Additional Drive Information:
Serial Number : EEDC026XXXXX
Interface type : ATA
DVR generation : 0009
Kernel type : SONY
Normal type : SONY
Kernel version : 0003

    Status : RPC-2 (region locked)
    Region : 1
   Changes : 4 region changes remaining
             4 vendor resets remaining
             state is 'Region set'

Firmwares and Drive type mismatch
Continue because force option was specified
Are you sure you want to flash this drive (y/n)?

It seem Kernel type and Normal type is “SONY”. That is why I got mismatch error.

So, I stopped operation.

My question is:

If I flash it with Pioneer firmware, what will happen? Will I damage my DVR-109? or Is it OK to flash it?

Any suggestion will be appreciated.
Thank you!

Hi & welcome, masakikura :slight_smile:

If it’s under warranty and you don’t have specific burning problems you’re trying to solve, then leave it as is. Look for updates on the Sony Vaio website instead.

In the opposite case, and you’re sure it’s a DVR-109 (double check the label on the drive), I think you’ll be OK to flash it. You may want to use the Buffalo firmware instead (believe 8.57 is their last release, search the Asus/Pioneer forum), because Pioneer’s original version doesn’t support bitsetting (turning DVD+R into DVD-ROM for better player-compatibility).

You can wait for a second opinion here. :slight_smile:

Firmware 1.00? Oh well, that’s really OLD.

I’ve nothing found here: http://sony.storagesupport.com/dvdrw/downloads.htm
Also: ftp://ftp.vaio-link.com/PUB/Vaio/Optical/

…which is very lame.

Hello. Thank you very much for your reply.

Well. I don’t have any specific problem. But I wanted to update it.

I tried to update once more.
But I got this message from DVRflash and didn’t update firmware.

==============
Firmwares and Drive type mismatch
Continue because force option was specified
Are you sure you want to flash this drive (y/n)?
y

Switching drive to Kernel mode:
Unsupported Drive Type SONY

I tried DVRupdate v1.0. Same things. It didn’t update.

Is there any way to force DVRflash (or DVRupdate ) to update firmware?
Thank you…

DVRFlash (2.2) will not work here because this OEM drive (SONY ID) is not supported. You could try with parameter -ff anyway…
What exact error did gave DVRUpdate 1.0?

You maybe could try with a package from TDB.
http://tdb.rpc1.org/#DVR109

I see the Sony firmware is dated May '05, while Pioneer’s latest is from September '05, so it’s not a huge difference. If you currently get good results, just stick with it and save yourself the hassle. Use quality media, like Verbatim DVD+R 16X (MCC 004), and you’ll be fine - there’s no further updates to be expected for this drive anyway.

What SONY firmware and from where??
1.00 is damn old.

Drive Information:
Description : PIONEER DVD-RW DVR-109
Firmware Rev : 1.00
[B]Firmware Date : 05/05/20[/B]
Manufacturer : PIONEER
Drive is in normal mode.

That’s May 20th, 2005, I’m sure. Guess Sony was late in adopting that drive for their Vaio’s.

Ah, ok.
But normally even OEMs would apply to the name scheme from Pioneer. Sony is again weird.

Hello.

I tried -ff switch on DVRflash. But same result as -vf switch.

DVRupdate, I got following error

PIONEER DVD-RW DVR-109 1.00 05/05/20
EEDC026664WL ATA 0009SONY SONY 0003
Step 1: to kernel mode, Error, because Scsi error with ASC:26 ASCQ:0!

I am not sure why Scsi error. Because DVR-109 is connected with PATA.

Well I guess I have no other choice but use my DVR-109 as is.
Thank you very much for your help!!!

SCSI error because IDE/PATA is using scsi commands…

You cannot flash that drive. It will fail. The OEM drives for SONY and others use specific firmware for their own PCs. Only a pioneer drive bought as a stand alone will allow you to install Pioneer firmware. Sony has no update for this DVR-109. Still V1.00. I have the same drive.

holy old thread resurrection

Yeah, no need.