Dvr 107d problems updating firmware

vbimport

#1

getting error trying flash with dvrflash unsupported firmware or firmware mismatch.
so i tried to force flash
getting this errorCommandline:
C:\Documents and Settings\Administrator\My Documents\My Apps\DVRFlash\DVRFlash
.exe -vf D: R7100107.121 R7100007.121

Reading firmware ‘R7100107.121’…
firmware is of Normal type (PIONEER DVD-RW DVR-107D 1.21 )
Reading firmware ‘R7100007.121’…
firmware is of Kernel type (PIONEER DVD-RW DVR-107D 1.21 )

Drive Information:
Description - PIONEER DVD-RW DVR-107
Firmware Rev. - 0000
Firmware Date - 00/00/00
Manufacturer - PIONEER
! Drive is in kernel mode !

Additional Drive Information:
Interface type - ATA
DVR generation - 0007
Kernel type - GENERAL
Kernel version - 0002

Firmwares and Drive type mismatch
Continue because force option was specified
Are you sure you want to flash this drive (y/n)?
y

Now sending the Kernel part…
// sptxSay.DeviceIoControl: x57 (87) The parameter is incorrect.
// sptxSay x 0 0 8000 E (ioctl status length senseLength)

C:\Documents and Settings\Administrator\Desktop\DVR-107D v1.21 - RPC-1 + 12xRip

  • nx4all>Pause
    any help please :bow:

#2

Use the latest DVRFlash version and try to flash with the official firmware first.
Maybe it’s also a good idea to use the real DOS flasher.


#3

tried using dos to flash cant detect dvr device
dvrflash no device
device shows up in idediag,
and listed as e: drive when i boot into dos
loaded addDEv aspi.sys driver no different
any help would be appreciated b4 i buy a new drive

thanks chicp


#4

Replace the IDE cable or flash the drive in another computer.


#5

Hey i just had a similar problem. I think somehow any other firmware from a non-pioneer site has “possibly” been modified…

So i went directly to Pioneer website and downloaded yet a latter version firmware.

Here try this link…

http://www.pioneerelectronics.com/pio/pe/images/portal/cit_3424/167170096DVR107D_FW121.exe


#6

Wrong conclusion.