DVR-105 firmware update failure -- any recovery tools?

vbimport

#1

I tried to upgrade the firmware of my DVR-105 to ver. 1.33B using DVRUpdate 0.9. Unfortunately, the process stopped in the middle of Step 2 after switching to kernel mode. After 15 minutes I decided to abort: what else I could have done? The drive appeared to be dead. In the end, I tried a re-boot. The drive is not being detected by BIOS anymore.

I don’t know what went wrong with DVRUpdate 0.9 – everybody seems to be happy with this utility…

Any recovery tools for Pioneer DVR’s? Eventually, DOS based…
Is there any way to revive the drive after such a failure?

Thank you


#2

Check out DVRFlash:http://pioneerdvd.rpc1.org/


#3

Thank you for your intention to help me out. However, the document you pointed me to is just the “Operating instructions” brochure and not the real service manual (that costs ~$25 or so if you buy it from Pioneer – not available for DVR-A05 at this time).

I’ll keep looking.


#4

You should be able to recover your drive using DVRFlash and following the documentation. Its simply a case of reflashing the firmware and getting back to user mode (it is now in kernel mode, a very restricted mode designed for flashing and limited system recognition.)