DVD's won't play/write any more!

vbimport

#1

Please can someone help me. I’ve spent 3 days trying to resolve this problem. I’ve gone forward and back with system restore, unchecked/rechecked boxes, uninstalled/reinstalled software so many times and am at a total loss as to how to get this drive working properly.

The problem is the drive works fine with CD media but all of a sudden it doesn’t recognise any type of DVD disk.
I’m new to this forum so I’ll try to give you as much info as I can.
The drive is a Freecom Classic DVD ReWriter (16N9) which I’ve had since mid-April. I made a DVD video ( and played it back successfully) using Roxio Easy Media Creator and a Philips 4x DVD+RW disk soon after I installed it, so it was working ok then.
Three days ago, I decided to back up my files onto DVD and found that the drive won’t recognise any type of DVD media. If I put a ‘proper’ DVD movie disk in my DVD/CDRW drive (the internal one that came with the PC) a dialogue box pops up asking which software to use and it plays fine with Nero Showtime but if I put it in the Freecom drive - nothing.
While the (movie) disk is in the (Freecom) drive, if I click on it in ‘My Computer’, a message pops up saying
" Disk is not formatted"
‘Windows cannot read from this disk. The disk might be corrupted, or it could be using a format that is not compatible with Windows.’
and yet it can read the disk ok when it’s in the DVD/CDRW Drive ??
(I get the same message with any type of DVD media in this drive)

I have Windows XP SP2 with latest updates installed and Roxio,Nero & Ulead DVD software. I have uninstalled/reinstalled both Roxio & Nero and am using the latest updates. Since April, I have also installed some digital camera software from Olympus, Samsung and Arcsoft.

I have run the Nero info tool and all the relevant boxes are checked e.g. CD-R, CD+R, CD-RW, CD+RW, DVD-R, DVD+R, DVD-RW, DVD+RW plus DL and others.

Please, please could someone help me as I’m desperate to back up my files before it crashes !


#2

Hi Jamajam, welcome to the forum.

What you describe doesn’t sound good. Most likely your drive has reached the end of its lifespan. I would advice to install the drive into another computer and then try if it still has these issues. If it has, I’m afraid it is “curtains”…

Regards,
Thom


#3

Hi Tommy - thanks for the welcome.

Are you sure it’s the drive that’s faulty? I’ve only had it less than 10 weeks and it’s only been used a few times.


#4

having both Roxio & Nero installed could be giving you problems, uninstall them both (for nero use nero`s clean tool). then just install Nero.

hope this helps

ako


#5

Do’h! I’m such a bad reader (just like my old NEC 2510)! :slight_smile:

If you bought it mid-april, it shouldn’t be faulty by now. Although on rare occasions I have seen drives dying within one month after purchase. Take Ako’s advice and if this doesn’t work, try the drive in another computer. IMO, this really is the fastest and easiest way to find out if your drive is faulty or not.


#6

Try using a -r or a +r dvd and see if it can handle those. Maybe you need to actually format the rw media before it will work.


#7

i’ve just got a new external emprex s801e external dvd writer, it worked ok until i downloaded an updated firmware file thing through live update, now i seem to be having the same problem!! HELP


#8

thanks for all your replies.

Tommy CP - i’m trying to borrow a friend’s laptop to try the drive on but it won’t be for a few days.

ako - i think i’ve tried only having Nero installed (i did uninstall it with the ‘clean tool’) but I didn’t use the registry tool.
i’ll try it again while i’m waiting to borrow the laptop.

harley2ride - i’ve tried both dvd-r and dvd+r, nothing happens and if i click on the drive with either disk in it i still get the ‘not recognised’ message so i haven’t been able to format a dvd-rw disk, either. also, purpose made movies will not play in the drive although they do in the cdrw/dvd drive.

eggy bref - sorry to hear you have the same problem. maybe the kind folks on here will be able to help.
whilst searching through the forums, i read that some people have had problems after updating the firmware so i purposely haven’t done that as it was working ok at one stage.

further info - whilst searching for help, i looked into updating the driver (this makes me sound as if i know what i’m doing but nothing could be further from the truth!). Freecom don’t seem to offer one relying instead on the Windows XP driver. however, on one of the ‘driver download’ sites there were a couple available. i’m a bit confused because they said they were USB 2.0 cable drivers :confused: but the icon indicated it was for an external drive.
the reason i mention this, is because i have recently installed a USB 2.0 hub (the faulty drive is connected directly to a new USB/Firewire board which i also recently installed, not the hub) and at some stage i lost the ‘USB host controller’ thing. not knowing how to get it back, i simply rolled back ‘system restore’ and it’s been working fine since, but maybe this is causing the trouble.

i’ve no idea how drivers work, just that they allow Windows to communicate with the device, but i was wondering if somewhere along the line, the driver has been altered so that my drive thinks it’s only a CD drive.
could this be possible ?


#9

i won’t be able to borrow this laptop until the weekend but can i just ask a question?
i notice in the USB device properties box under DVD Region it says Current region ‘not selected’. would this have anything to do with my problem? i haven’t altered this in any way so presumably it had this setting when it was working ok.
also, does this mean i can play dvd’s from any region (if it was working)?


#10

To me it sounds like the drive is toast. But just for the hell of it check the region box that you are in. It won’t hurt anything as you have at least 4 more oportunities to change it back. Also am I correct in that this is an external drive that your using? If so what type of enclosure is it? I’ve never heard of the drive before so I’m not much help there. Is the drive set to DMA in the device mgr.? Also like (I believe ako said) Roxio and Nero DO NOT get along with each other. Get rid of Roxio as it Sucks. I think you said you have all the latest updates for Nero but for giggles double check that. You can verify this by opening Nero and clicking on the Nero logo on the upper left corner of its main page. There you will see your version numbers and dates of release. Under that you can click check for updates. Unless you use this for CD’s, I wouldn’t bother downloading InCD as this has been known to throw some quirks into some systems. Hopefully some of this info will help.

Mark


#11

sorry i haven’t replied sooner but it’s taken all this time to find someone’s pc to test it on & guess what - it’s broke !!

i’ve got a replacement which i’ve tested, (plays & burns dvd’s ok) but now i’ve got a new problem.

although it works, the wrong player is listed in Nero. i’m guessing nero gets it’s info from device manager because that also lists the wrong one.

my internal cd/dvd rom is a toshiba sdr 1202 but it says my external usb dvd rewriter is a toshiba sdr 5372v when it should be freecom classic ???

how can i get dev. manager & nero to recognise the drive correctly or should i just be happy that it’s working, at last.

p.s.
Sportfish - even tho’ it’s reporting the wrong drive, i’m still getting the ‘region not selected’ thing.
also, you’ll be pleased to hear that i’ve cocked up roxio & can’t get it to re-install from the disk. i would like to get it working as it does one thing that the other progs don’t do.
i’ll fiddle about with it & if i can’t get it going, i’ll ditch it.


#12

A possible reason your computer recognises the Freecom drive as a Toshiba is because the drive unit in the Freecom external case may be, in fact, a Toshiba. Freecom only fit third party drives into cases. They don’t actually manufacture drives themselves.

Put an original movie DVD in the Freecom drive (best to have something like WinDVD or PowerDVD installed first). You will be prompted to set the correct region for the disk. From then on, you should have no problems.


#13

thanks Mender, i did as you said. i didn’t get a ‘prompt’ but when i checked the region, it’s now correctly set as ‘region 2’.
but it still says ‘toshiba’.

can you just confirm that it’s ok to leave it like this only it might be a bit confusing with both drives being toshiba ?
you don’t think that leaving it as a toshiba will cause any problems in future ?

it’s funny 'cos the one that wasn’t working properly definitely came up as a ‘freecom’ drive. maybe it’s a later model or a different driver or something?


#14

It is basically a matter of try it and see. If it works OK as it is, then leave it like that.

As you say, it is very possible it contains a different drive than the other one, or it may have the same drive but a different firmware version. The one that showed as a Freecom may have been a Toshiba with a Freecom licenced firmware so it was detected as a Freecom :iagree:


#15

ok i’ll leave it for the time being.

many thanks for your help.