DVD's appear to copy BUT won't play anywhere

I’ve been using AnyDVD 5.6.1.1 and CloneDVD 2.8.5.1 on a Sony PCV-RZ54G Media Center pc with all the latest windows updates, my DVD Burner is a Pioneer DVR-107D that came with the PC its Firmware: 1.20. I had been able to make perfectly good copies of commercially released movies (that I always get 1st, the day they are released to help make sure they are not damaged or scratched)

To the point: All of a sudden all copies appear to copy as they normally do, CloneDVD goes though all the motions and time that it always takes, BUT when the disk is finished, I take it to my DVD player to test it and nothing! It always says disk not readable. If I put the disk in the computer it brings up the “what do you want to do” dialogue, and if I go to explore or properties, it shows an empy disk.

I have tryed installing a firmware update I found here, it said it found no target for the firmware.

Today, I tried reinstalling XP from my recovery disks, did all the windows updates, installed AnyDVD and CloneDVD with no extra crap like Nero, etc. and I got the same results. Unreadable DVD. These are the same dvd’s I always use, got them at Sam’s Club they are Verbatim DVD+R inkjet printable.

What I have had to do for the last few weeks is us CloneDVD to copy the movie to a hard drive.

Maybe someone else has had the same problems?
Can Anyone help me please?

@ papagiorgio,

Suggest updating your Pioneer DVR-107D with the new up to date version 1.22 firmware. Below is a link to the newer version 1.22 firmware.

http://forum.rpc1.org/dl_firmware.php?download_id=1754

Also suggest using DVD Identifier (http://dvd.identifier.cdfreaks.com) or DVDInfo (http://www.dvdinfopro.com) and provide the MID (Manufacture ID and Media Code) of the Sam’s Club Verbatim DVD+R inkjet printable media.

Best Regards,
bjkg