DVDRW NEC ND-6650A Drive Will Not Boot

vbimport

#1

Hello,

I have a IBM Thinkpad T30 Laptop on which I recently upgraded my DVD Drive to an Internal DVDRW NEC ND-6650A.

The drive works fine, and is able to burn all the media types that it should.

However, when I change the BIOS Boot Order to boot from the CDROM/DVD first, this drive just won’t boot. I’ve tried a bootable Fedora 5 Linux DVD, as well as a Windows Bootable Installation CD. I’ve used the same bootable CD/DVDs on other Internal Drives/Systems and they boot properly from it.

It would appear that Windows and Linux are able to detect the drive, but the BIOS isn’t.

Will an upgraded firmware for the drive resolve this problem?

Please help.

Thanks,
sanjibm


#2

do this:

install the cd rom or dvd drive that came with your computer new.
run the nero info tool and inspect the configuration once it completes
look to see where your computer sets up the orginal drive

is it the secondary ide channel as master or slave?
dma should be on by default.

write this info down as it is what you want to see from the nec 6650 drive once you install it in and boot up.

i will be willing to bet the 6650 does not set up the same way as the drive that came with your computer.

the reason why you can’t boot up from it is the way it sets up.

if your original drive sets up as master in the secondary ide channel i will wager the 6650 sets up as slave in the secondary channel.

no firmware will correct this.

look around here for soldering tips or reverse ata at liggys site.


#3

Unfortunately, I don’t have the old DVDROM drive with me anymore. Sold that off a few days after the NEC 6650 arrived :sad:

I did try using the Nero Info Tool, and I checked the configuration with it. The current NEC 6650 Drive sets itself up as :

Secondary IDE Channel : Master

with DMA set to ‘on’ and Autorun ‘on’

I was also parrallely trying to see if the binflash tool (v1.28) would be able to scan my drive and report the configuration. It failed to find any supported drives when run from linux (using necflash -scan) or from the windows GUI version. Using the -v option did display the drive (firmware version 102C) , although it kept saying that it was unsupported.

Finally I tried once again in Windows, this time replacing a media inside the drive with another with the binflash GUI running in the foreground. And while the new DVD was autorunning, the Windows GUI version of binflash was able to detect it as a supported drive. This looks like a bug to me. Once again I closed binflash and reponed it to find that it wouldn’t find any supported drives. Very strange behaviour.

Coming back to the original problem, if I understand correctly, you suggest that changing the NEC drive from master to slave on the the secondary IDE channel using the reverse ATA tool should resolve this problem. Will the DMA being ‘on’ have any effect?

In the meantime, as you suggest I am going to try to get hold of a friends DVDROM drive (which boots properly on a thinkpad) and check out how its set up.

I guess soldering won’t work for me as its already set up as master.

Thanks a ton for your help on this,
sanjibm