Dvdrw ide1008 - HELP PLEEZ

vbimport

#1

Hi All,
I have been trying to get DMA enabled on my I/O magic DVDRW1008 drive. I am using 0159 firmware which I just upgraded. I have contacted I/O magic and they have had me delete and reinstall the drives and both channels. I also went into the Regedit and did some things they told me to there. It still says DMA is off. I went into the BIOS but saw no option to adjust it there.

OS: Windows XP SP2
Dell Intel P IV

I have also gone to windows and tried all of their suggestions. Does anyone know…does DMA mode exist in this drive? It seems to me this thing is junk! I have seen other threads with people in the same boat, but I have tried everything I could find. Does anyone have any words of wisdom or can you recommend a drive that will actually work!

I have about 15 coasters now from trying different things and trying to write. The write process always fails.

Also, I only have 3 channels on my motherboard, so I can’t put the burner on its own. I have deleted the master and slave in the regedit and that doesnt work either.

Thanks for the help…I am extremely frustrated…this has been going on for weeks.

Alicia


#2

usually when you are in the bios of the computer, the page where you can change the time and date has also the list of the drives, primary master and slave, secondary master and slave floppy ecc… On mine, it is set on auto, but if I select for example secondary master and press enter, it goes into another window where it shows the drives name, pio modes and dma modes, that is the place where you could have the dma off by default

how do you know that the dma is off? what are you using to detect it?


#3

I finally got the drive to work, but i had to install the burner as the master and reader as the slave. Now i cant read any video dvds in the reader and it reads at an extremely painful rate. I know the DMA is off because it says so in the device manager. It sets anything that is the slave on channel 1 to PIO mode. I cant get channel 0 above DMA mode 2. I am going to call Dell to find out what the heck is going on. I think it may be the way intel processor is set up. I saw some info on windows about it and a way to fix it, but I dont know if I have DMA66 on my drive and i dont want to screw anything up.

Thanks for the info…
alicia


#4

I’ve had the IDE1008 at Firmware Rev 0159 for about a year. The DMA is working under Windows 2000 SP4 at UDMA 4 (UDMA/66). IO Magic recommends that the IDE1008 be put on the secondary IDE controler as 'Master"

I’d make sure that your BIOS is set to UDMA Mode 4, 32-bit access if the option is available and then go into Device Manager and check the settings on the 'Primary" and “Secondary” IDE controllers. They should be set for “DMA if Available” on the “Advanced” tab. You will have to reboot afterwards if you make a change.

Also, if memory serves, UDMA 4 support and higher did not come along until either Service Pack 2 or Service Pack 3. In any event, I would download SP4 and install it. A good idea is to save it to a CD for future use. Ms may pull support for W2K fairly soon.