DVDRW IDE1004 Firmware update problem

Hi,

I have a Emprex 4x burner and have recently run into an issue. Firstly I never noticed the problem until I tried to burn a dvd through Nero and was unsuccesfull, although I had been making DVD’s with TMPEG dvd authoring software without any issues (drive also works fine in recognizing DVD’s and burning CD’s with Nero). So I found this site and check out the help thread for my drive and first thing is update firmware. Well I try to update the firmware, with the Liveupdate program recommend on the BTC site and with just the firmware update, everything looks good, d/l update for version .043 to .450, untill “WIndows Flash Program” window pops up, all fields empty except in the bottom window says “It’s only for (1) DVDRW IDE1004” and the drive never updates (I have a screen capture of this if needed).

I am running XP, my HD is on primary by itself and the DVD burner is on secondary by itself so I don’t think that should be an issue, i’ve checked the other troubleshooting ideas except I haven’t gone digging around for and deleted old program registry entries but I wouldn’t think that would affect the firmware updating.

Any ideas? Im thinking I may have to upgrade the Firmware manually/force it somehow?

Thanks

Sure, post the screenshot of the error message that you are getting.

If the windows update continues to fail, you can update the drive by obtaining a .BIN file of the firmware and using MTKFlash to update in DOS.

I once owned a BTC 1004IM (which is what you have).
I also had the same problem, but it was only with one version of the flash utility. If i recall correctly, there was a utility which came with the drive? Try using it instead of the live update program. All i know, is that it worked eventually.

Hey,

Here it is:
http://members.cox.net/fernie1/FW-fail.jpg
The target drive field is also blank and shows no drives, I tried typing in the drive letter but it still would not recognize it. I will check the discs that came with it to see what else is there. Thanks

try to download fw 0450 from here i flashed under winxp pro without problems,

you can also try the rpc1 0350fw from dangerous bros. works also great with winflasher.

or you flash the drive in dos like wes suggested

Thanks guys.

Okay, it looks like im either going to have to use MTK and flash in dos or try the “rpc1 0350fw”. Is win flasher a program I need to flash the rpc1 0350fw files? Also if anyone could point me to a link for the 0450 bin file that would be great. Thanks again!

One other thing to note after researching more on this issue is that I do have a nforce board with the nvidia ide drivers, may be causing this problem???

Yes that could be causing your issues.
Try uninstalling the Nforce IDE drivers, and then rebooting so that the default Microsoft drivers are loaded. Nvidia IDE drivers are notorious for their incompatibility with DVD writers.

Also, make sure that your burner is jumpered correctly (as master), don’t use cable select as that could cause some recognition problems…

ok, I am posting in this forum as I have noticed that this page is link number one on google when searching for “DVDRW 1004 Update”.

I had many problems whilst trying to update my firmware on my BTC DVDRW 1004 Drive. I tried many different version of firmware but none seemed to work. For the most part, I was getting error messages along the lines of Error 50/2/0 or something along those lines. I too have an nForce 2 motherboard. After some hunting arround, I came along this site which had a link posted to http://tdb.rpc1.org I downloaded the firmware version 051 and decided to give it another go.

Once I had downloaded the firmware, I rebooted my system and then closed any applications that started up. (Such as MSN etc etc…)

My current firmware was version 040 which was present when I bought the drive. I then ran the IDEFLASH.EXE that was in the rar file and it updated fine…

I hope that someone searching Google for ideas on how to resolve the firmware updating issue finds this post useful as much as I did.

Hi,
I had some problems while trying to update my firmware on my BTC DVDRW 1004 Drive too. The message that i got while applying the v0051 is :
This firmware can be used on below drives :
(1) DVDRW IDE1004 .
Check Sum : 27D9
Please wait a minute…
Execute command errorA!! 5/20/ 0
Flashing is incorrect!!
The current revision of the firmware is 0040. I would be very thankfull to have some helps.
Thierry.

try an other fw, download @ dangerous brothers the link is in my sig.

or you can flash under dos.

Thanks a lot,
i will try to flash under dos.

Hi all

Do you know where i can find a link with the previous firmware for my btc dvdrw 1004 ?

Thank s for your help :wink:

@+

The Dangerous Brothers there you can find all previous versions. these are rpc1 modified btc fw´s

Many thk’s for your help Herbei :wink:

@+

I’m desperate as my computer is experiencing several crashed after firmware update… :sad: … I need IT to work as soon as possible!

…so yesterday I updated the firmware of my Waitec Storm 40 cd burner. (I used the winflash tool and the .bin file from Waitec website).
Everything seemed fine after restarting, except that my old burner still didn’t work - not big deal I thought as I already planned to buy a new burner.

Half an hour later disaster - Blue Screen !

 KERNEL_DATA_INPAGE_ERROR
 stop: 0X0000007A (0XE1995D88,0XC000000E, 0XBF93095D, 0X129FE860)
 WIN32K.SYS Address BF93095D base BF800000, Datestamp 41107f7a

I start to Panic about the firmware update.
As I restart the machine I had the error: Searching for Boot Record from IDE-0…Not Found.

Only after I left the machine few minute powered off, I had the chance to full start up into windows - but, not long after I had the second Crash:

 stop: 0x0000007E (0xC00001D, 0XF7577595, 0xF797A7B8, 0xF797A4B4)
 CLASSPNP.SYS address F7577F95 base at F756F000, datestamp 41107EC2

I went on the Ms website and I donwloaded the Windows Memory Diagnostic (mtinst.exe) - I let it run all night with the /t flag on for deep scanning…all tests yielded no problems.

This morning I had an error on the starting up Windows’ screen:
System cannot start as the file …\system32\hal.dll is missing or damaged
After playing around with boot floppy disk, Safe mode, debugging mode finally I managed to load the OS again.

I disabled from the device manager the CD burner …
I disabled from the device manager the other CDRom …
I disabled then the graphic card as the first blue screen adviced …
I backed up hal.dll and substituted the file with a new one from my wife’s computer.

No success…still crashing.

I tried to run NOD32 antivirus in a deep mode and as long as I could see before crashing again, I have 3 viruses (somewhere in Documents and Settings/myscreenName/… archive … /application data /… {08af34dd some long number } ).

I read that virus can cause start up problems damaging the boot sector but it’s too strange coincidence them get triggered just after flashing the firmware memory!?!?

System Specifications:
OS Windows XP professional sp2
Processor 886 Pentium
BIOS: AMIINT - 10 Version 1.00,02/08/02 (Updated a month ago)
Graphic card: NVIDIA RIVA TNT2 Model 64/Model 64 Pro
bus: PCI, ISA
Ram: 768 MB
HD: primary partition: C: 14.6 GB (3.53 GB free) ; secondary D: 4.96 GB
File system: NTFS on both partitions

I’m really lost as all the infos I could find take to one solution: updating the firmware :frowning: in my case the update has been the problem!!!

Please help me! :bow:

Many thanks

Welcome here

here are some infos about your devective hal.dll

and here
Kernel Data Inpage error

i think that the first errors are caused by the flashed drive, try to disconnect the flashed drive completle (ide cable) and try to boot.

hi H3rB3i, thanks for your reply.

I disconnected the drive, I could boot aftewoods but I still have crashes problems…

I’m trying to work out with the recovery system and as the MS Kbase says at the 0x7A bug related page.
Unfortunately The chkdsk /R has stopped at 1% saying that the Volume has one or more fatal error… What does this means this…
I’m worried I had destroyed my pc …Help! :confused:

Sounds like your Hard Drive is duff. Get a new one and load a new clean version of Windows. Don’t re-connect your old HDDs until you’ve installed a decent virus scanner and then make sure you do a full virus scan on them before you copy any data off.

Why does everyone keep telling people to go to Dangerous Brothers for Firmware. THEY HAVE OLD FIRMWARE, CHECK IT OUT! It’s probably older then you have on your drive right now.

Can someone PLEASE help me ! I have an emprex usb 2.0 external
dvdrw (1016). It was working perfectly fine on my windows 98, but I did
a fimware upgrade and it no longer works !!! I updated with the
wrong firmware and a ‘update failure’ message showed up.
It can’t be detected by windows and if I try to open the drive
to put a disc in it, it wont open. It’s not responding to anything.
PLEASE tell me how to get and reinstall its origioanl firmware !!!