DVDROM-Speed Problem

Here is my system specs:

AMD 1.2GHz w/. 768mb PC133 on MSI K7T Turbo Ltd. Ed.
2xWDC on primary master and slave.
Liteon 166s on secondary master and LG writer on sec.slave.
WinXP w/. SP1, 4-in-1 not installed, DMA enabled on all drives.

Problem begins…in Nero CD Speed…
My problem (not only to this Liteon drive but also to my Sony 16x, LG 16x, AOpen 16x and Pioneer 16x) is that my DVD read speed (I tried with many different DVDROMs and DVD-Video discs) max out @ 10x, then the speed decreases a bit. The reader starts @ about 6.87x and peaks @ 10.3x, then slows down to about 8x @ the end of the disc.

What do you guys suggest? I tried formatting the HD, reinstall XP, also same thing happens.

Which firmware version is your LTD-166S drive using? Please update it to the latest DS0F version and test again.

I know it’s definitely not the drive itself…I have posted a user-review of the 166s yesterday…but just didn’t get to do the DVD benchmarks done due to this problem.

I mentioned all the 16x drives I have have the same problem, all latest firmware, etc. All max out @ 10x for DVDs…

I was thinking if I have a bottleneck somewhere in my system…

Originally posted by Raz0rX
WinXP w/. SP1, 4-in-1 not installed, DMA enabled on all drives.

How do you expect to use DMA if you don’t install the drivers for it? :cool:

Install the latest VIA 4in1 drivers and it should fix your problem. :wink:

OK, loaded the latest 4.45 ViA driver, still the same result.

I had DMA enabled on all drives and still have enabled after 4-in-1 is set up.

I have even tried format the HD and then setup Win98SE a few months ago, it gave the same result too.

Windows XP has NATIVE BASIC VIA IDE Controller support.

The IDE Driver provided in 4in1, aka Hyperion 4in1 can’t bring you any performance gain, it’s much or less the same as Windows Native driver. Download IDE Miniport 3.014 to have higher performance.

Raz0rX,

The slowdown that you are experiencing in reading DVD discs could be caused by a defective or hard-to-read disc, but since you have tried a variety of discs this is not likely. Also, as I’m sure that you know, a dual layer DVD will read much more slowly than a single layer and after reaching a peak will gradually slow until the end of the disc is reached.

What results do you get in CD Speed for audio and data CD transfer rate tests? Are they normal - 48x for these tests with the Liteon drive?

Have you checked the system BIOS settings for the secondary IDE channel? It usually would be set to auto-detect, but you should investigate this and make sure that it is set to an option that allows full speed.

BTW, the Nero DVD Speed program is much faster for testing DVD drives with DVD discs. :slight_smile:

Yep ok, thanks Richteralan for the mentioning of MiniPort driver, I downloaded the version you mentioned, and load the IDETool, showed that my DVDROM is only Multiword DMA Mode 2. OK so I tried to run Nero DVDSPeed, gave me an error about “invalid drive parameter”. So I uninstalled the IDE tool, tests run fine but still the speed @ 10x max. Before I uninstalled the IDETool, I tried to change to UDMA 33 Mode 2, but after reboot, it didn’t change, still Multiword DMA.

Also Inertia, thanks for your tips. I used single layer 4.18GB DVDROMs, not dual-layer. My mobo has latest firmware and the drive also has latest firmware.

I think some other people who have mobo based on KT133a chipset have the exact same problem as I have.

My CDSpeed result:
http://www.geocities.com/rrazorrx/liteon166sreview.pdf
(copy and paste this URL in a blank page broswer)

Raz0rX,

Your results in data transfer with data CD’s are normal for this drive. The DMA Multiword 2 bandwidth of 16.7 MB/sec. is adequate for full performance in CD reading, which requires (52 x 172 KB/sec [raw]) only 8.9 MB/sec for a 52 speed reader.

This is not the same with DVD reading, which spins 3x faster than CD at the same speed rating. At 1x speed, a DVD transfers about 1,108 KB/sec. At 16x, a DVD will require 17.7 MB of bandwidth. This exceeds the capability of DMA Multiword 2, and explains the cause for the drop in performance.

At 10.3x the DVD is using about 11.4 MB/sec of bandwidth, and although this does not approach the theoretical capacity of DMA MW 2, it is probably hitting the practical capacity in your system.

WinXP has a known bug in that is sometimes spontaneously resets ATAPI device connections from UDMA to PIO mode. There is no known fix at present but there is a workaround. This involves going to Device Manager and removing the IDE channel to which the PIO device(s) are connected and rebooting. Upon rebooting the IDE will be detected and the devices will be reinstalled. Usually this works to redetect and restore the UDMA capability of the ATAPI devices.

Your problem does follow this pattern exactly, but it is similar. It is possible that this bug in WinXP has reset your drive connections to DMA 2 from UDMA 2 (33.3 MB/sec). I would suggest trying the fix above by removing the secondary IDE channel.

Let us know if this works. :slight_smile:

Inertia, thanks a lot for your help. Without removing the secondary IDE channel, the system is using Multiword DMA Mode 2 and from that drop down list, only two options (to use PIO only and use DMA if possible). I tried your method of removing controller, reboot, still am using Multiword DMA Mode 2:rolleyes:

Right now, I have completely removed IDETool/Miniport driver since it does not allow me to run CDSpeed/DVDSpeed if I have these driver installed (so strange).

In the BIOS screen, the DVDROM is detected as ATA/33 device, but XP puts it as Multiword DMA Mode 2 (16.6mb/s?). I even used an 80-pin IDE cable.

What other hardware devices are connected to your computer (including motherboard)? What software is running in the background?

For testing purposes, I disconnected the LG writer which was on sec.slave.

Here goes:

MSI K7T Ltd. Ed. (KT133a) w/. 768MB PC133 w/. AMD 1.2GHz
Leadtek GF3
SB Audigy
NICx2
WDCx2 on primary master and slave (both ATA/66 enabled in XP)
Liteon 166s on secondary master

Software running in background:
NAV 2003
ICQ
Mail.com mail alert

Did you notice any difference after disconnecting the LG?

My next suggestion is to reverse the master/slave connection of these drives. Of course, this should have no effect, but computers can be very fickle due to unknown conditions. If you decide to try this, don’t forget to change the jumpers in the rear of the drives. :wink:

Yep, after I disconnected the LG drive, ran some tests again but still same result for DVD reading.

Like your said, reverse jumper setting, put the drive to sec.slave and changed to another 80-pin IDE cable, still same thing, XP detects as Multiword DMA Mode 2.

I don’t think that this problem can be very easily solved or it can’t be solved @ all:eek:

Yes, I know that is is frustrating to have a problem like this.You could go to the 4in1 Drivers download page and try the older drivers one at a time to make sure that this is not a driver issue.

The Microsoft Knowledgebase article at Programming of Transfer Mode Speed Is Not Supported by Atapi.sys When You Hot or Warm Swap Drives does not match up with your problem, but it gives insight as to why swapping drives or removing the IDE controller works to restore UDMA modes.

Meniak has found a fix for his Plextor being reset to DMA multiword 2 mode by using a registry patch originally designed to force UDMA 66 mode in Win 2000. When he applied this patch to WinXP, his Plextor has run in UDMA mode 2.

This may be what we have been looking for. :wink:

See Enabling UDMA/66

If you would like to perform the operation manually, you can do it by browsing to the HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class{4D36E96A-E325-11CE-BFC1-08002BE10318}\0000 key and adding a new DWORD value called EnableUDMA66. Set the value to 1 to enable UDMA/66 or to 0 to disable UDMA/66. Or you can use the following registry file

Enable UDMA/66

I was hoping that the UDMA patch was going to work but … still no go:eek: God damn it…someone on the other forum said it might be the ViA Southbridge that has particular problem…I still remember when I had a Liteon 48x CDRW on secondary channel, XP still loads Multiword DMA Mode 2 no matter what, but for writing/reading CD, of course that didn’t matter.

But Inertia, thank you very much for supplying all those links!

Sorry it didn’t work, but did you try removing the secondary IDE channel and rebooting again?

WinXP has to redetect drives before any change to higher connection speeds can be made, even if the system supports the higher speed.

OK, I just removed the sec.channel and about to reboot…then saw your new msg:cool:

After reboot, same old Multiword DMA Mode 2.

Let me try those IDE Miniport driver again.