DVDR1000 'no disc' error

Hi All

I just bought a second hand Philips DVDR1000 (DVDR1000/171 Nov 2001) that will read audio CDs fine, but not DVDs of any kind. I tried commercial movies from USA and Australia, +R, +RW, -R, VCD, CD data and DVD data discs. All display ‘NO DISC’. Interestingly, when I put in a blank DVD+RW it says ‘EMPTY DISC’ and recognises it as a DVD+RW disc.

I have upgraded the firmware to ff9p but it didnt help. My questions:

  1. Is that the latest version?
  2. The thread above recommends the revision before (ffpo) why?
  3. Is it possible to get/install a new laser?
  4. Why does the Philips site tout v6.3 as the latest version, is that later than ff9p?
  5. How can I tell what the region it is set to read DVDs for ?

My Firmware version details is:
BASE_SYS 20030703_FF9p 20030704_1330zp.

Maybe its just plain broken? I bought it cheap unseen accepting the risk, but I would really like to try and get it going. I have even tried to use a laser lens cleaner, but it just acts like all the other discs and reads ‘NO DISC’. So it doesnt display the diagnostic info on the disc, or get to the cleaning track.

Any suggestions would be very welcome and appreciated.

Thanks!
Glen

Sorry - some cookie malfunction prevented me from seeing this additional post on the thread.

To answer the specific questions:

  1. Yes, ff9p is most probably the latest version for the DVDR1000. However I vaguely remember reading something about an ff9q version appearing in the 6.2 service release collection, and which I need to investigate.

  2. The link is to an old page which wasn’t updated. Thanks for pointing this out and I’ll include the newer version in a firmware update sticky currently being prepared.

  3. It is possible, but Philips will have to do it for you and it probably won’t be cost-effective.

  4. As described in the ‘firmware upgrade, downgrade’ sticky at the top of the entry page to this forum, ‘6.n’ refers to a software release for all Philips recorders and not to a specific machine. The individual firmwares within the newer software release may be updated, or for these older machines, almost certainly not.

  5. You can’t tell until you put a wrong one in, then there’ll be a region-related message. The problem is that your machine won’t recognise the discs themselves and cannot even start to interpret the region setting. There are a couple of easy region-free hacks for this machine, but of course it would have to be working first.

If your machine will recognise +RWs then have you tried recording anything on them?

If that’s the original DVD1000 model without hoping to sound too negative…it’s knackered. :sad:

Hi Glen,

I’ve got exactly the same problem. I thried everything but realy nothing worked. I even looked inside the dvdr1000 and cleaned the laser with a wet paper, but unfortunately it didn’t worked.
When you know how to solve the problem, could you send me an e-mail to avd117@hotmail.com because I want to repair the dvdr1000. It is taking 1 year by now and it still doesn’t work.

I hope that you can help me!

Bye,
Arthur

The Philips DVDR1000 is one of the most unreliable recorders.
Being so old it’s certainly not under guarantee and without doubt the laser assembly is knackered. :doh:
What makes it sad is the Philips DVDR1000 & DVDR1000MK2 are the best looking recorders ever. :iagree:
Pity they don’t work for long. :sad: