DVDFlick problem

vbimport

#1

I recently ran into a problem with DVDFlick.
Has anyone else experienced this problem ?
I tested this on another movie & no problem with it.
I haven’t yet ripped & third movie but I’m going to & test.
Could this be some odd copy protection left behind ?
I used AnyDVD with CloneDVD2 for the rip.
I haven’t yet tested with DVDFab.

When trying to use DVDFlick to create a a menu for a whole movie vobset.
Only one title to be in the menu.
This is done by "add title " the first .vob file. For example: VTS_01_1.VOB
then using “edit title” /“Video sources” the “add” . This is supposed to append the rest of the .vobs in the set to the first .vob .Creating a single title.
The problem is DVDFlick reads the first title frame rate as 29.97fps which is correct . It reads VTS_01_2.VOB with a framerate of 60fps . This is not correct as I will show with MediaInfo & could with G-Spot too.
This is the DVDFlick error:

This is VTS_01_1.VOB MediaInfo:

This is VTS_01_2.VOB MediaInfo:

This is VTS_01_2.VOB DVDFlick:


#2

Don’t know what is going on there cholla. You could try running the decrypted dvd through FixVTS and see if that helps.


#3

I did a rip with DVDFab & got the same results with the VTS_01_2.VOB .
I also tried FixVTS & DVDShrink the VTS_01_2.VOB still shows as above.
The reason I am working on this is because of the Custom DVD topic geno888 started.
I thought I would just rip a DVD with the language tracks all on it . Then when trying to load that this odd 60 fps reading by DVDFlick .
I’ve already ripped another movie & am working with it . It doesn’t have the problem.
What I was wondering is did I find some kind of hidden copy protection in this movie .
The name of it is xXx with Vin Diesel. The final manufacturer is Sony Home Entertainment.


#4

Will Vob2Mpeg merge the vob files into an mpeg2 file without having a nervous breakdown? This tool is so easy to use and so quick, I find it saves headaches to use it before importing any dvd-video files into AVStoDVD…don’t use Flick much.

When the dvd video is split into 1gb sizes to create the vob files, the cut point is fixed by size alone and doesn’t always have navigation headers at the very beginning of the vob file. This one may occur in a place that is causing Flick some problems to process.


#5

This seems to be more a DVDflick issue as opposed to some “hidden protection” issue…Just my thoughts…This is precisely why I get tired of some of the freebie proggies, always giving ‘me’ some issues…Purchased ConvertxtoDVD and never looked back, got rid of the rear-view mirrors sorta-speak…Not to say that they’re all bad or that all commercial ones are all good…I do favor HCenc which is why I also prefer DVDRB Pro or the freebie one is good too…
Whatever works eh!
Cheers!..


#6

Hi t0nee1 , I haven’t used ConvertXtoDVD since I used the trial a few years back. It might be the solution to making good menus . If so you might post in geno888’s topic with your opinion on how well ConvertXtoDVD works for creating a menu & some instructions. Maybe even a screen shot of a menu you have created with it. I think one of geno888’s concerns was using multiple languages so how well does ConvertXtoDVD do that?
http://club.myce.com/f32/how-make-custom-dvd-321047/
I use DVDRB the free version . I’m now using HCenc version 26 in it . It has worked well for me with the free version but if I ever need the features of the pro version it is a software I will buy.

Back to the DVDFlick problem .
I ripped two other DVD’s & neither had the wrong fps on any .vob . However I still haven’t got a multiple language menu that works correctly with those.
I actually did 3 more rips of XXX one with each language only . When there is only a single language in this case English .French , or Spanish the VTS_01_2.VOB reads the correct fps 29.97 . It is only the multiple language rip that has the 60fps read that is incorrect. This was the case with a CloneDVD2 & DVDFab rip . I also ran the CloneDVD2 rip through FixVTS & DVDShrink doing an analyze even though it said I didn’t need to.
The results were the same with the 60fps VTS_01_2.VOB .
So I have tracked the problem down to the multiple language rip. Any ideas why DVDFlick has a problem with this ?


#7

cholla, you’ve certainly gone further than I when it comes to DVDFlick’s problems with vobs. I’ve yet to get any commercial movie completed with DVDFlick or DVDstyler or Avs2dvd. With Flick I ususally get “failed to generate thumbnail” on the 2nd or 3rd vob added and it shows the duration as -1 second. None of the movies I’ve tried, Star Trek, The Reader, Inception, have multiple audio tracks in the ripped vobs. The only success I’ve had with vobs as input has been with home movies I’ve made myself using DVDFlick to create the DVD structure first and then using the generated vobs as input to DVDFlick again as test projects.


#8

@ Whappo & this may help geno888 too . I found a solution that worked on XXX & I believe it will work on most commercial movies .
I didn’t find the reason DVDFlick has a problem with multiple language tracks. It has a problem even with movies that it doesn’t read the fps in any .vob incorrectly. If you add list the first .vob & append the rest with edit title/add more than one audio track will load incorrectly. What I found was all but the first track will have silence beginning after the second .vob . The first track will only play the first audio track but has part of the other audio tracks . So in other words a mess.
Now for the solution :

  1. First you need to rip the movie to the HDD with decryption software. I used AnyDVD with CloneDVD2 but DVDFab should work too.
  2. You need to check the order of the audio track languages with VLC player. You need to open the VIDEO_TS folder with VLC for this information. Under the Audio pulldown it will list the language by the Track.
    DVDFlick won’t tell you what each audio track language is. I tried Media Player Classic - Home Cinema for this but it didn’t get the order correct. I hope VLC will do this correctly for all movies. You need to check this here because the joined .vob in the next step will have the Audio tracks but the language won’t be shown . You can find it by listening.
  3. You need to join the .vobs in the VIDEO_TS folder.
    I used & like the Join VOB Files Tool (freeware) available here : http://beginwithsoftware.com/videoguides/joinvobfilestool.html
    I have previously contacted the author of this tool & he personally responded. With this information:
    "all VOB files are joining (copying in one target file) in binary mode - byte for byte, that is all."
    So it shouldn’t make any changes inside the .vobs.
    I use the movie title for the name of the .vob in Output .
  4. "Add title " this single MOVIE.vob in DVDFlick.
    Then “Edit title”/ Audio tracks highlight each track & select the correct language for that track in the pulldown window to the right of “Track”. These will be in the order you checked with VLC player. If you don’t all the tracks in the Audio track menu will show as English even if the aren’t.
    After you have selected the language for each you can Moveup or Move down the tracks to the order you want on the Audio menu. Make the other settings you want in “Edit title” for example movie name & Target aspect ratio in General . Then “Accept” .
  5. Select “Project settings” make the settings you need. Their is one setting you can make that will speed things up & encode a lot less . So it is better to use it if it works correctly on the movie you are working on. It is trial & error on this.
    The setting is “Project settings”/Video/Advanced/ Check “Copy MPEG-2 streams” .
    Then “Accept” .
    When DVDFlick finishes you have to watch the movie to see if there are problems . If there are it was probably caused by this setting & you need to uncheck it & let DVDFlick do the long process of encoding.
  6. Select " Menu settings" . I use “Mosaic” & “Auto-play menu” checked .
    You can check " Show audio menu first " .
    Unless you have text subtitles which is unlikely with a movie vobset you won’t need to check " Show subtitle menu first". You probably won’t need to do anything with subtitles anywhere in DVDFlick. And you won’t have subtitles.
    If you want subtitles then you would need software that would extract them.
    Then you should be able to add them to DVDFlick. I’ve never done that so I can’t say it works. When the single movie.vob is played in VLC the subtitles are there. DVDFlick just doesn’t detect that type subtitles .
    I hope this guide will help .
    Give it a try Whappo & let me know if it worked for you.

#9

[QUOTE=Kerry56;2585571]Will Vob2Mpeg merge the vob files into an mpeg[/QUOTE]
Kerry I have Vob2Mpeg installed & have for a long time. I have never been able to get it to work . In vobset mode I get this message:

Basically this tells me it did nothing & the Output folder is empty.
I looked at the log but it contained no useful information.
Any ideas to get it to work in Vista?