DVDFab too zealous in marking VTS as fake

I’ve had this with quite a few DVDs now, whereby DVDFab appears to be over-zealously removing fake vts files. Is there anyway to rein in DVDFab’s habit?

I’m making ISO copies of purchased DVDs for loading and subsequent playing back from a networked device and use either Clone or Full Disc mode depending upon the disc. Although the ISO is successfully created, when played back many of the DVD menu entries don’t work or (more essentially) parts of the disc’s ‘additional features’ won’t play.

For instance, with the disc “OLD_GREY_WHISTLE_TEST_DISC1” DVDFab’s summary screen reports “13 fake vts protections are removed” and the resultant ISO fails to play all of the interviews and some of the introductions. However, when I launch those supposedly fake vts files from the original DVD, they play the removed videos without problems.

[QUOTE=astage;2306271]I’ve had this with quite a few DVDs now, whereby DVDFab appears to be over-zealously removing fake vts files. Is there anyway to rein in DVDFab’s habit?[/QUOTE]

I’ve never seen this personally and I don’t recall seeing it posted previously.
Honestly, I’ve never paid much attention since I tend to disregard most “extra” features.

As just a guess you could try the following:

  1. Untick [B]Copy DVD-VIDEO DATA ONLY[/B]…not sure about this as it is still video data,
    but perhaps Fab is stumbling re: this.

  2. Disable PathPlayer completely.

  3. Try combinations of 1) & 2)

  4. Send the .IFO files to Fengtao
    You can do this from [B]Common Settings > Info [/B]and click on
    [B]Send IFO Files [/B] tab.

In the event of a problem, you can send the .IFO files manually.
Fengtao has a sticky near the top of the forum with instructions.

Thanks for the reply.
I already have 1) unticked, and have tried 2) although normally have DVDFab set to “always enable”, but that didn’t make a difference.
As a test, I tried putting the “Old Grey Whistle Test Vol1, Disc1” through “RipIt4Me” and “DVD-Decrypter”. This took all the data across and all the menus work as expected.
I’ll try sending in the IFOs.

In Clone mode, try putting a checkmark in the “Copy Original IFOs” box. This will leave some of the protections intact but may help.

[QUOTE=signals;2306388]In Clone mode, try putting a checkmark in the “Copy Original IFOs” box. This will leave some of the protections intact but may help.[/QUOTE]Hey pard, thanks for covering my back. I meant to add that and forgot all about it…:doh:

[QUOTE=signals;2306388]In Clone mode, try putting a checkmark in the “Copy Original IFOs” box.[/QUOTE]

Thanks for the suggestion. I’ve tried that, but the same result!

I looked at the created ISO ([I]with the above setting[/I]) and whilst the [I]allegedly fake[/I] IFO/VOBs are in the ISO, opening the ISO or VOB files in MediaPlayerClassic, indicates them as ‘unknown media type’. However, a further examination of those [I]fake[/I] IFO/VOB files in a binary editor indicated that their content is actually “null-bytes” (0x00) - so hardly surprising that they don’t play.

Whilst I have overcome this current problem with RipIt4Me/DVD-Decrypter, I’m surprised this is cropping up with DVDs that are not even heavily protected.

I’ve sent in the IFOs, so we’ll see if there’s a response.

if you look through the release notes you will see several references to the problem, fengtao notes Fix: A PathPlayer problem that playable content be removed in certain cases.

so this is a known problem and sending the IFO files with any added information will help greatly.

There are ongoing tweaks to PathPlayer, which involve trying to balance/improve speed, cleaning accuracy and coping with odd DVD authoring and new protections. I think it should not matter to Clone mode if PathPlayer is disabled, with the possible exception of bad sector protections which I guess might show up as read errors (set or click to Ignore All?). You can throttle PathPlayer back to some extent with the sliders in Common Settings but I think it is not likely to solve this problem. astage needs the MonkeyMan.