DVDFab Platinum subtitles showing all the time

I am having an issue with ripping my movies to iPod. Everytime I finish the movie, when playing the movie the subtitles are showing up.

I even turned off the subtitles in myItune, and it is still showing.

On the first screen on the left bottom right hand side, something called subpicture. Should this be checked or unchecked, by default it is always checked.

Any input is greatly appreciated…

It should be unchecked. Subpicture is the same as subtitles. Just uncheck it and you should be good to go.

You can’t turn them off because the subtitles are “Direct rendered” into the video; not even Steve Jobs can undo that. Krispiek’s advice is 100% correct, you should uncheck all the subpicture boxes before you click Next. There is a way in Common Settings to make it so that no subpictures are ever automatically selected, but then you may miss some on a DVD to DVD backup that you want (e.g. DaVinci Code, Apocalypto etc.).