DVDFab not reading any of my DVD's anymore

Hi All,

Have had DVDFab 6.0.1.0 for a while now and it has been excellent at backing up my DVD’s for use with my WD HDTV player (Also an excellent little device). I had an issue with one of the episodes of the Tick (one episode was split into two). This was the way it was on the DVD itself and wasn’t a DVDFab error so I downloaded a program called AVIDemux to merge the two avi’s into one. This worked perfectly.

However, now DVDFab doesn’t seem to want to read any DVD’s in my disc drive. I can read and play DVD’s normally and it works with Handbrake and DVD Decrypter but everytime I select the DVD drive as source in DVDFab, It will read it for a split second before stopping and giving me the Report screen:

I can, however, read DVD files from the harddrive without problems. This is now happening for EVERY DVD I insert and I really dont want to use the other programs. They are much slower and I’ve already paid for fab. Any ideas what could be causing this? I have uninstalled AVIDemux, disabled previews and have tried the pathfinder fix all to no avail. For your info, here are my system details:


Windows Vista Home Premium
2Gb RAM
1.8 Ghz Dual Core Pentium 4 (Intel Centrino)
Plenty of harddrive space.
No AnyDVD installed (And never had any issues with Handbrake, DVD Decrypter, Magic DVD or Fairuse installed)

If it simply a DVDfab update issue, how do I update it? I know i’m using an older version but there is no update option and I dont want to have to pay for a new version.

Any help would be massively appreciate.

Thanks in advance,
Noobsaibot21

Update:

I got version 6.0.2.2 now but it still isn’t working. Same as before but not I dont even get the report option.

Seems to me that AVIDemux is the problem, not DVDFab. Try uninstalling the program that changed the way things were working for you.

I’ve used system restore and everything is back to normal. I have also reinstalled Avidemux and it’s working in harmony. May have something to do with me recently deleting 4OD.

Cheers,
Noobsaibot