DVDFab Freezes on "Go!"

Hello,
I wanted to backup my own DVD’s. I have DVDFab Platinum 2.9.7.3 installed and am using the Gold program. I have a dual-boot system, 98SE and XP Pro SP2. Each O/S has its own partition and they cannot see each other at all or share any system or application files. In 98SE, I have no problems at all. Everything works fine.

I just installed XP Pro SP2 three weeks ago. In XP Pro SP2, DVDFAb Platinum Gold will see the DVD correctly, allow me to use the wizard and choose my split point. When I get to the last step and I click “Go!”, my whole system instantly freezes everytime.

Since I have a dual-boot system, all the hardware is identical. My XP Pro SP2 installation was a fresh install on a blank primary NTFS partition. All of the application partitions for XP are also NTFS. The temporary partition is normally a FAT32. However, it doesn’t matter which partition I choose, NTFS or FAT32, I still get a system freeze. The NTFS partitions are version 3.1, for Windows XP. The FAT32 partition I use for large temp files, in both XP and 98SE, is just a standard formatted 16 GB @ 8 KB cluster sizes.

In XP Pro SP2, I can play DVD’s using PowerDVD6 no problem. Using the same DVD-ROM drive, I also test ripped 2 of my music CD’s using CDEX 1.51 (9/2003) with no problems. However, when I tried to scan my DVD’s using an older (12/2004) ANYDVD+CLONEDVD combination, I received an error message, “cannot read videoTS” or something. These last 2 programs have since been uninstalled and I also used a XP System Restore Point to ensure there were no files leftover after the uninstall.

I have 4 different DVD drives. No matter which drive I choose in DVDFab, they will all freeze and I must reboot. In 98SE, I have no such problems.

This is my system:
Athlon 1500+
Abit KG7 motherboard
1 GB RAM, ECC+Registered
Promise Ultra133 PCI PATA Interface card (latest drivers) with:
…Seagate 250 GB
…WD 100 GB
…WD 120 GB

These 4 are connected to the motherboard controller:
1 DVD Burner Drive
3 DVD-ROM Drives

Can anyone tell me why XP Pro SP2 is freezing like this? I have tried everything I can to try and fix this but nothing works.

Thanks in Advance.

My post #13 in this thread may at least give you a starting point to troubleshoot. I run XP Pro SP 2 and usually run problem free until I start experimenting with new programs.

http://club.cdfreaks.com/showthread.php?t=175563

Mack

Geez, I guess you don’t need me to point out…this really sucks!.. :iagree:
Just to add to what Mack suggested…if I read your post correctly, you don’t receive any specific error(s) with fab, it just freezes and with the older software, you get ‘…“cannot read videoTS” or something…’ I’m also sure you tried what I’ll suggest and I’m just guessing here (no expert, for sure), but have you disabled all your firewalls (make certain the windows fw is disabled as well)? I would also uninstall fab completely and be certain to keep your reg key or retreive here. I would then run a decent reg cleaner, reboot and do a clean new install of fab, reboot again. Keep the firewall(s) off, probably a good idea to disconnect from the internet.

What happens now? You shouldn’t be getting any conflicts, at least as a result of enabled/disabled programs and sp2 and firewall(s).

If problem persists, are you able to see a dvd in xp with fab at all? Any error message or just “the freeze”?

I run xp pro sp2 in a custom - a little over a year now and have had absolutely no problems. Some folks, as you know, have had horrendous issues with sp2 and some of the stuff seemingly, is the result of blackmagic or bad karma. Anyway, I hope this helps, and with any luck, one of the resident experts will spot this and lend a hand.

Good luck.

To both of you, thanks for the suggestions. I’ll try what you recommend. I don’t think it’s the XP Pro SP2 firewall, but I’ll disable it anyway. I’m not in XP right now; I’m in 98SE. I don’t know when I’ll switch back. Maybe later tonight.

There are a lot of other problems I’m having with XP also, such as my latest nVidia video card drivers are really lousy with the TV-out and the Microsoft Intellimouse drivers aren’t as good either. In general, the user interface in XP is NOT as convenient as in 98SE. I don’t know how Microsoft thinks their product is acceptable for general use. I think they just didn’t put enough effort into it this last time around… and XP SP2 has been out since August 2004. That’s 1½ years ago!

I’m ready to backup all my XP partitions and start uninstalling one by one all the Windows updates it automatically did. I’ll let you know how it goes.

[B]BTW, I have the Academic version of XP Pro SP2. Do you think Microsoft put something in it to disable anything?[/B] Like I said, I can rip CD’s fine. It’s only when I get to DVD’s that I start having problems.

Do you have Auto Run and the Windows Cd built in burning program disabled?

My office is in a community college, but I am a county employee so we use a different version than the college. But in my experience Academic versions do not have features disabled. I have purchased Academic software in the past and am qualified to purchase it now, and this is a form of advertising. They want to empress you making you a lifelong customer and count on you recommending it to your students and friends. They don’t want you to be showing me how good it is and it crash.

Mack

FYI, I have been doing a lot of research and from time to time I find some interesting information. I found this program when looking for a way to slipstream SP2 with XP on a bootable CD. It is ISOBuster and has many free features, but you can register it for more advanced features for about 26 bucks, but free version will probably do what you need to check for drive.

A lot of information and there is a link to this site om the Microsoft site. This program can communicate with a drive using SPTI or Aspi (wnaspi32.dll) is standard installed on Windows 95, 98 and ME. Microsoft did Adaptec a big favor here and the nice thing about it is that we can make use of it as well. Aspi interface is the default for Windows 95, 98 and ME, But 2000, NT, & XP use SPTI which cannot work on the Windows 95, 98 and ME group. Some programs add or allow downloading a version of wnaspi32.dll. Nero offers a download but says not to use it with other programs. Downloading and using ISOBuster will allow you to see the drive and rule out some possible problems.

Mack

How do I disable XP’s built-in CD burning program and AutoRun? I am still in SE and will probably boot into XP tomorrow. I will probably copy all of my XP system and application partitions and start experimenting by uninstalling/disabling everything. When I find the culprit, I’ll copy these partitions back and remove the offending feature or program. I’ll let you know how it turns out.

BTW, I did add the last XP ASPI 4.712 drivers in an attempt to fix the problem, but it didn’t work:
http://www.adaptec.com/worldwide/support/driverdetail.jsp?filekey=aspi_471a2.exe

C&P:

Turn Off the CD-ROM Autorun

Intended For
Windows XP
Windows 2000
Windows Me
Windows 98
Windows 95

When an Autorun-enabled CD-ROM is inserted into a CD-ROM drive, Windows automatically launches the program contained on the disk, whether you want it to or not. Similarly the audio CD player pops up whenever you insert an audio CD and starts playing it immediately. This is cute the first or second time, but soon gets infuriating. What’s worse, is that if you double-click on the your CD icon in My Computer, the autorun fires up, instead of a folder window as you’d expect. This is especially irritating on slower computers, where you have to wait for what seems like an eternity for it to load some ridiculous welcome screen. Here’s how to do it:
Any OS

If you hold down the Shift key when inserting the CD, the autorun is bypassed. (although it’s not exactly graceful trying to insert a CD while holding down keys on the keyboard.)

Windows XP - Solution 1
Right-click on the drive icon for your CD drive, CD recorder, or DVD drive, and select Properties.

Choose the AutoPlay tab, and choose the desired action for each type of CD. For example, choose Music CD, then click Select an action to perform, then select Take no action.

Windows XP - Solution 2
Obtain and install TweakUI (part of the PowerToys for Windows XP package), and then start TweakUI.

Expand the My Computer branch, then the AutoPlay branch, and then select Drives.

Turn off the checkbox next to each drive letter for which you want AutoPlay disabled.

Windows 2000/XP

Run the Registry Editor (REGEDIT.EXE).
Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom.
Double-click the Autorun value, and type 0 for its value. (If it’s not there, create it by selecting Edit -> New -> DWORD Value, and typing “Autorun” for its name.)
You may have to log out and then log back in for this change to take effect.

Note: With this solution, Windows will no longer be notified when you insert a new CD. To make sure the correct icon and title for the current CD are displayed in My Computer and Explorer, press F5 to refresh the window.
Windows 95/98/Me - Solution 1
Right-click on the My Computer icon (or whatever you’ve renamed it - hopefully something less cute and more meaningful than “my computer,” such as “Bart”), and select Properties.
Choose the Device Manager tab.
Open the CD-ROM branch, and select the entry for your CD-ROM drive.
Click Properties, and then choose the Settings tab.
Turn off the Auto insert notification option.
Click OK, and then OK again. You’ll have to restart Windows for this change to take effect.

Note: With this solution, Windows will no longer be notified when you insert a new CD. To make sure the correct icon and title for the current CD are displayed in My Computer and Explorer, press F5 to refresh the window.
Windows 95/98/Me - Solution 2

Run the Registry Editor (REGEDIT.EXE).
Open HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer.
Change the Value of NoDriveTypeAutoRun from 95 00 00 00 to BD 00 00 00.
You might have to restart Windows for this change to take effect.

Note: With this solution, Windows will no longer be notified when you insert a new CD. To make sure the correct icon and title for the current CD are displayed in My Computer and Explorer, press F5 to refresh the window.
Windows 95/98/Me - Solution 3

Because of new features in TweakUI, this can now be truly disabled by turning off the Play audio CDs automatically and Play data CDs automatically options in the aptly-named Paranoia tab.
Also, make sure that the AutoInsertNotification option is turned back on - see Solution #1 above for more information.

Note: With this solution, Windows will still be notified when you insert a new CD, so you may not want to do this if you use CD Recorder software (the constant polling can interrupt the recording process).

Mack

To disable built in recorder/burner:

http://support.microsoft.com/?kbid=279157

Mack

I looked over Microsoft Article ID : 279157. You are saying to disable XP’s recording software, I right-click on the burner in Windows Explorer, choose properties, click on the Recording Tab, and uncheck “Enable desktop CD recording for this CD-R device”? Is there anything else I must do, such as edit the Registry or Disable a Service?

I am not currently in XP, I am in SE, so I am just guessing here. I must add some new hardware so I won’t be in XP until later tonight. I still don’t know why I am getting this freezing. Although I will disable the built-in recording S/W and AutoRun, I don’t think it’s any of the above problems.

I think it’s either something which the Windows XP CD automatically installed during initial installation, one of the Windows Updates which were automatically installed, or some type of tweak which I must do such as in the Registry or disabling a Service. It could even be some type of protection which Microsoft created in their Academic S/W. Keep in mind, my XP Pro SP2 installation is almost a fresh install. I have virtually no other third party software. I will experiment later tonight by uninstalling everything, after I copy all my XP partitions.

Yeah, it’s a mystery all right. Did you get a chance to disable all your firewalls…not just xp’s? I know you didn’t think that’s the problem …but it’s easy and quick to check.

Good luck. If I have any flashes of wisdom, I’ll let you know.

Tom

Another thing, I have read that Promise add on boards have problems with copying DVDs. I’ll try to find that info. Here are some links that deal with XP.

Mack

DVDFAB rocks!!! never ever had a problem with dvdfab

I never had any problems with my Promise board in 98SE. I [B][I]am[/I][/B] considering whether it’s a driver problem in XP SP2. I hope it isn’t. I am using the last drivers Promise will release for the Ultra133. However, remember that I did [B]NOT[/B] have any problems ripping my CD’s in XP Pro SP2. It smells like some type of protection Microsoft embedded for DVD movies. In any event, I am too busy to experiment with XP right now. I need to do some tasks before I can return to XP Pro SP2.

BTW, you did not include any links discussing problems between Promise cards and XP Pro SP2. I can’t believe I must deal with this problem.

I ran out of time and need to search. I only remember it when I was looking for something else. I think it may be something to do with boot drive being on a MB ide or disabling the on board. I’ll try to find something tonight.

Mack

I don’t think this is related to MS and copy protection. I was just looking at your specs…apparently, there is a known conflict with xp (? sp2 specifically), Promise PCI cards, Abit mb (and others, I think). I found a couple of sites yesterday while fooling around at work, I should have some time today to relocate them…I’ll post back. I believe some of the info had to do with IRQ mapping.

Out of curiosity, did you install the latest drivers prior to the card install?

Also, from your specs, could you swap IDE devices…run your xp hd off the mb?

Mack, thanks for getting this old brain started in the right direction… :iagree:

Tom:

Maybe we could combine our 2 old brains and have a new one. Lately the more searching that I do, I realize how little that I know.

Mack

Running the HDD’s off the mobo IDE instead of the Promise would be difficult. I hope this is not the problem.

“…Ain’t It the Truth…” … :bigsmile: … (Bert Lahr - Cowardly Lion, “Wizard of Oz”, 1939)

Try just hooking up drives on the master channel with each having its own cable. Also read that a bios chip on the Promise board has to be flashed with new FW sometimes.

Mack