DVDFab 3.0.7.5 Beta

Dear all,

DVDFab products 3.0.7.5 Beta is out (02/02/2007):

DVDFab Platinum 3.0.7.5 Beta:
http://www.dvdfab.com/DVDFabPlatinum3075Beta.exe

DVDFab Gold 3.0.7.5 Beta:
http://www.dvdfab.com/DVDFabGold3075Beta.exe

DVDFab Decrypter 3.0.7.5 Beta:
http://www.dvdfab.com/DVDFabDecrypter3075Beta.exe

What’s New:

3.0.7.5 Beta (02/02/2007):

  • New: “Merge” feature to combine several titles of several sources into one DVD. For example, you can combine two DVD-9 like “The Lord of the Rings” into one DVD-9, or merge five season discs into three, or create your own special features collection, etc.
  • New: Improved copy protection removal engine.
  • New: Updated language files.
  • Fix: Several minor problems.

Best Regards,
Fengtao

Fengtao & Ting,

Wow, you are as usual very fast :iagree: Keep up the great work it sure is appreciated throughout the forum :clap: :iagree: :bow:

Barry White :cool:

I am incredibly impressed by your efforts to improve and support your products. Platinum is the best of the best!
Thanks for all that you and Ting do.
We really appreciate it… :bow:

THANKS Fengtao and Ting you both are improving the Fab products so fast other software will not be able out do Fab at all truly the ALL-IN-ONE software in years

Tim

Brilliant work, Fengtao and Ting! Really appreciate your dedicated efforts. See you later, then. Jim :slight_smile:

This is going to be the feature that did it for me. I will be purchasing Platinum this weekend.

If I read the details of the new merge feature correctly, when perfected it will pretty much do away with the need to use DVDShrink at all…

Nice work.

What next? I can’t think of a more complete program, this goes beyond the " Call of Duty " It is awesome. Thanks Fengtao and Ting, your efforts are greatly appreciated.:clap:

HAHA I just “merged” “Once Upon a Time in the West” with disc 2 of “Once Upon a Time in America” :bigsmile: Worked Perfectly! :bow: Merged these two unrelated almost two hour titles and compressed(90%) them to fit on a DVD9 in 38 minutes flat (HDD read/write). Thank you Fengtao (and Ting!) for another great feature :clap: :clap: :clap:

@maineman
I found some tool that work with Liteon only, but never used.

http://forum.cdfreaks.com/showthread.php?s=&threadid=83441

Maybe Allen can shed some light on the tools for Liteon.

Mack

All of these tools are for Liteon drives only. They are used alot by Liteon owners. They used for crossflashing and booktyping and alot of other thing including scanning and other uses. Please clarify " but never used " maineman. These tools are used by almost every Liteon enthusiast I know.

Thanks Allen, I ment to reply in the 3.0.7.2 thread, but am at work and went to wrong thread. I guess I now have a link to refer Liteon users to when Fab does not set booktype.

Mack

Best regards Fengtao/Ting.

This version doesn’t save correct dvd title.

e.g the real one is at The X-Files Season 2 Disc 2 “XFILES_DISC2” and DVDFab makes “XFILES DISC2”

Haven’t tested it with 3.0.7.2

Here’s something strange that is occuring when burning DVD titles: at the end of ripping you are asked to insert a compatible media to start the write process but when you do insert blank media it keeps showing you the same window with no other option. This has never happened to me before.

The only option is to cancel, goto the image where DVDFab saved the files (thank god I unchecked delete temp files when done) and try burning again. But wait, this still causes the same error messege to appear - No media inserted. Even if you eject and insert the blank media into the drive it doesn’t matter, DVDFab doesn’t recognize it.

The only way to make it work is to close DVDFab completely and open it up again. Goto full disc mode, open the folder where the image you want to burn (in my case it’s Open Season) and BAM, it works. My question is this: What changed from the previous versions for something like this to occur?

Which media and burner are you using? Also does your burner lite indicate there is media loaded? I have a BenQ and light blinks green until media is recognized, then becomes steady green light.

Mack

Hi Mack, the type of burner I’m using is an LG and the media is Maxell at the moment. I Haven’t any problems with either the burner or the media since the release of Platinum 3.0.2.0.

As for the lights, I didn’t notice any lights going on or off because this is my laptop and my burner is on the side. When I ususally insert the media, Windows will recogize the disc first and ask me what I want to do with it. I always click cancel and will click OK to allow DVDFab to continue with the burning part of the process.

I know it’s not my burner or my media but the recent change in this new release of Fab that’s causing this to happen. Otherwise, why would the operating system recognize that blank media has been inserted into the drive?
What confuses me is that you have to shutdown Fab completely to burn the newly created image in full disc mode.

I bet if I reverted to 3.0.7.0 the problem would go away since I didn’t have this untill I upgraded to 3.0.7.2. But When Fengtao came up with this latest beta I figured he’d fixed this problem but he hadn’t. I’m sure I’m not the only one this is happening to ~ But I think Fengtao will address this problem sooner or later as other people become aware of it because to me this is a pretty big bug.

Tanweer

I noticed this as well even when Fab creates the folders on the hardrive it duplicates the dvd titles. Now it leaves spaces instead of underscores. I don’t think this to be a too big of a deal since I’ve used other DVD programs and they did similar things to the titles.Maybe Fab is just going with the flow.

Tanweer

Still have the same problems discussed here:

http://club.cdfreaks.com/showthread.php?t=208550

Tanweer, I used to have that problem once in awhile also, I just put in another blank disk and then it worked okay, so I guess maybe that it was a bad disk, since then I have been using verbatim media and haven’t had that problem since. Hope you get it straightened out :slight_smile: