DVD2SVCD jumps to 100% during sound extraction, the resulting soundfile is too short

vbimport

#1

When using DVD2SVCD to turn DIVX movies into a DVD format, audio extraction fails :Z :

  • the extraction process moves in increments
    to a certain percentage, i.e. 30%, then directly
    jumps to 100%

  • the resulting Soundfile is (in this example) only 30%
    of the size it should be

  • this happens with approximately 70% of all DIVX
    movies I downloaded so far (so it’s a real pain in
    the a**)

Is there a simple solution to this problem, I tried some
remedies, but at best I ended up with out of sync
audio…

Your help is greatly appreciated

Cheers
Heiko


#2

That error comes from problem AVI’s, unfortunately a common feature of AVI’s downloaded !

Solution is to use Nandub or VirtualDUBMod to extract the audio file for you. Load in avi, set Audio to Full Processing Mode, then hit Save WAV. Convert the WAV to MP2 with BeSweet, rename file to Encoded_audio_1.mp2 and copy it over the one dvd2svcd made. Then in dvd2svcd, in Misc tab, hit Recover, select Multiplex & Cut and then Continue.


#3

Hi Chicken Man, thanks for your quick answer. I’m truly impressed…

I tried Nandub as well. In one instance it worked and I produced a copy that was in sync. I followed a different path though:

  • I extractet the sound to an uncompressed .wav

  • then I used AC3 Machine to turn it into .ac3 audio

  • I interrupted audio processing after starting DVD2SVCD
    to save some time

  • I put video and ac3 audio togehter in TMPGEnc DVD Author

So far so good…

But with most of my files that does not work. Nandub only
produces approximately 900 KB .wav files before breaking
off the audio extraction. That happenes with 9 out of 10 Files.

So this replaces one show stopper with another. Any idea
what to do about it? :confused:


#4

There are many ways of doing it, yours is just as good.

There are 2 ways to extract from Nandub/VirtualDUB. One is an actual WAV converted from the audio track and the other is to just demux it out. Setting Audio to Full Processing Mode actaully converts the audio to a WAV file. (Remember VirtualDUB cant handle AC3 or VBR MP3’s, Nandub & VirtualDubMod can)

But the best is to demux the audio out by leaving Audio set to Direct Stream Copy and hit Save WAV. The file is NOT a wav file but whatever it is in the avi. GSPOT will tell you exactly what the audio is in the avi. So save as *.MP3 or *.AC3 or whatever, then convert with BeSweet.

The main thing is to extract it out fully, then convert it.

You can also just load the AVI into an audio editor like GoldenWave or CoolEdit and save out the audio as a WAV file.

Out of the last 20-30 avi’s that I’ve converted, I can remember 1 that I had to extract the audio manually via Nandub. All the rest have converted flawlessly. If you have 9 out of 10 with problems then I suggest you look at your download manager, etc. Have you tried running them through DixFix or DivXRepair?