DVD2One Encryption detected BUG?

Has any body seen this before:-

DVD2one 1.02 won’t process movie due to the following message
Encryption detected???

Ripped file to HDD and then tried to process (tried smartripper and DVD decrypter) then used DVD2one to process but Encryption detected error shown.
BUT… the dvd original has no MACRO and no form of CSS code.

Any ideas!!!

Regards

BNS :slight_smile:
:frowning:

Yes, BNS…I have the same problem and posted here in regards to it but got no help. I tried ASPI layer change and all 3 dycripting/ripping programs I have and there is no change to this problem. CAN SOMEONE HELP???

More and more people with the same problem guys…come on…change the way DVD2ONE detects encryption…or find out what this problem really is.

The makers of DVD2ONE have been told about this problem but are unable to recreate it themselves and therefore unable to do anything about it.

Maybe I should send them one of the DVDs that I’m having this problem with and see it they can recreated it, huh?

I’ve observed this error message one time with DVD2one, i.e. when I ripped the entire disc (all files) with DVD Decrypter.

When I took the same disc and only ripped the Main Movie files, I received no Encryption Error message and DVD2one worked fine.

I have tried both methods (main movie and full DVD)…but all produce the same results…Encryption detected!!!
All the DVD’s originals are by SHIVA…

I have also tried to backup the DVD using instant copy 7… but the program bug checks when running, this bug crash only happens with these disks for me.

System:-
Compaq Evo 1.7Ghz
1Gb Ram
Windows XP pro SP1
160Gb Raid hardware disk system.

I too get the same error, so have stopped using it.

@kamikazee & BNS:

Try upgrading DVD-ROM drivers in your computer system…

Milkman

Do you know of any region 2 discs that always produce this error?

I’d like to look into it a little futher myself as the DVD2One team dont think it is a bug at all.

Im pretty sure the problems have nothing to do with drivers / aspi etc.
The ripper is obviously able to talk to the drive, so ASPI must be installed correctly - either that or you’re using an alternative I/O Interface (ASAPI, ElbyCDIO, SPTI) within my program.

Like I said, get a list together of all effected dvds. I people can confirms other findings with a certain disc, there is obviously a problem somewhere. I have no problem buying one of the ‘problematic’ discs in order to help solve the issues you lot are having with this tool.

Just out of curiosity : How many of you people who are having this encryption error have overclocked their machine?

I ask this because DVD2one is way more CPU/Memory intensive then any other program i know.
On my own system i found out that if i played with the RAS/CAS, FSB speed DVD2one became highly instable!
And indeed started to produce this encryption error.

It’s not really the data that’s encrypted but due to the higher FSB or RAS/CAS settings, my memory was to slow in releasing the data.
Due to this slowness of memory, DVD2one get’s corrupted DATA to process and it is theoriticaly possible that this is detected as encrypted data.

Also we haven’t really tested DVD2one on MSP machines (multi proc). I did some testing on a win2k AS with 4 700Mhz 2mb XEONS and it runned perfectly on that. But we have no AMD based MSP system our selves so that makes testing very hard for us.

(For reference my machine is a xp2100, msi kt3pro, infinion CL222 521 pc2100)

My machine is not overclocked.

Just tried Buckaroo Banzai and had some sort of success…almost.

I first tried ripping to ISO with DVDdecrypter and running DVD2ONE on the image (which I’ve done in the past as well with different DVDs and had the encryption error). DVD2ONE ran through without an error, but when I was looking through the Vobs it created I found an error in the last vob near the end…just as the credits are starting and Buckaroo comes down the wall on a rope. The video suddenly jumps forward a bit then breaks up into many blocks…then continues.

I checked the ripped image and the same part played fine.

Then re-ripped in File mode and ran DVD2ONE on the new rip (also with DVDdecrypter). Once more it ran through without a problem. And once more at the same point I had the same messed up video. Checked ripped Vobs to compare and no error there.

So, when it finishes without an error I get a corrupted file, and the rest of the time it doesn’t finish and give the “encrypted data” error. Now I’m going to have to go back and look at the odd time where DVD2ONE finished and check for an error in the video on the 2 discs I’ve actually burned. Now I’m never going to feel comfortable that the program has worked even if the encryption error gets solved.

sigh Ah well…at least it was something different.

Mordant,

I have to agree with you… it has be the way that DVD2one handles it’s encryption detection.

If you can use INstantCopy on the DVD’s you ripped then it’s a DVD2one problem. I see posts like yours all over the place, something has to be done by the developers to fix this or they will lose customers.

My system is not overclocked and the original DVD’s have no region code, macro or CSS keys.
Both rippers I have used state no key etc…
They all rip fine to HDD and play fine using Power DVD etc…

For those of us that are having issues with the encryption detection error are you original DVD’s like mine ie no keys, macro or region coding???

PS system is running all the lates DVD rom drivers, firmware, aspi, XP Qfixes etc…

I have also tried instant copy 7 again on a few DVD’s all are fine apart for the Shiva disks that have no keys, macro or region coding??? once again these dvd’s cause IC7 to bug check “MultiCopy.exe”

AMD 1GHZ, not over clocked…768MB memory, 64MB G-Force Nvidia Video card…all DVDs work for me except the ones that have no encryption and are macrofree. DVD2SVCD has no problem doing its thing…DVD2One gives the encryption error.

I use Region 2 Dvds and i’m not having any problems at all.
Dvd-roms tested and ok: Lg 8160b, 8161b and Pioneer 105s.

i see a pattern here, is it pretty safe for me asume that the problems only ocure on NON ENCRYPTED DISCS?

To fix a problem we first need to encounter it ourselve on a test machine or find a registered user that is willing to help us solving this problem!
We can not and will not go blindly changing things in our code if we are NOT sure that what we are changing is causing this!

Also, would you please not try to trash this thread with non related postings we are working on this problem.
It makes it sound like we are ignoring this problem, and that is absolutely NOT TRUE!
(this is meant as a general question, please don’t take it personal)

Thank you for your cooperation people :smiley:

Yes it would seam that when you rip an encoded DVD that you set the code, region etc to zero say, but when you rip a no encrypted DVD the code is null, therefore is a null seen as a code?

Just a thought

:o

I had to make a contribution to this discussion (while listening to Opeth).

I recently purchased DVD2one, and did several DVD-conversions. One of them is “Planet Of The Apes”, region 2 and 4, Copyright Protection System Type: CSS/CPPM. Another one is “Virtualia Episode One” (porn), region 1 through 8, Copyright Protection System Type: None.

Both DVD’s were ripped with DVDDecrypter in file-mode,converted with DVD2one and burned with Nero 5.5.10.7b as DVD-Video; Flawlessly.

My system: P4 2.53 MHz (not OC’ed), Asus P4T533 motherboard, 512 MB RIMM4200, GeForce 4 TI4600.

[EDIT] I forgot the most important thing: Pioneer DVR-A05 with firmware 1.21 and Datawrite 4x DVD-R’s.

I hope this helps a bit.

Rene,
Thank you, thank you, thank you! I may have been the one who was negative here. I’m sorry…I’m glad now that this issue is being taken seriously. I am not a registered user yet…I still only have the trial version of the software and couldn’t get it to work with the above mentioned non-encrypted disc, so I haven’t bought the software yet. Especially, if this problem can be worked out, I will buy the software…I have many such discs and want to back them up.

Frustration may leave me sounding more negative about DVD2ONE then I really am…

The DVDs I’ve had trouble with were not unencrypted at the start. ie Lord Of The Rings SE ect.

I just finished redoing Buckaroo Banzai one more time. Reripped it in the same way and once again DVD2ONE finished without an error (it really seems to love this disc for some reason). I don’t see anything wrong with a scan through the Vobs so far. Going to burn it now and see how it plays on my stand alone. Then I’ll try another disc and hope my lucks hold out.

When DVD2ONE is working it is exactly what I’m looking for (Menus ect are not something I’m really concerned with except perhaps with multi episode discs).

I am a registered user and willing to run tests for you…I’m going away for the next week though.

Thanks for looking into this problem.