Dvd writer

vbimport

#1

i have an compaq presario desktop w/Windows Vista and an HP DVD writer 840y.It is not functioning although it’s showing up on the computer.I went to compaq(HP) site for drivers downloaded what was available and still no luck.What’s the problem and does anyone have a solution?


#2

You will have to be more specific about “not functioning” before we can try to guess what is going on.


#3

By not functioning I mean,it wont read or write blank dvd’s and I’ve tried several brands and + and - formats.when i load the dvd it doesnt show up on the drive at all.I went to hp and updated all drivers needed.That’s allI can tell you.


#4

Does the dvd writer show up in device manager and (right click dvd device, clicking properties) under “general” does it state this “This device is working properly.” ?

If so, let us know what software you are using for burning and if you are working with data or dvd video.


#5

@meanone2
If it’s no hardware issue the following often solves problems like yours.

Try this Microsoft FixIt solution & reboot:
http://support.microsoft.com/mats/cd_dvd_drive_problems/en-us

If that doesn’t help please try to manually delete upper/lower filter as described here:
http://support.microsoft.com/kb/929461/en-us


#6

It’s showing up in device mgr as functioning properly.I’m running Vista Home Premium with SP1 and SP2 updates


#7

Before I forget I’m using Roxio as well as IMG BURN. I appreciate your help and patience.


#8

Try to insert a CD in the drive to see if it is recognized. The DVD laser may have died.


#9

I put in a cd and still nothing.I wemt to microsoft fix it and it keeps saying dvd not readable.these are new dvd and cd blanks and I even use prerecorded dvds that i purchased.I know the main drive in my computer dvd laser is gone but I recently unpacked this dvd writer because I used it on my previous computer and tried it on this one before.it worked then so why is’nt it now?I’m perplexed.


#10

There were a myriad of problems that arose with Vista and DVD/CD drives. You did try the fixes that Terramex suggested? One other option is to try plugging the drive into different USB posts. Or unplug any other USB devices than KB and mouse, uninstall all USB root hubs/controllers from device manager, and reboot.

One other interesting solution I ran across, but not tested myself:

go to start
right click on my computer
click on manage
then click on storage
then click on disk management
then right click on your device and select add letters and path
window will pop up then click on add
the select an alphabet and click on ok