DVD writer not recognising DVD disks

I have a problem regarding the DVD read/writer (HL-DT-ST DVDRRW GSA4164B) fitted to the Scaleo P PC (my PC is about 6 months old).
I can burn VCD’s and CD’s but I cannot burn DVD’s.
I’ve tried different makes of DVD and different burn programs (Nero v6 as loaded and Burn4free)
When I get the request to insert a DVD disk to start the burn I keep getting the message please insert a disk even though I have done so.
At this point the burn program hangs.

Can anyone help please

Hi and welcome!

as your computer is rather new, please check if you are still under warranty.
Then, start your system in Safe Mode and try burning a DVD disc. If that fails, too, then ask technical support of your computer manufacturer for further advice.

Michael

Michael
Thanks for the info, I’ll give it a try

Have any joy? I have exactly the same PC and exactly the same problem…

mmm same computer same burner same problem after firmware [officily] update 1.01->1.03
phoned fujitsu i have pick up and return warrenty [yesyes iknow xflashed it and back :cop: ]

dont used the warranty it takes to long

tried everthing to “repair” it no luck bought benq 1655

but alway trying to fixed it perhaps ik take it apart :wink: and take alook myself