DVD Writer Firmware Upgrade failure under Windows 7 (64 bit) OS

vbimport

#1

The product is actually TSSTcorp CDDVDW SH-S223C F/W SB01 and
not SH-S223B as per dropdown list.
Downloaded latest Firmware file SH-S223C_SB04.exe and ran it from the desktop.

My OS is Windows7 Ultimate 64 bit.
This exe file starts up TSDNwin.exe which “freezes” the computer.
Have to use Task Manager to End Task.
It hangs at the flashing “Caution” message that comes up.
Tried running TSDNWIN.exe from the Desktop but
this needs bin files which Samsung site does not seem to supply.
Any help to solve this would be appreciated.


#2

Run it in the XP emulation.


#3

Hi woppr,
I have just installed Windows XP Mode (under Win7 64 bit Ultimate).
I have two Samsung Sata DVD writer drives attached.
The XP mode recognizes only one virtual " MS C/DVD-ROM "drive. This virtual DVD drive responds only to one of my Samsung drives.(Y: drive)
When running update firmware file SH-S22C_SB04.exe file
I get the message “Can’t Find Suitable Drive for F/W"
So I tried accessing my DVD drive under " Y drive on PC” [\ sclient](file://tsclient/) Y:drive is not accessible
and I get this message,
"You might not have permission to use this network resource"
What can I try now?


#4

Have you tried unhooking the 2 nd drive and doing one at a time?


#5

Hi bean55,
Have unhooked 2nd drive but I get the same failure.
Running under virtual XP mode the OS sees only a virtual d:drive as MS C/DVD-ROM
It sees the my attached DVD drive as the y: drive which the Tsdnwin.exe software cannot access or recognize.
Besides I cannot even acces y: drive directly from virtual XP mode because of some permission problems.



#6

Try upgrading the firmware in Win 7 with only 1 drive attached at a time.Not the Virtual XP Mode
It might have hung when it seen 2 drives connected.

If that does not work do you have access to another computer with Windows XP ? If so upgrade firmware on it and then put the drive back in your machine.


#7

Tried with one drive connected and using Win 7 64bit OS
Same problem. It hangs. No luck.
Your second suggestion sounds a very good idea.
I have a laptop with XP on it, but unfortunately I would not be able to connect these DVD SATA drives to it.
My second desktop PC recently had a MOBO failure so it will be a while before I can assemble a new spare one.


#8

Ask a friend :iagree:


#9

Hi,
There is always the option to flash the drive in plain DOS (see FAQ for details). Disconnecting one drive for the flashing procedure is still recommended.

Under Win7 64, you may run the firmware update tool “as Administrator” (right-click and select the desired option).

Apart from that, I am curious to know what Sata controller is used for this drive. Some controllers have compatibility issues with opticals.

Michael


#10

Hi Michael,
I have not tried the DOS approach yet.
I have run under Win7 64 as Administrator and also with all my AVG Internet Security components disabled. Despite this Tsdnwin.exe program hangs and I have to End Task.
My MOBO is Gigabyte GA-X58A-UD7
The storage controller is GBB36X






#11

[QUOTE=EasyJoe;2531801]
My MOBO is Gigabyte GA-X58A-UD7
The storage controller is GBB36X[/QUOTE]
Connect the drive to one of the Intel Sata ports and try again. (Not sure what happens if you have a Raid configured on the Intel controllers).
If you want to stick with the Jmicron controller, then I’d suggest to configure that as “IDE”. Also install latest drivers from Jmicron for the controller. If I remember correctly, then there are different drivers for the different operation modes.

Michael


#12

Michael,
I have checked my UD7 MOBO and now realize that the TSSTcorpCDDVDW writer is not connected to the SATA Gigabyte port controlled by GBB36X but to the Intel® ICH10 Family 2 port Serial ATA Storage Controller 2-3A26 Version 9.1.1.1013
The SSD and other HD drives use the GBB36X. No RAID is used only IDE channels.
Attached are my BIOS and driver details.




#13

Hm. Nearly out of ideas. :confused:
Perhaps you try the drive on different Sata ports.
Additionally, I’d contact Gigabyte support for advice. Perhaps there is some Bios issue…

Michael


#14

The problem has been solved by a comment made in another thread by kenny5277.
See " Seemingly silly problem with upgrading the firmware"
It appears that for the upgrade software to work on my monitor (resolution set to 1920X1200) custom text size needs to be "small-100% " not "medium-125% "
This is located under Control panel/Display/Set Custom text size (DPI)
With this setting Tsdnwin.exe displays the full box image instead of clipping off the OK button.


#15

Good to Know

Thanks for letting us know the outcome.