DVD writer does not recognize writable media

Hi there,
I’ve been searching and reading the forums about possible solutions to this problem but with no luck:

I have Windows XP SP2, I used to have a cd writer, but removed that and plugged in a dvd writer instead, it’s a Pioneer DVR-111. The writer software I’m using is Nero 6.6.

Symptoms:
The drive can read CDs and DVDs fine, I got it to play a movie (whee).
The drive chugs whenever I put in a writable cd (CD-R) or writable DVD (DVD+R or DVD+RW) - cheap cd, sony made dvds. The cds were written to by the old cd writer fine.

Actions I’ve already taken:
‘Uninstalled’ The secondary IDE channel to which the drive is plugged in and restarted - no dice.
Killed and turned off the CD writer software in the OS. Stopped service, enabled “Remove CD Burning Features” from the Group Policy dialog (User Configuration --> Administrative templates --> Windows Components --> Windows Explorer).
Restarted a few times, Uninstalled and reinstalled nero. Killed virtual drive software.

Nothing. Drive still does not recognize writable discs, Nero info tool tells me everything I would expect about the drive, says no disc, nero refuses to burn (since it thinks there’s no disc) ImgBurn tells me the media is incompatible.

One thing that is weird:
In the Configuration tab of Nero InfoTool, It shows me:

  • Unknown Adapter
  • Primary IDE Channel
    ----+ Hard disc one - sckiiping details.
    ----+ Hard disc two - skipping details.
  • Primary IDE Channel
    ----+ Master: PIONEER DVD-RW DVR-111
    --------- DMA on
    --------- Autorun on

Since this is odd (Two primary IDE channels, no secondary), I figure you may need some specifics about the motherboard:
From the seller’s site:
Asrock K8 upgrade VM800 Socket 754 DDR400 +64MB VGA +8x AGP +SATA RAID +LAN +USB2.0 +6 ch. Audio skt 754 microATX Motherboard

When I look at the IDE ATA/ATAPI Controllers node in the device manager, I see:
Primary IDE Channel
Secondary IDE Channel
VIA Bus master IDE Controller

Is the primary / secondary channel thing a red-herring?

Any help / gems of knowledge would be geatly appreciated.

maybe your drive can’t read CDRW??? some drives can’t read CD-RAM and some other medias.

Is the drive actually jumpered as master to match the cable positioning?

Do you have Alcohol software installed?

If so, there’s a setting in there which can cause writeable media to be recognised as non-writable.

In Alcohol settings, Emulation --> Ignore Media Type has to be unticked.

Hi Hello20,
It’s supposed to read & write to DVD+R, DVD+RW, CD-R, DVD-RAM, all sorts.

I didn’t look at the jumper settings yet, since I figured if it read it was A-OK, I’ll do that, give me 10 minutes…
Edit: I just finished checking and the settings were correct.

Then as Arachne asked do you have Alcohol or Daemeon Tools installed?

Hi Arachne,
I just installed the demo version of alcohol 120, checked the correct option, and then tried to burn an ISO image to dvd. No joy. Alcohol says please insert a blank disc… I do, The writer chugs, and after a minute of chugging, stops and goes quiet. Alcohol still thinks there is no disc in the drive…

Any other ideas? I have a nero log file, and a suspicion that the spanking new dvd writer is broke :frowning:

Edit: I tried the same thing with the option uncheked as you asked, and checked even though the latter seems crazy…

Was it doing that before you installed Alcohol?

If so, Alcohol’s not the culprit.

But don’t worry, I’m sure either myself or another member will come up with something :wink:

If it reads both CD and DVD media fine, then I would tentatively say the burner is fine, the lasers haven’t died.

It’s gotta be a software problem…:slight_smile:

I’m hoping it’s a software issue!
It was not working before I installed Alcohol - nothing seems to have changed - including the angry chugging :-). I’ll uninstall it since other posts I’ve read suggest it may mess things up.

I’m certainly reading from both CD and DVD (CD I burned and film DVD).

Yeah, Alcohol can mess things up - that’s why we asked if you had it installed, since if you did, it might have been causing the problem.

Any possibility you could run Nero InfoTool, save the results as a text file, and copy the output here?

It would help us see what you have running on your system driver/software wise, in case some software is mucking things up. :slight_smile:

You say you killed virtual drive software - did you uninstall it, or just disable it? Virtual drive software is a prime suspect for something like this :wink:

I ran an uninstaller for the paragon cd emulator, apparently it does not uninstall cleanly, the program I ran I downloaded from them, specifically to remove the drive that was showing up but was duff.

This is the dialog it pops up when I run it.


Warning

Do you wish to remove CD/DVD Emulator software from Paragon and Splyne vendors?

OK Cancel

Also, I’ve attached the output from Nero’s InfoTool.
Edit: Hmm, would I have been better off pasting that?

Could you try deleting you upper and lower filters. Your upper filter (GEARAspiWDM) has been known to cause problems with optical drives. You may need to uninstall and reinstall any burning software that you have.

Heres a guide on deleting them: http://support.microsoft.com/?scid=kb%3Ben-us%3B314060&x=12&y=13

Probably ;)…but no matter, I’ve downloaded it and will take a look now.

Haha, jhtalisman beat me to it with some very good advice :iagree:

I’ve done this, and checked it’s gone with devfilter.exe from bustrace.com. (Which I found while reading other posts earlier). Same results, nero (after uninstall and reinstall) still says:
“The recorder does not support this type of disc!”

Edit: The tool says:
Upper device filter: redbook (redbook.sys)
Device object
Lower device filter: imapi (imapi.sys)

Can you check the color of the motherboard IDE connector of the cable your drive is on?

The plastic bit on the motherboard, that the ide cable plugs into is black. it’s beside a blue coloured slot / connector that the harddrives plug into.

The cable is grey with a thin red stripe, and the connectors on the cable say “FC-40P” on them. The dvd drive is the only thing on its cable and is plugged in at the end - primary.

there’s an image of the motherboard here: http://www.microdirect.co.uk/ProductInfo.aspx?ProductID=12554&GroupID=954

I know I need some special cable to write at high speeds - the manual says so, is this what you’re thinking about?

Sorry it’s taken ages to reply, I was asleep. Also, I’m just heading off to work now.

The motherboard end of the cable needs to be blue, representing an 80 wire cable. Your current one is 40 wire. If I’m not mistaken the drive requires an 80 wire cable to be in the correct DMA mode.

Also, have you updated the firmware on the burner yet?

Yep, I upgraded the firmware as soon as I found that there was a problem.

The manual did mention attaching it to the 80 pin connector, but only for writing at higher speeds. I’ll swap them over when I get home, and see what happens.

Will there be any performance issue with putting the hard disks on the 40 pin connector?

Pioneers like to be on 80 wire cables. Saying that, I once had a Pio 110 on a 40 wire cable.

With a 40 wire cable, you’ll be limited to UDMA Mode 2, whereas with an 80 wire, you’ll get UDMA Mode 4 for the Pio.

I wouldn’t put HDDs on a 40 wire cable :disagree:, the transfer rate would go right down…if you can possibly use 80 wire cables for both your HDDs and optical drives, that would be the ideal solution - no 40 wire cable at all. :slight_smile:

Am I limited by the mother board or is it literally the cabling, which is cheap to replace?