Dvd writer buffer underrun problem

vbimport

#1

Hi there, Ive been battling with this problem for quite a while.
Ive got an 8x IDE DVD writer which worked perfectly fine in the beginning. Took about 13min to write a 4.7GB DVD. However at some time or other it started giving me issues. When writing a DVD in Nero the buffer level (not read buffer) fluctuates heavily, jumping from 30% to 70% and all over the show whereas before it’d stay pretty steady at around about 100%.
The result is that now writing a DVD takes almost an hour instead of 13min.

The first time I got it working properly again was after I formatted my system partition and reinstalled windows xp. It worked fine for a while then but after a bit the problem reappeared.

The Second time it came right again was after I thought it had something to do with my motherboard. I sent in the board to my supplier and they sent it back saying it was perfectly alright. After I’d put the pc back together again and redone the bios etc. it worked fine again. Then after my friend changed some bios settings to add an extra drive temporarily it went back to the old problem (even after resetting the settings to what they were before…)

Another friend told me he had a similar problem with his writer and had fixed it by settings the IDE channel transfer mode to “DMA if available” in the device manager. But its been like that on my pc all along.
Anyways, i changed it to pio, rebooted, then back to dma and rebooted again. the problem remains. Ive also uninstalled my dvd drive in the device manager, rebooted and then tried again, problem remains.

Ive got ample hard drive space and the drive is defragged.
Ive tried increasing the ultra buffer in nero and it doesnt help either.
I downloaded the driver clean tool and registry checker from nero and that didnt help either.

Ive tried various bios settings, exchanged the IDE cable, taken the whole pc apart and put it back together, updated my bios, motherboard drivers etc. I’m at a bit of a dead end. Was going to format my system partition again tomorrow to see if that sets it right again. Has anyone got a clue what my problem could be? Any help would be more than appreciated…

Oh, perhaps some system specs:

Windows XP Professional
Sahara Dual +/- RW 8R + 4RW + 4R + 2RW (OEM) DVD Writer
2.4ghz Intel Pentium 4 processor
MSI 865PE Neo2 Motherboard
geforce 4200 ti
512MB DDR RAM
120GB Seagate HD


#2

Ok, wait. It seems Ive been stupid. I think its a DMA problem afterall.
I ran Nero info tool and it said dma is off. I uninstalled the primary ide channel which my dvd-writer sits on and rebooted. Afterwards nero info tool said dma was on and it said so in the device manager as well.
I then tried to write a dvd and the same buffer problem came up again.
After the write I ran nero info tool again and it said that dma was off again.
So for some reason it seems to kill/override the dma setting once I start a burning session


#3

Nevermind for now, trying all the dma solutions in other threads atm…


#4

Rizza
I’m running into the same exact problems you were encountering. Were you able to find a solution for it without having to put apart the machine and/or reformat the hard drive?


#5

ive been trolling the fourms as well but there seems to be no simple definative guide that i could find, if u could help me out i would really appeciate it as well, i dont want to skrew with my system too much and cause more errors then i solve along the way :slight_smile:


#6

Damn ,happaned to me also…
and its the 2nd DVD-Burner I have
the other one was from Lite-on so I thought I have a porblem with the computer or Windows Xp so i tried to reinstall, didn’t help…
I tried it on some other computers still problem wont change…

so i bought a new one that was from Nec…
it was all good untill yesterday…
I can buy another DVD-Burner and it would be the 3ed but then again I think i’ll have the same problem after a while…

I’ll try to change the cable I have,

10x Ahed…
maybe I’ll install Linux


#7

okay ppl nvm
I fixed the problem…
thanks anyway
and good luck 2 the rest

brw rizza
did you checked the current Transfer Mode if its on Ultra DMA?
cuz after u change the “Transfer Mode” from PlO to DMA
and do reboot
you need to check that the “Current Transfer Mode” also changed to DMA

I guess that you know what i’m talking about, but its worth asking