DVD won't play on PC

Hello,

I’m new to this so please forgive me if I’m posting into the wrong section. I would appreciate any help.

I have a Plextor PX 712-A DVD Burner. In the past, all I would have to do is load a DVD into the burner and it would ask to to select the media player (Windows Media, PowerDVD, or NERO), I’d pick one, and then it would play. This was the case for regular DVDs, DVD+/-Rs, VCD, etc. Then one day, I tried to play a DVD-R and nothing happened. I put in a regular DVD and the same thing…nothing. So I double clicked on the DVD-RW icon in My Computer and got an error message of I/O error or something.

I’ve tried the following:

  1. I searched around and was told to go to the device manager and play around with the IDE Channel settings PIO or DMA and vice versa. That didn’t work.
  2. I went into the properties of the DVDRW and noticed the Auto Play tab, it was defaulted to autoplay music files, so I selected DVDs. Then selected “Apply”, but that didn’t work. I re-went into the properties and noticed it defaulted back to “Music Files” rather than the “DVD” setting I previously selected.

I don’t know what else to try. Any suggestions, or help is greatly appreciated.

Regards,
Steven

Hi sm5486 and welcome to CDFreaks. Sounds like a bad disc or a disc that your drive is having trouble reading. Have you tried a different DVD to see if your drive will read? Moved this thread to the Plextor forum.:slight_smile:

Yes. I’ve tried multiple DVDs. Standard movies and DVD-R.

First it might be due to enabling the “hide cd-r” feature in some software. Don’t ask me why, but disabling it worked here.
Secondly, well, can there be a copyright protection program on your machine? It might prevent the access to your drives.

Thanks URVEIH,

  1. How do I look for the “hide cd-r” feature in all the software I have? Is there a simple way to do this?
  2. From what I know, I don’t believe so, since I was able to play regular DVDs and DVD-rs in the past.

Some thoughts, I know this all started when I installed the ipod quicktime player and itunes.

  1. Plextools settings. (or adv. settings)
  2. Doesn’t iTune imply a special copyright protection?

This i/o error, can you remember the exact text? How about deleting the channel in the hardware manager and having it restall (XP does this automatically, if it does not, reboot.)

I tried #1) and it didn’t work. I also deleted the channel via the hardware manager and had it reinstalled to no luck.

Not sure about the copyright protection. I searched around on itunes and Quicktime but couldn’t find it.

Any other suggestions?