DVD won't play in computer or dvdplayer

Hi, so I’m very new to this and made 2 dvd’s a few days ago with no problems using avstodvd and imgburn. However today I encountered a few problems. First being that when I was running avstodvd something popped up in yellow text saying “No channel layout specified. The encoder will guess the layout, but might be incorrect”. It proceeded and finished “successfully”(this process took 8 hours, much longer than previously).

I then opened imgburn and dropped the files in VIDEO_TS and AUDIO_TS to burn them. The process went through and verified successful. I went to put the dvd into my player and nothing. No disc menu, just a black screen the disc will not play.

Stupid of me, i reburned on a new dvd, which also won’t work and neither disc will play on my computer either. When i open my cd drive to play the disc what is shown is the 2 folders VIDEO_TS and AUDIO_TS.

Inside the VIDEO_TS folder are:

VIDEO_TS
VIDEO_TS
VIDEO_TS.BUP
VTS_01_0
VTS_01_0.BUP
VTS_01_1
VTS_01_2
VTS_01_3
VTS_01_4
VTS_01_5

They’re all mpeg files, except the bup files.

I don’t know what I’m doing wrong. All the mpeg files play perfectly on my computer using powerDVD, if that means anything.

Imgburn log:

File info:

video bitrate: x264 L4.1 High @ 3722 Kbps
frame rate: 23.976 fps
audio: English AC3 5.1 @ 640 Kbps
runtime: 2:22:55 (h:m:s)
resolution: 1280 X 720
subtitles: English, English (foreign parts only) ,Bulgarian, Russian, Greek
format: IDX/SUB
chapters: yes
file size: 4.36G

imgburntrouble.txt (5.22 KB)

The list of files in the Video_TS folder should have .ifo, .bup and .vob files. Ifo files are necessary for navigation. The bup files are simply backups of the ifo files.

The file info at the end of the second post. This is the original file that you converted to dvd-video, correct?

The error you saw in AVStoDVD was regarding channels in the audio. Your original audio is 5.1 channel sound, in AC3 format, but at too high a bitrate to be used in dvd-video, so it has to be re-encoded to 448kb or less.

ImgBurn shows no errors, and even verifies correctly. I don’t suppose you have the log file from AVStoDVD?

ETA: Ok I found the log, it was on my desktop :slight_smile:

Here it is attached

Filmlog.txt (7.45 KB)

In looking at the list in post #1 . The only file extension you show is .bup .
Do the rest of the files have a file extenson like .vob ?

Here is a screenshot showing the files. I moused over 1 of the non bup files to show what the info box says.

The other dvds I’ve burned thus far have all been avi. This is the first mkv I’ve tried and it also has some subs, could that have something to do with it?


This is a screen shot of a VIDEO_TS folder I created from a file with AVStoDVD . It wasn’t a .MKV file & it didn’t have subs.
It shows the extensions. A 303MB file is not very large for a .vob file unless it is the last .vob.
Have you tried playing the folder in a media player like VLC ?
I suggest using “rename” & add the file extension like in the image I’m posting. then see if it works.


Ok I downloaded the VLC player. Tested them and all of vob files play perfectly. Here is a screenshot

This is how the files look on my computer…don’t know why



VLC should let you open the VIDEO_TS folder . On my computer I have it where this works from the right click menu . So you might try jsut right clicking on the folder.
If it doesn’t worl it usually indicates it’s not going to play when burned to a DVD.

One note when you installed VLC you let it “associate” a lot fo your audio/video files. I can tell this by the icons. This usually doesn’t hurt anything but you may find some you want associated with something else.

What I think you should try is right clicking on each file & renaming it .
You should be able to use the screen shot I posted as an example to follow.

Once you do that try the VIDEO_TS folder in VLC again.

Ok tried renaming them but the video_ts folder still won’t open in vlc player. The only files that will play are the VTS_01_1 to VTS_01_5. They play from start to finish with perfect video and audio. I was able to open the ifo files in powerDVD and they seem to be the disc menu I created in avstodvd.

I just tested one of my previous video_ts folders with VLC player and it opened, I clicked play on the disc menu and it worked. So I don’t understand what went wrong with this one. Only differences I can think of are it’s an mkv file, higher res/quality and has subs. Are there some settings I should change in AVStoDVD?

ETA: When I click “add title” in AVStoDVD and select the original file i receive a prompt that says “Warning! Framerate value detected is invalid. Please insert it manually” with an area below to fill in. What does that mean?

I think the framerate seems to be the problem, here from the log:

Info: AVC - 3722 kbps - 1280x720 - DAR 1.778 - [B]0 fps (VFR)[/B] - Progressive - 2:22:54 hours - [B]0 frames[/B]

That can’t be good lol

The mkv was encoded using a variable frame rate, so AVStoDVD cannot give a fixed frame rate for it.

When you look in the previous dvds you’ve made in AVStoDVD it should show the complete set of .ifo, .bup and vob files. This one has not been authored properly.

To fix this we need to merge the vobs into one file and try to author it again in AVStoDVD. You’ve already done the hard part of encoding the video to fit dvd specs. We just need to take the various parts and reauthor.

The problem is that we need to use programs that look for the .ifo files in dvd structure. The file that is named VTS_0_01 and looks like an mpeg file in your computer is actually the .ifo file that we need to use.

You can try a program called PGCDemux. Use this VTS_0_01 file as input in the program and make sure to set the program to demux the audio and video streams and the subtitles. You might have to rename the file with an .ifo extension to have it recognized. If it will process this, you should have separate streams for each of those. Do you still have 4 different subtitle streams in this dvd?

If this will demux everything, you can import the streams back into AVStoDVD to try and build the dvd structure again.

I don’t know that this will work properly.

Another way to try this is to merge the vobs with VobMerge. Then use this combined vob file as input to AVStoDVD and try to reauthor. The problem is you might have to import the subtitles separately. And to do that you might have to extract them from the original mkv file using Mkvtoolnix and MkVExtractGUI2.

Thanks Kerry I’ll give that a try. I’m afraid of wasting 3 DVDs on this so I’ll check to make sure the video_ts folder is playable in VLC player before burning.

Try using a rewritable DvD until you get things sorted, that way you are not wasting DvD’s.

:cool::cool:

I tried using PGCDemux but got the following error at around 20% processing “error reading input VOB unsychronized”. I think I may just give up on this project. Thanks for trying.

I do have a new issue though, how do you add subtitles in .srt format to avstodvd. When i go to my subtitle folder there is nothing there under “supported types”. I select “all files” , choose the sub and upon opening i get the following message “error file format not recognized”.

I tried opening the file with SubtitleCreator and got this “Error reading subtitle 1. (Input string was not in a correct format.)”. I opened the file with notepad and changed format to ANSI, opened again with SubtitleCreator and file opened fine. How do I now get this file to open with avstodvd?. I tried saving it as sup and srt and neither will work in avstodvd.

You might give FixVTS a try.

[QUOTE=cholla;2673994]You might give FixVTS a try.[/QUOTE]

Would this fix the subtitle issue?

No ,It is for the first issue.

I don’t work with subtitles very often . So I don’t have an answer for those.