DVD Volume Label Not Refreshing

I am having problems with my DVD Volume Label refreshing when I insert a new DVD into the drive with AnyDVD running in the systray. It ONLY refreshes when I right-click/close AnyDVD, seems like AnyDVD when its running, locks whatever label that is being displayed on the drive in place, even if you remove the disc from the drive and leave the drive empty, it still shows the label from whatever disc was in there before.

I tried uninstalling the application and re-installing, same deal. I am using the latest version of AnyDVD. Any suggestions?

Drive model and firmware information would help.

Samsung Model No: SH-S182M
Firmware Revision: SB02

I have noticed this as well with my BenQ’s, 1640 BSLB and 1650 BCIC or BCDC.
Info from last disk inserted remains in place in My Computer, untill AnyDVD is cycled off and back on.

Yup, same exact thing thats happening to me…its very annoying.

Have either of you opened a support email with Slysoft on this? It may be a bug that they need to fix. I can tell you, however, that AnyDVD contains a fix for a Windows bug of this exact nature. It may be that the fix doesn’t work on your drives and/or that it ends up CAUSING the issue in your case. Either way, I’d send them an email detailing the problem(reference this thread, as well) and see what they say.

P.S. ColonelPwnage, go here:

That has info on an updated firmware that just came out a few weeks ago for your drive.

Will do Samuri, most likely tomorrow, kind of tied up this evening.
After a bit of experimenting, I have discovered that cycling AnyDVD will not fix the problem 100% of the time. Sometimes it requires a reboot for the volume info to return to empty and display type of drive. Or, inserting a different title, and cycling AD results in display of the new disk.
Also, if AnyDVD loads at startup, Windows will not identify a disk when inserted, but merely displays the usual drive description information.
However…even though the wrong info is displayed in Windows, AnyDVD displays the correct information within the Settings/Status window for any subsequent disks inserted, and functions correctly when ripping. I just happen to stumble upon this issue a few days ago by accident, when looking in MY Computer after backing up a disk. It may have been doing this from day 1, and hasn’t affected any of my programs functions that I am aware of, so it seems to be a minor issue, in as much as I can tell.

Yea, this is a known Windows flaw that they fixed in AnyDVD, so, either the fix isn’t working correctly on some drives, or something else is causing the issue. Definitely let Slysoft know (give them your drive and firmware info and any other pertinent info plus reference this thread) and see if there’s anything they can do. Who knows, maybe they’ll be able to find the problem and fix it. At the very least they should be able to give you more info on what’s going on. Good luck guys!

I’ve been having a similar problem, what has been happening with me is when I finish backing up one DVD and insert the next original DVD in my drive, it is not recognized by my computer. Often I have to re-boot my machine before I can back-up the next DVD. Anyone else had THIS problem?

Possibly unchecking “Enable AnyDVD” (right click the fox) before inserting the new disk, and then reenabling it after the drive recognises the disk, (even if Windows still labels it by the previous disk name) would save you from the reboot.

This is a known bug in WinXP. It may cause many problems but the most common are:

  • drives do not refresh (and no label change)
  • F5 does not refresh explorer windows

You can download a fix from MS that repairs the autoplay functions. It’s not as simple as just re-enabling the autoplay option from the drive property tab. I had this problem twice and it repaired it both times.

You may need to run it more than once. The first occasion I had to run it twice, and the second time I ran it 4 times! It needs a reboot after each run and it runs in “steps”, hence the reboot after each step where something is found wrong.

Once repaired, all should refresh correctly. You can then either turn off autoplay in the drive tab (or using TweakUI) or have AnyDVD handle that.

You can get it here from MS:
http://www.microsoft.com/downloads/details.aspx?FamilyID=c680a7b6-e8fa-45c4-a171-1b389cfacdad&displaylang=en

My bad, I do have the SB03 revision. I thought I had SB02, but I checked the device in device manager and confirmed its the SB03.

Not a problem. Just wanted to make sure you had the latest in case they fixed something.

W00T!! That fix from MS did it! I appreciate the help! When I ran it, I pointed it to my dvd drive and it said it detected a driver problem. I clicked fix, rebooted, and viola. Volume label refreshes again.

Nice one, goober22. Hopefully this helps everyone having this problem. Alan, perhaps we should take this post and sticky it for future reference? We’ve seen this problem a few times and if this helps people out that’s be great.

Thanks goober22, much appreciated. :clap:

I’ll try the fix from MS, but it does not do it every time, just whenever it wants to. So it may be a few weeks before I’m sure it really is fixed. Thanks for the link.

No problem guys. I searched for weeks for a cure until I ran across a post in some forum somewhere (can’t remember) while doing Google searches. It fixed me up. It seems something messes up the reg settings somewhere (maybe installing/uninstalling so many apps to test) but it fixed mine both times it occurred. I have a copy tucked away in my “tools” folder just in case. :wink:

Excellent idea. This post is not likely to get sticky status, so, guys, keep this one stored somewhere just in case. James has mentioned that there is a Windows bug that’s been there forever that causes this issue and that AnyDVD attempts to work around it. Seems like MS is aware of it, as well. Let’s hope it’s fixed in Vista. :slight_smile: (I’ve yet to see the problem in Vista, but, um, I seem to have never run Vista without AnyDVD in the background for some odd reason. :wink: )