DVD & Subtitles

I have noticed when burning a film only (using dvddecrypter & dvd2one) - I do not get the subtitles appear when a foreign language is spoken. On the original they just pop up when they are supposed to.

Surely these sub-titles are '‘part’ of the movie. After all, I don’t press substitles on when I’m playing the original DVD.

I have tried a number of ways with DVD2ONE, but with no luck.

Can anyone help. I’m only after the movie and one sound track. No menus & no subtitles all on a single dvd.

You’ve fallen into the trap of deleting subtitles that are actually needed.

On the original, the ‘translations’ that appear at the lower edge of the frame, really are subtitles (not part of the film as you assume). The only difference is that they are what is called ‘forced’. In other words, they alwaysappear at the appropriate time and you don’t get to call the shots via the controller.

However, if you use a utility to strip them all out, then all bets are off. You’ve thrown the baby out with the bathwater!

Always be most careful about deleting English subtitles. If in doubt, leave them. They don’t take up enough room to make a discernible difference to your movie anyway.


Trap - I don’t think so.

I have just tried what you have said:
I have decrypted the whole dvd onto my hard disk. The ran DVD2ONE and burned the movie only with the 6 Ch. english language and 2 english subtitles ticked boxes. (one was forced english subtitles).
Anyay, the result - still NO subtitles at the appropriate time.

The film: Star Wars Episode 1, The phantom Menace ; timing of one scene where the subtitles should appear are Chapter 18 (51Min. 48sec)

I have even tried using DVD2ONE on the basis of having copy mode in full disk and EVEN these does not do it.

Surely this consitutes as a serious flaw ?

will it not be because the stream ID will have been changed or does DV2One maintain the original stream numbers for subtitles now

I’ve seen it posted regarding the audio now maintaining the same streams but does the same work for subs cos it don’t look like it


are there only 2 english streams and the forced is definitely the 2nd english stream?

some have 2 english subtitle streams and then other unknowns which are sometimes the forced streams

I have that DVD here (region 2) and I’ll check if you ain’t 100% sure

I’ve just checked mine in PowerDVD and there are 3 english subtitle streams within 7 subtitle streams

the 1st is obviously the complete english subs, the 6th is the directors and the 7th are the forced subs as you can see are autmatically checked

what you need to check is that after processing using DVD2One you still have the same amount of streams and the same stream checked during playback

If you only have one stream and not 7 with 6 dummy entries then you will need to remap stream 7 to show the same subs as stream 1 and it will work :slight_smile:

I have just tried DVD2ONE using FULL DISK as copy mode and it DOES work, but I only want the movie copied.

MackemX, I am not sure if I totally understand what you are saying. I have ripped the whole dvd onto my hard disk. Using DVD2ONE I have included just the 2 subtitle tracks I thought I would need - being
English - Closed Caption &
English - Forced.

There is only one other english subtitle which is headed
English - Directors Comments , but surely I don’t need to add this too, do I ?

IS that the 3 you mean ? and do I need to include all 3 for this to work ?
Talking of remapping streams seem to fly over my head, unfortunately !!

do you have PowerDVD 4.0?

if you play the original DVD and right click the screen the select audio you will see the 7 streams

now if you play the DVD that DVD2One produces by opening the IFO then you can check and see how many subtitle streams it has

it should still have 7, if it has less then you need to modify the IFO to correct the stream mapping

it’s simple to do once you know how and if you don’t know to do it or can’t find a guide I will find the link to a guide I have used

Yep , I do have Powerdvd 4.0 and yes the original movie does indeed have 7 streams listed under SUBTITLES not AUDIO LANGAUGES as you staed.

The movie created by DVD2ONE only has 3 listed, but I don’t think there should be any more as I only chose those three english subtitles when using DVD2ONE.

With the subtitles sub menu, If I click on display substitles and english 3 then the movie shows the correct subtitles only at the correct points.

In the original movie all these options are greyed out, but are as I have already mentioned above i.e subtitles on and english 3 chosen on the subtitles section.

I need to get the same options greyed out and activated just like the original. The fact the other subtitle streams don’t exist surely does not matter ?

Anyway , thanks for your help so far. I’d better go to sleep.I’ll catch up with your reply tomorrow.

Originally posted by andypandy
Yep , I do have Powerdvd 4.0 and yes the original movie does indeed have 7 streams listed under SUBTITLES not AUDIO LANGAUGES as you staed.
oops :slight_smile:

so at least now I know the cause of your problem. you only have 3 subs streams yet you need 7

streams 1-6 should be dummies and stream 7 should be the forced subs

this post here will explain how to fix it with Ifoedit


any questions just ask cos you may find it hard to understand at first

Hard to understand may be a bit of an under statement, but after a few reads I think I’m getting to grips with it. Some things were not quite accurate in the article and I think I have found a quicker route within the article .
I am still trying them out and hopefully I’ll post the successful outcome tonight.

one thing that may have been obvious, but not to me, was that had to open the VTS_01_0.ifo file in IFOEDIT. I was opening the other file .ifo listed and I couldn’t see the options mentioned.

Anyway, I only selected the forced english sub-title track in DVD2ONE.

I altered the number of sub picture streams mentioned to 7. If I understood the notes correctly, I found I did not need to change any other values as all the other streams were zero because I did not copy them. After saving the file and checking Power DVD I found the options were still not greyed out and sub-tile was not ticked.

The easy option, which seem to work was to simply switch sub-titles on and then they would appear at the appropriate time as that was the only sub-title track I copied.

I am curious where I have gone wrong.