Dvd Shrink problem

vbimport

#1

I have a small problem with Dvd Shrink. Yes I know that it is old and no longer supported.
Ok the problem I'm having is: when I try to output the results to a external 3 TB hard drive it gives me an error "The parameter is incorrect" It works fine with my 2 TB external HDs. Mr B, Debro or anyone else have a tweek for this?

Many thanks for any help you can offer. If it is just to old to recognize that large of a HD, so be it. I can send the shrunk files to a internal HD then transfer them over to the 3 TB for storage.


#2

I stopped using the program [I][B]because[/B][/I] I was getting this error. I am curious about what causes it also. Even if I uninstall and reinstall the program, it gave me the same error.


#3

You may be running into a problem with Shrink not recognizing the 4k sector format used on newer hard drives. Shrink was written back in 2003, and is undoubtedly set up for the older style 512 byte sectors.


#4

I don’t have any harddrives that large. So I can’t test. What Kerry posted sounds like the probable cause.
Maybe the 3TB harddrive could be reformatted to the 512 byte sector size.
That probably would only effect speed performance & possibly lower the capacity some. Just guessing on that but it might be worth checking out. Or as you posted :
Use the internal for DVDShrink then transfer.
I usually use CloneDVD2 to do transfers like that. I’ve found Windows copy & paste can cause some artifacting or audio problems. This is not consistent but if you have done a transfer with Windows & the rip checked out fine before but not after that is what I think causes it.


#5

I don’t think this is the change-over to 4K Sector but rather a new implementation of Sector Address commands instituted for 64-bit OSs. This is also the reason behind “Bootable Partitions Must Be 2Tb or Less”. For some reason, the calculation of the 64-bit UEFI-style GBR takes too long and Bootable Processes must be installed first before the GBR is loaded.

It smacks of those synthetic driver utilities that mask drive-sizes and present some translation-upon-translation set of tables.

The real question would be, “If I went back to a 32-bit OS and chopped up my 3-4Tb drives into 1-2Tb partitions, could I use those?” I think so.

Leaving DVD SHRINK to read-and-write to a >2Tb partition (like the boot partition must be) is one option. DVD REBUILDER has some good SHRINK abilities. “Keeping an old computer in good running condition” will ultimately be the only way to ensure DVD SHRINK’s valued services continue to run.


#6

I think Christine came up with the explanation.

I only use Shrink with a 32bit .
My main use is to either cut a clip out that i want &
A TV series ripped from DVD so I can seperate each episode.
Then create a simple menu & get the best fit on a SL DVD.
Usually 3 episodes per SL DVD.
I’ve found that DVDShrinks’ transcoder works well but if I want to be sure .
I don’t compress any with DVDShrink .
Then I use DVDRebuilder.


#7

Small test completed. DVD SHRINK can read from one of my media RAID5s (15Tb - six 3Tb drives using one as parity with 5 actives). But I did all my Writes to my C: Drive because indeed DVD SHRINK couldn’t write to the RAID. I never bothered trying before, though. I suspect DVD SHRINK is using some Validate-Write command that is based on a 32-bit Address. In this process, a Program will check to see if Address exist, then validate an Acknowledge Write-To step and that’s where the 32-bit SHRINK programming fails to get an acceptable response.

The Read-From isn’t an issue because DVD SHRINK isn’t reading from the hard-drive - it always reads from Memory or Page-Memory, and my 64-bit OS has translations for “x86” program limits. It’s the Write-To and Validate-Write-To steps that fail inside DVD SHRINK’s 32-bit programming.

If DVD SHRINK was updated, it might get around this by using Microsoft’s newer table of WRITE TO/VALIDATE WRITE TO commands so a 64-bit OS could re-translate onto larger-than-2Tb partitions itself. But it looks like DVD SHRINK’s programmers were doing what most of that era’s programmers did - take care of Writes and Validates themselves, in their own program, rather than relying on Microsoft’s, uh, “expertise” to handle SAVEs. It wasn’t an unwise choice at the time!


#8

I looked this up on Google and over at Videohelp.com. One person was having this same issue, and was advised to run DVDShrink as administrator. This solved her problem writing to a 3tb external drive.

So, it may simply be a UAC issue.


#9

I haven’t tried this one yet!


#10

I always use shrink in my admin account and it has no problems with either one of my 2TB external drives. Since Shrink is so easy to use (I only use it where 15% or less is required to do movie only) I set it up on a friend’s (no computer savy at all) and he called me when his 'puter wouldn’t let shrink write to his 3TB drive. He is using XP pro, I think. I’ll just tell him to keep using his 500GB external and to transfer only the movies he wants to keep to his 3TB drive.
Shrink works great on my Win7 64bit. I was really shocked when I found out that it would.
Thanks for all the info guys. I am just now getting around to putting all my movies that I lost when my last 'puter burnt up on to this one and I am using external drives that stay shut down unless I am moving data around so maybe I won’t lose them again. ( about 800 to 1200 movies)


#11

If your friend is using XP, it cannot be UAC. And the vast majority of people on XP use the 32 bit version…XP 64 is a cludged up excuse for an operating system.


#12

Ah - XP with a 3Tb drive… then the problem is likely related to the special translator driver installed so XP can ‘see’ a 3Tb drive.

Just have him default his SAVE TO destination to his C: Drive, and then he can burn from there reliably, too. THEN if he wants to save those files to his 3Tb drive, move them there. I’ll bet they’ll play from there if he’s using it as Media-Server storage.

But I am always suspicious of those translator packages - motherboards offer them as do most of the HDDs, too, but they’re still extraordinary drivers for a base-level drive function. This demands absolute perfection on every function, and we all know how perfect our tech world is.

If and when he moves this 3Tb to a newer system, he might serious problems retrieving the 3Tb’s data. He’ll be safer to build that newer system first, install another clean hard-drive and transfer that data from his XP-based 3Tb onto that new system’s clean drive - via some network cable. THEN install that 3Tb drive and see if the data’s scrambled or not.


#13

New Egg had them on sale for $110 and I asked my friend if he wanted one because I was going to order one and he said sure. I have win7 Home premo and it doesn’t work on my system either. I think I will try to partition mine to a 2TB and a what’s left over and see if that will work. If it does I’ll do his the same way. That way he can write from Shrink to the 2TB part and keep his music on the other partition, and I’ll remove the partition on mine.


#14

Your external must have a power consumption problem, AFAIK.


#15

Partitioning worked good. Every other program Has no problem recognizing the 3Tb.