DVD-RW drive reading DVD-R as CD-R

vbimport

#1

I’m new to this forum, and forum posting in general, so please forgive any newbie sounding comments or questions. I have an HP DVD writer 640c. Every time I incert a DVD-R or a DVD+R, the dirve reads as a CD ROM drive and some, but not applications used to burn DVDs report an incorrect media error. Hardware errors are something I know very little about. Is there a good way to fix this problem?


#2

Can you post a few more details about the problems you’re having?

In Explorer, my own DVD burners change to CD-ROM Drive too, that’s just a bug in Explorer.

Which applications give an “incorrect medium” error, and what are you trying to do?

Welcome to CDF, BTW :slight_smile:


#3

Right now, I am trying to burn a video DVD using windvd creator, not the best program I know, but I have gotten it to work befor. befor I incret any disk, the drive reads as “DVD-RW Drive” under My Computer and explorer, if I incert a blank DVD-R or DVD+R, which I only tried once, the drive name changes to “CD Drive” and the auto-play function starts, giving options that relate to CD-R media. If I attemt to select something from that auto-play menu I get the “I:/ is not accesible, incorrect function” error. However, Sonic RecordNow will recognize that there is a DVD in the drive, and will burn to it. I have also had problems when trying to do a stright CD copy from my DVD-ROM drive to my DVD writer using Sonic.

Thanks for the welcome Arachne


#4

“Incorrect media” is typically a hint that you should be searching for a firmware upgrade or crossflash.

Edit: This drive is a BenQ 1625, (it has LightScribe support, correct?), and could be crossflashed to the latest 1625 version, BBIA, if an official firmware update from HP doesn’t fix your problem.


#5

I am familiar with the term crossflash, but could you run me through the basics of a firmware change.


#6

All of this is normal. Try looking for a firmware upgrade from HP, if not, you could crossflash it to a BenQ (see above post).


#7

No probs :slight_smile:

The part quoted above is normal behaviour for Explorer - mine does the same.

See TehGrue’s reply above about crossflashing, it’s a good start :slight_smile:


#8

As said the identification in explorer/my computer (technically the same thing) is a bug, it happens to me too.

Does the problem with the CDs happen on all machines? Some contain encryption to prevent straight copies.

Download the trial version of Nero and see what it reports back and if you have problems with it.

Don’t do a fw upgrade unless you have to, and if you do not know what you are doing avaid crossflashing. Crossflashing is not realy for the newbie as it voids the warranty, but if you don’t know what you are doing you are more likely to make a possible mistake and ruin the drive.


#9

I think I would like to change my firmware to BenQ, but simply downloading the .exe file from the BenQ site has failed. Is there another way?


#10

I’ve got a similar issue with my HP 840b supermultidrive burner, turns out my cd burner laser is konking out and is screwing around with any blank dvds or cds as being not writable, I’m still under warranty so I’m getting a new burner sent to me to replace, it and although the only problem is with is the cd laser, i can’t burn a data dvd for backing up right now, which i want to do. I went through removing upper / lower filters in registry uninstalling drive and restarting. Wouldn’t burning a data dvd use the dvd laser even if it sees the optical drive as a “cd drive” in its brokenish state?


#11

I’m having the same problem with mine…It now reads as “CD-R drive” when I’m trying to recode a DVD with Nero 7…and now it reads as “CD-R drive” when I’m not doing anything…I’m not tech-savvy, and if you guys have ANY idea how to fix this, I’d greatly appreciate it. I do not know the type of DVD-RW hardware it is; my computer says standard, and this was a gift (used) from my father. I’ve had it for years, and it worked fine until a couple of days ago. There is also no update available for the driver. I’m at a loss.


#12

Go into device manger and uninstall the IDE channel thats it’s on and reboot and let windows reinstall it, Make sure you don’t delete the IDE Channel that the hard drive is on