DVD-RW -drive excellent read error correction etc.?

vbimport

#1

Hi folks,

Some days ago, my NEC 4571A stopped reading some pressed(!) DVD movies out of the blue. I tried said discs out with a cheap standalone player, which had no trouble reading them whatsoever.

I’ve been going over the drives which are currently available at a local store (LG H12N, Lite-On18A1P, NEC 7173 and Samsung S182D) and all of those seem to have a single notable issues at the least - from the S182D’s DVD-R lead-in problem to the LG’s “abysmal” DVD read speed.

And now I’m in a dead-end. I found very few comments on read quality when searching for info, which is to be expected considering the nature of this website though. But that aside, I would very much like some recommendations as to which drive would have outstanding read (DVD and CD) capabilities. Of course I’ll still to burn a DVD every now and then, but speed is no concern - even 4x would be just fine since I write discs so rarely.

Thanks.


#2

The best choice would be a Pioneer 111, but the read speed of the LG drives is not an issue unless you are ripping a lot of DVDs and it looks like that is not the case. My LGs have always been very good and they keep getting better.

Welcome to the forum.


#3

My own SH-S182D (and that of another moderator) has no lead-in problem, and it’s excellent at reading even the dodgiest discs. It’s a great drive, and probably my favourite at the moment.

Maybe you could try one with the option of returning it if it has problems?

Just my two pence worth, even though I guess you already decided against that drive. :slight_smile:


#4

I didn’t rule out anything permanently… yet. :wink:

Seems I need to perform more extensive research on the drives mentioned. But I would like to know one thing Arachne: which firmware version does your S182D have?

Cheers!


#5

It came with SB02 - no -R lead-in problems, and I’ve since flashed to SB04 - again, no -R lead-in problems. :slight_smile:


#6

Ended up getting the S182D. Still some issues with DVD movies… sometimes they work, sometimes they don’t. What’s more, I tried to scan the surface of said DVD’s with bizarre results. A disc that yielded over 99% in bad ‘sectors’ (or whatever they’re called in this case) later showed 100% good. Slowing down the read speed via CD Bremse did not affect end results.

It’s possible that the JMicron IDE controller is to blame. I will propably swap this drive for the S183A (SATA) when they become available in two or so weeks (which is why I didn’t get one in the first place).


#7

That’s very strange - but having said that, mine’s not on a JMicron controller, and there have been issues with those (huge thread in the ODD forum somewhere). I also don’t tend to run scan disc on any of my discs, so I wouldn’t know about any issues there. :slight_smile:

Try connecting the Sammy to it’s own power connector (not sharing with a HDD or GFX card or whatever).


#8

I do have the drive connected to a separate power cable.

Anyhow… I managed to obtain a S183A just two hours ago. Now to overcome my laziness and install it. :smiley:


#9

Ah, nice one :slight_smile:

LOL, you work fast! Enjoy the new drive, and let us know how it works out :wink:


#10

Blargh… still have problems with one disc in particular. Only explanation now is a haphazard copy protection scheme, so I’ll try to rip the whole thing and see if that works.

And they wonder why people don’t buy DVD’s. Not only this nonsense but I’m also forced to watch that annoying ~40s “piracy, it’s a crime” clip whenever I play that DVD. Nothing quite like treating paying customers like scum. :rolleyes:


#11

Grr, AnyDVD and other programs just hit a wall halfway through.

The disc(s) (5x4 DVD box sets of Hercule Poirot…) in question have been published by Granada Ventures, whose releases I will boycott from now on. :a