Dvd+rw drive doesnt work

Hi

I’ve just installed a DVD+RW drive to replace my old CD-RW drive. It’s the Pikaone IDE1008 drive from PC World.

The info that came with the drive says that it’s a plug and play drive,so I connected it up and it seems to work fine, except that it can’t read DVD’s or CD’s!!!

It CAN recognise blank dvd’s however… but wont write to them, only to CD’s

I am using XP Pro… and am a TOTAL newbie so I don’t know about much else.
The device manager says it should be working fine and i can’t find any drivers so I don’t know what else to do.

Any advice would be greatly appreciated.

Glen

have you installed a aspi driver, adaptec do one free for download from there website, also did your cd-rw drive work fine?

My cd-rw drive was fine, that’s why i am so concerned.

I dont know about an aspi driver, simply cos I dont know what it is. I will look into it.

thanks for your help.

ok this is going to sound so daft but i got that aspi from the adaptec site but i dont know how to install it…

i click on the install app and it says press any key to continue. i press a continue and it closes… should this happen or am i being totally stupid?

Right… I’ve had a play about with it and have found that:

  1. It can recognise blank DVD’s and CD’s, or apparently music CD’s that have been created from the drive.
  2. It cannot recognise data CD’s or movie DVD’s. It recognises that there is a disc in the drive but suggests that the disc size is 0 bytes.
  3. Nero or any other burning programs can recognise it except Windows Media Player, which recognises it as a CD Drive (I assume it still sees it as a CD-RW but am not sure)
  4. Windows Media Player can use it to burn to CD, I copied one of my CD’s with no problems. When I tried to copy a DVD it said that there was not enough space on the CD, even though it recognised the blank DVD in the drive.
  5. Windows Media Player can recognise all audio CD’s but the actual CD drive cannot… weird

I assume that this must be some kind of driver or setup problem cos it sees everything there but just cannot perform the operation. Hopefully, anyway.

If this is all laid out too confusingly email me at glenfletcher@boltblue.com with DVD Drive as the subject and I’ll explain it to you in more detail (if I can, I am pretty clueless at this kinda thing).

Thanks for your help
Glen

This may sond daft…but did it come as a kit with it’s own ide cable or a bare drive?

Your old cd-r/rw may be connect to the main board with an older 40 pin single density ide cable, your new spanky drive may really need the newer 40pin/80 wire cable…

Just an idea…:slight_smile:

tell us something more about your system config ( Motherboard …)
where is your drive located, ( Primary master slave, secondary master or slave? )
what is the other device on the ide channel?
is DMA mode enabled?
have you installed any pocket writing software like Nero INCD or Roxios DirectCD?

Zigzag: It came with a cable but it looked the same as the old one, so I just used the old cable. I think the old cable was white but the new one is yellow, apart from that they appeared to be the same.

Herbei: Dunno about my motherboard and that, how do you find out? I know it’s the secondary slave though. My other device is a bogstandard DVD-ROM. Dunno what DMA is. I have installed Nero INCD and Alcohol 120, both of which fail to recognise that the drive’s there. Windows Media Player does however, but only for CD’s…

Thanks guys
Glen

you can check this out using Nero Infotool

start --> programs --> nero --> nero toolkit

try to set the burner to sec. master, or try to run the drive without a connected dvd-rom drive.

you can also try to remove the secondary ide channel from device manager, after a reboot the drives are installing new automatically.



Right… I made it the secondary master and turned it on and it worked ok. So I made it the secondary slave again and it works fine.

BUT

Now my original DVD drive wont work!!! It recognises the CD or DVD in the drive but says that it’s blank!

AAARGH!!!

Help me please!

is your dvd-rom jumper cs (cable select) or slave…sounds like a master / slave conflict

ok, make the DVD writer set to master and the CD-RW set to slave,
, if it still doest work you could try reversing the roles (dvd writer slave and cd-rw master), oh and to install the new aspi once you have downloaded the exe file and “instralled” that, look in C: >adaptec folder then open “ASPIINST.EXE”, do what that says then reboot. :slight_smile:

bcn_246 I have a DVD-ROM drive and a DVD+RW drive. I THINK that I have it set to DVD-ROM master and DVD+RW slave. But I’m not sure.

What’s this ‘Cable Select’ Thing that was mentioned?

I tried them both separately and they worked fine, so I know that it’s not the drive that doesn’t work.

It’s when I use them together that there’s a problem…

bcn has given you a reall good grapic of what needs to be done.

2 ide devices on the same channel need to be setup as master/slave.

The jumpers on the back of the drive do this.

CS (cable select) is a half assed default drives usually come set as…Ie, I’m the master or alone if no other drive present this ide channel, or slaveif master present, it doesn’t always work though.

AS BCN said…physically jumper one of thdrives as master…and the other as slave. Reboot, and let us know…:slight_smile:

Will do

Thanks :slight_smile:

Right, did that.

Turns out my DVD-ROM drive has 5 of those master/slave things. I tried em all, and only the one it was in and the middle one work. But on the middle one neither drive will work properly, they will read the DVD/CD but say that there’s nothing in the drive. (The icon changes from DVD drive to CD drive and says that there is no space on the disk, and asks to insert a disk).

Will my new DVD+RW work as a proper DVD/CD drive or is it only useful for copying? Cos I’m considering using it on its own…


Scratch that. Now I am trying to use it on its own as the master but it won’t work.

WTF is going on…

Now it is working.

For the moment at least… I am going to attempt to copy a DVD and see what happens.

(Beginning to feel he should have taken his new drive to a shop… :sad: )


It didn’t work. Stopped around 33% for no apparent reason.


Another interesting thing I have just found:

When trying to mount an image onto my virtual DVD drive using alcohol 120 it displays the same characteristics as with the physical drives. Surely this shouldnt happen?

Right. I have managed to get all 3 drives (2 physical, 1 virtual) working.

But only by placing a DVD in them and rebooting the computer.

Otherwise, on the insertion of a disk they revert to a ‘CD Drive’ logo rather than ‘DVD Drive (or whatever it was)’, showing the DVD to have a capacity of 0 bytes.

I assume there must be some form of driver or something that I am lacking, as I seem to have the master/slave thing under control now…

(I know I’ve made loads of posts but I thought I’d just try and keep those kind people who were helping me aware of the situation. Believe me this is not how I wanted to spend my Saturday afternoon…)

I hope you can help me with this.
Glen

As a stand alone drive…it will read as well as write both cd’s and dvd’s. It’s generally considered useful here to have a seperate dvd-rom for ripping, but your burner can do it all on it’s own.

ok, it may be the drive gets “frozen” and wont accept new media without a reboot, vso´s Patin-Caufin driver comes with a “unfreeze” function so you could try installing that and using the “unfreeze” function when inserting a new cd/dvd, as ZigZagMan said you could have one drive for reading and one for writing, but this isnt allways idea particually when trying to get new protections to work, also i suppose it is better to have 2 working readers for making .bwa files etc.