Dvd-rw drive/ blank dvd changes drive to cdrive

vbimport

#1

i didnt know where to post this really i have a NEC DVD_RW ND-3520A with updated firmware i only nodiced today when i tryed to burn a movie.

i placed blank dvd-r disk in the drive and it hangs for a few seconds then changes the icon for the drive from dvd-rw drive to cd drive but the disk reads dvd-r with zero free space on it ive tried several disks nothing worked always same resultes i take disk out it goes back to dvd-rw drive put one in changes to cd drive also it plays burnt cds and dvd just fine.

i may get lost here soon information but ntools says my firmware is 3.04 i belive and i have both my ide channels set for DMA and auto if possable.

i used google but only found other people with the same problem and they have diffrent drives.

EDIT: If this needs to be moved sorry i didnt post here because i think you guys are smarter its just this issue seems to be a problem that ocures with winxp sp2 and any dvd drive -.- and im at a loss


#2

What happens when you try to burn to the disc and what software are you using to burn? List any error messages/logs too for best help.


#3

it wont let me burn to dvd says to insert a empty dvd the programs ive tryed in the last few hours are alochol120% nero6 and just plain microsoft burning utility all tell me the disk is full and to insert a empty dvd i looked and it says the diskes have 0mb free space and total space = 0mb also soon as i eject the disk the drive changes back to dvd-rw drive soon as the new dvd goes in the system hangs for a few seconds and then pop up window asking me mothod of burning but then i get that error the disk is full
hmm i looked under my eventlogger and from 5:11:52pm to 6:34:47pm the IMAPI CD-Burning COM sent a start control then the IMAPI CD-Burning COM entered a running state followed by the IMAPI CD-Burning COM service has entered a stopped state these occured about 5seconds apart from each other continually untill 6:34:47pm not sure what that means i just knew where to find it. Also it seems to br reading blank cd’s just fine i test it and burned music to one of my 700mb disks

i found a site that says it maybe caused by a fulty SP2 atapi.sys driver verson 5.1.2600.2180 i found an older verson of the driver verson 5.1.2600.1106 and installed it in place of the 5.1.2600.2180 and rebooted and its doing the same thing i tried uninstalling the dvd drive alltogether and reinstalling it and nothing its still doing it. i did take it out of my pc place it in my parents pc and it worked like normal and read the blank dvds brought it back and place back in my pc and it it was the same deal put disk in changes to cd drive and dvd is 0mb pop it out and its back to dvd-rw :frowning: ive been trying to fix this for problly 4 or 5 hours now i might take a rest at it till someone posts =) and here the link to that site that exsplaned the faulty atapi.sys driver http://erpman1.tripod.com/current/atapi-xp.html but i had to really hunt for the 5.1.2600.1106 verson and like i said it didnt solve the problem which is why i flashed it to the newest firmware thinking maby that would solve the problems needless to say it didnt


#4

I read your post quickly- The one question i have is what are you trying to burn. alsoWhat version of nero??


#5

You can’t burn to DVD with Explorer, but not burning with Nero and Alcohol is an entirely different problem…


#6

ive tried to burn avi, and iso images to dvd-r formate which is the only type my player reads besides dvd-rw the verson of nero im useing is 6ultra full verson. one thing i want to let u guys know is when it changes to a cddrive i see this change when i watch it under mycomputer where it shows the drives. its dvd-rw drive when its empty i insert a blank dvd-r disk which always worked b4 and it hangs"lags" the system for about 6seconds then the option of burning viewing or do nothhing pop up and at the same time the D: drive (my dvd drive) changes from dvd-rw drive to cd drive but oddly enough it knows it has a dvd-r disk in but says it never had any space on it 0mb total and 0mb free space give me a little ill get screen shots for you folks its listing it as a cd drive ahead fo time also but stilll has dvd drive options till i place dik in and it changes

EDIT: ok here they are too big a size to use image tags so heres the links :doh: not sure how to resize the pictures with out losing the quility of the images =(

http://i17.photobucket.com/albums/b99/D2Meep/dvd-rwdrivenodisk.jpg is with out disk in
http://i17.photobucket.com/albums/b99/D2Meep/drivewithdisk.jpg with dvd-r disk in nodice its saying dvd-r but it changed to a cd drive =( i only nodiced this problem yesterday ive only had sp2 installed for a few days.


#7

Which exact version of Nero is it?
You can see it in the about box. If it is lower than 6.6.x.x you maybe should upgrade it.


#8

i got alcohol120% to let me burn iso files but thats it im still unable to burn anything else to dvd so its a start what i did was look up my dvd drive useing alcohol120% then i clicked on disk by some chance it nodiced the disk i had in the drive was in-fact empty i clicked ok and tried to burn and it actully started this time needless to say nero ultra 6 is still not beliving its an empty disk and so trying to burn movies to disk as .avi’s are out of the question still =( also when alcohol120% makes the files into mds files and i tried to burn to disk alcohol decied the blank dvd was not empty agine -.-so pretty much back to square one also i cant make data disks for the same reason doesnt even let me place the files on the disk folder because the disk is supposedlly full =/

the verson of nero is 6.6.0.16


#9

Fooled by shrubby exploDer…


#10

errr… :frowning: whats that mean??? exploder?


#11

Windows only supports CD-R/RW and DVD-RAM media for burning with it’s shrubby IMAPI Burn Engine.

The icon for ODD will change in the explorer depending on what media was inserted last time… :rolleyes:

Use a REAL burning app.


#12

I think that IMAPI is not used for DVD-RAM, only for CD. During DVD-RAM access/format IMAPI.EXE does not appear in the process list.
Furthermore, even disabling the IMAPI service, it is still possible to use the DVD-RAM direct access feature.

The following link from Microsoft library seems to confirm that.

Regards, :slight_smile:

ET


#13

This is correct, I just wanted to point out that xp has no dvd burn support beside for DVD-RAM…


#14

ok then what is the atapi.sys used for?because if u look near that top and follow that link it says sp2 has a fulty atapi.sys file could this be the problem?

also i was able to install sp2 with no problems so im at a loss chef’s answer partilly exsplains the situation but doesnt tell me why it tells me the disk is empty but theres no space on it.


#15

Some Packet-Writing software is surely installed and that’s the reason for this confusion…


#16

so no way to fix the problem? its flatout not letting me burn with alchol or nero because it always thinks the disk is full even though the programs are listing the disk as empty


#17

Uninstall InCD, DLA or similar and uninstall Alcohol properly.


#18

I have the exact same problem, and i don’t know how to fix it. dvd+rw drive read blank dvd+r/rws as cds. and the dvd+rw drive turns into a cdrom drive. i used to be able to burn avi video files to dvds, now it won’t let me, Nero 7 says that there is not enough disk space available in the dvd, when in fact there is (it just reads it as a 700 mb cd+r than a 4.x GB dvd+rw). Does anyone have a solution? I donno if this will help but i’m using sp2 and my dvd writer is an NEC DVD rw ND 2510A (recently flashed from a 2100, i thought if i upgraded firmware, it would solve the problem, but it didn’t).


#19

I doubt that your drive recognizes a DVD+RW as CD - only the stupid explorer does fool you here. :frowning:


#20

but why wouldn’t nero 7 burn avi files to dvds? and I donno what u mean by “stupid explorer”? :sad: