DVD-RW 1008IB(No Firmware)

vbimport

#1

I used LiveUpdate to try to update my firmware. Unfortunately my PC crashed and…you all know whats next…its cream crackered(not working atall) I’ve read explanations on how to rectify the problem but i can’t make it work. The shop where i bought it won’t do a thing. Is this completely irretrievable or can someone help…please!!! I’m running Windows XP Pro SP2 if that is any help to you.


#2

try to flash the drive under dos, recover link in my sig


#3

I’ll give it another go but I’ve already tried and failed. Have all the downloaded zips got to be on floppy. I couldn’t get to the new dir in c when i rebooted to dos.


#4

:confused: Please anybody help, I’ve gotten as far as d:\dir. The dir i added (FW) is there…all good up till now!! How do i open the DIR? What do I type next D:???, the explaination of the string ie MTKFLASH 4 W /M fw.bin is all good but it the bit b4 the string that i get stuck on. I am sorry about this but I really am computer illiterate. I’ve done weel to get this far…HELLLLLLLLLLPPPPPPPPPP!! :confused:


#5

I’ve tried unsuccessfully to follow H3rB3i 's instructions on how to Recover a MTK based DVD-RW under DOS (short guide). I can’t get the string ‘MTKFLASH 4 W /M fw.bin’ to work… anyone any other ideas? :bow:


#6

Read this post http://club.cdfreaks.com/showthread.php?t=96896 it talks about flashing a 1004IM, but you can use the same procedure to flash your 1008IM in DOS.

I actually have a 1004IM that I flashed 1008IM firmware into.


#7

I´s your drive recogniced when you booting up your pc?

Try this:

  • disconnect the drive (only ide cable not power supply)
  • boot up the pc under dos
  • disconnect the other DVD/CD-Rom drive
  • connect the 1008 to this ide channel as master (jumpersettings !!!)
  • call the directory where the fw file and the fw.bin file are available (d:\ and then cd dir)
  • be sure that both files mtkflash and the fw file are in the same directory
  • flash with the string mtkflash 3 w /m fwfilename.bin

if the mtkflash don´t work try it with an older version of mtkflash you can find it on http://dhc014.rpc1.org there can you build also the flash command.
i always flashed successful with mtkflash 1.80

hope that works for you


#8

If i connect my drive I cannot get past ‘detect ide driver’ just after memory test. When i disconnect the power cable to the drive it boots up.


#9

try to flash with mtkflash version 1.80 not 1.80.1, i remember that there was a problem a view weeks ago, where also only 1.80 worked.


#10

I’ve tried with mtkflash version 1.80 and 1.80.1 all i get is: updating 00% then ERR: fail to open input file. I’ve got a sinking feeling here that my drive is dead and doesn’t want to be brought to life again (DNR). Like i said before if i connect the power to the drive i can’t boot, with ide only it boots bur i can’t get the goddamn thing to work. I appreciate all you guys out there giving me tips on how to rescue my drive, but do you think this MF is just not rescueable. I’m pissed because this all happened when I went to the update site that the drive recommends (drvupdate.com) and it all goes bad. I’ve contacted the retailer and they are saying it’s not their problem. This drive is 2 weeks old, what do you think guys is this drive dead or what?


#11

i think you should be able to recover the drive.

try to boot up under dos, with connected power supply and disconnected ide cable.
set the drive to master and disconnect the master master drive, when you only connect the drive after the dos boot, is the drive on slave and there are no drivers for the slave drive loaded. you hve to change the drive with the master!!! then should you always able to flash.

when the drive is not flashable contact btc support, i´m sure that they change the drive to a new one. they did this also for me without any troubles


#12

How happy am I? Right this is how it went when I figured out what I was doing. Downloaded mtk180.zip and rcp1v758.bin from Dangerous Brothers. Unzipped them to 1008 folder in c: Got a boot disk from http://www.bootdisk.com/ . Got NTFSdos.exe and added it to the boot disk. Now I’ve made my DVD-RW 1008IB secondary master and disconnected the ide whilst connecting the power cable and also disconnecting my basic cd rom drive. Next I’ve booted up with the boot disk, gone to dos and then connected the ide cable(the power was already connected) I’ve then gone d: cd 1008 then mtkflash 3 w /m /b rpc1v758.bin and the rest is history. Like i said at the start, how happy am I? Ex Fu###ng static. Big thanx to H3rB31 and darklock for the input, I wouldn’t have got there without you guys. NEXT QUESTION: Can I now go to drvupdate again and update to the latest firmware or should i stick with 0758?


#13

Sorry inbetween the booting to dos and going d: I ran ntfsdos.exe.


#14

there is no problem to go to the latest fw.

p.s . good to hear that you got your drive back alive


#15

Thanx Mate


#16

Use the firmware for the 1008UI and enjoy! The problem is that some motherboards are too advanced for the software to upgrade the FW of the devices. I’ve a 1008IB and i couldn’t update my firmware 'cos the software didn’t find my drive!
I tried the version for USB devices and… that’s it!


#17

Just updated to 1008UI 0059 firmware and all is good!! I was having major problems burning. I’ve got Roxio Easy Media 7 installed and I’ll report back if I have more luck with this firmware. Any burning software recommendations? Tried Nero and Roxio! Also are their any specific cd-r dvd-r’s that work better with these drives? All info gratfully received.