Dvd-rom - JLMS XJ 166s - suddenly not working

vbimport

#1

I’m running Windows 2000 and have a LiteOn JLMS XJ-HD 166S 16x/48x dvd-rom drive that has suddenly stopped working. It won’t recognize any discs (cd, dvd, or otherwise), but there doesn’t seem to be a problem with my computer recognizing the drive itself (I get a continuous error: “No disc inserted” etc). I use CyberLink Power DVD 4 and I ran a diagnostic on the dvd-rom via that program. I also installed what I think may have been a driver update from the JLMS website, as well as a patch from the CyberLink site. I even tried to use a cd-rom lens cleaner - it wouldn’t even recognize that. I’m stumped! Is there anything else I can do (other drivers, other diagnostics, anything?) besides trash the thing? It’s only a year old. I hate to fork out the money for another one already. Ugh.


#2

@ anesthezea
Welcome:). What firmware does your drive have. You could flash the latest version available(or was that your ‘driver update’). You could also try deleting the IDE channel the drive resides on and reboot to let windows re-detect your drive. That has been known to work. You could also try switching it from master to slave or slave to master. If these fail, you could try your drive in another system to see if it works there.


#3

You also could try to boot from a bootable disk, after enabling CD boot in your bios settings, to check if the problem is hardware or windows related.


#4

New here, and having the same problem. Not experienced with all of the technical stuff but am learning fast since my warranties have expired recently. How do I delete the ide channel? Sorry if I sound like an idiot. Thanks in advance.


#5

First make an image backup of your system partition. To delete the ide channel, open device manager, find the channel in the ide controller tree, right click on it and select deinstall (might be remove).